Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [Teneo]Failure to persist a reference (to subclass)
[Teneo]Failure to persist a reference (to subclass) [message #605347] Mon, 07 May 2007 19:24
Michael Kanaley is currently offline Michael KanaleyFriend
Messages: 89
Registered: July 2009
Member
Hello,
Attached is a plugin demonstrating the problem with a simple model.
There are model objects for Book and Author.
A ScifiBook (subclass of book) has 0 or more Authors (non-containment
reference) associated with it.

In the TestSaveref JUnit test, I create two ScifiBooks and one ForeignAuthor
(subclass of Author). I associate the ForeignAuthor with both of the
ScifiBooks. When I retry to reload the model, one of the ScifiBooks fails to
retrieve its reference. Test output looks like:

junit.framework.AssertionFailedError: Book "The Name of the Rose" has
incorrect number of authors. expected:<1> but was:<0>

Any ideas why? Any workarounds (potential model changes ok)?

Thanks,
-mike


Previous Topic:[teneo-jpox] jdoDatastore initialize failed on with mulitple ecores
Next Topic:[Teneo]Failure to persist a reference (to subclass)
Goto Forum:
  


Current Time: Tue Jan 19 23:00:29 GMT 2021

Powered by FUDForum. Page generated in 0.02194 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top