Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [Teneo] invalid Mapping Error / SAXParserException
[Teneo] invalid Mapping Error / SAXParserException [message #604894] Thu, 19 April 2007 17:14
Christian Neudert is currently offline Christian NeudertFriend
Messages: 13
Registered: July 2009
Junior Member
Hi, im trying to migrate from eclipse 3.2 to 3.3 including the stepup to
Teneo 0.8. But since this change its imposible for me to generate a
mapping file. It always ends with following error:

Caused by: org.xml.sax.SAXParseException:
The content of element type "list" must match
(meta*,subselect?,cache?,synchronize*,comment?,key,
(index|list-index),(element|one-to-many|many-to-many|composi te-element|many-to-any),loader?,sql-insert?,sql-update?,sql- delete?,sql-delete-all?,filter*) ".

at org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseExc eption
(Unknown Source)
at org.apache.xerces.util.ErrorHandlerWrapper.error(Unknown Source)
at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
at org.apache.xerces.impl.dtd.XMLDTDValidator.handleEndElement( Unknown
Source)
at org.apache.xerces.impl.dtd.XMLDTDValidator.endElement(Unknow n Source)
at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanEndEleme nt
(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$
FragmentContentDispatcher.dispatch(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDo cument
(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
at org.dom4j.io.SAXReader.read(SAXReader.java:465)
at org.dom4j.io.SAXReader.read(SAXReader.java:365)
at org.hibernate.cfg.Configuration.addXML(Configuration.java:43 5)

My runtime for Teneo 0.8 was eclipse 3.3 EMF 2.3 v20070329... and
Hibernate 3.2.2 ga . I've also tested it in eclipse 3.2.2 with EMF 2.2
v20060627... with the same error message.
I also tried to reload the model and IGNORE_EANNOTATIONS but after both
the error still occurs.
It seems to be a Teneo 0.8 problem, because after the switch back to
0.75 everything works fine.

Thanks in advance for any kind of help.
Christian
Previous Topic:[Teneo]Problem Persisting GMF diagram to HibernateResource
Next Topic:[Teneo] invalid Mapping Error / SAXParserException
Goto Forum:
  


Current Time: Tue Jan 19 22:25:00 GMT 2021

Powered by FUDForum. Page generated in 0.02184 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top