Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Building with Java 1.5 and 1.6 in the same workspace
Building with Java 1.5 and 1.6 in the same workspace [message #603215] Thu, 12 November 2009 22:53
Stephen McCants is currently offline Stephen McCantsFriend
Messages: 92
Registered: July 2009
Member
Hello,
I have a large set of Java plugin projects. Some of them need to be built on Java 1.5 (they will
be run under Java 1.5 in an environment I can't completely control), while most would be best built
on Java 1.6. I have both JVM's in Properties->Installed JREs, with 1.6 as the default (also the
default compliance level). Then on the project that needs 1.5, I switched the compliance level to
1.5 and set the build path to use the 1.5 JRE System Library. However, it is still being built to
Java 1.6 and fails with this exception:

java.lang.UnsupportedClassVersionError: (com/ibm/hdwb/util/common/http/atom/QueryResult) bad major
version at offset=6

What additional properties do I need to change to get it to build with Java 1.5?
Thanks in advance!

Sincerely,
Stephen McCants
Previous Topic:EclipseGenerator and categories
Next Topic:Manifest Editor and Handler/Command TreeNode Labels in ExtensionPage
Goto Forum:
  


Current Time: Sat Aug 08 17:18:04 GMT 2020

Powered by FUDForum. Page generated in 0.01952 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top