Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Error in exported product log
Error in exported product log [message #595967] Tue, 21 April 2009 13:47
Maurice O'Connor is currently offline Maurice O'ConnorFriend
Messages: 86
Registered: July 2009
Member
Hi!

This is x-posted from .equinox, in the hope that you guys might know more
:)

I'm seeing this error in the log of my exported product:

java.io.IOException: Unable to initialize osgi.frameworkClassPath
at org.eclipse.core.launcher.Main.addBaseJars(Main.java:567)
at org.eclipse.core.launcher.Main.getDevPath(Main.java:466)

I solved it using the solution given here:

http://dev.eclipse.org/newslists/news.eclipse.platform.rcp/m sg12468.html

It says:

- Copy the org.eclipse.osgi_vernum.jar from the
plugins/org.eclipse.osgi_vernum directory to the plugins directory
- Delete the org.eclipse.osgi_vernum directory
- Launch the application

So this has solved my problem, but I haven't figured out _why_ I need to
do this. Is there something I can do to prevent it on the Eclipse GUI
side, so it doesn't happen if I'm exporting to a new product?

Thanks!

Maurice
Previous Topic:Retrieving fully qualified names of method and field signatures.
Next Topic:Product configuration on other platforms
Goto Forum:
  


Current Time: Mon Sep 26 03:33:54 GMT 2022

Powered by FUDForum. Page generated in 0.01590 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top