Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » pde.exportPlugins failed with class not found
pde.exportPlugins failed with class not found [message #586525] Fri, 05 December 2008 14:47
VincentL is currently offline VincentLFriend
Messages: 88
Registered: July 2009
Member
Hi all,

I have the following error when I build my plugin with ant script and the
pde.exportPlugins ant task.

build.xml:31: Type pde.exportPlugins: A class needed by class class
org.eclipse.pde.internal.core.ant.PluginExportTask cannot be found:
org/eclipse/core/resources/IWorkspaceRunnable

Any idea or suggestions?
Thanks
Vincent


Here is my script:

<?xml version="1.0" encoding="UTF-8"?>
<project name="opbuild" default="plugin_export" basedir="." >
<target name="plugin_export">


<condition property="builddir" value="${rootdir}">
<isset property="rootdir" />
</condition>

<property name="builddir" value="tmp"/>
<property name="pluginName" value="com.opalrt.livelab.datamodel"/>


<pde.exportPlugins destination="${builddir}\\eclipse" exportSource="false"
exportType="directory" filename="file.zip" plugins="${pluginName}" useJARFormat="true"/>

</target>

</project>
Previous Topic:pde.exportPlugins failed with class not found
Next Topic:Multiple versions of library wrapper plugins
Goto Forum:
  


Current Time: Tue Aug 03 05:39:05 GMT 2021

Powered by FUDForum. Page generated in 0.02196 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top