Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » PDE build issues with multiple platforms
PDE build issues with multiple platforms [message #58704] Mon, 27 April 2009 22:12 Go to next message
Frank Du is currently offline Frank DuFriend
Messages: 91
Registered: July 2009
Member
Hi, All,

I encountered a build issue with multiple platforms. We have a feature
which has platform specific fragments, such as:

org.eclipse.core.filesystem.macosx
org.eclipse.core.filesystem.win32.x86

Both has set proper "Operating System" and "Architecture" information.

Then we created an update site, and include the feature. The problem is
that update site "Build" action doesn't include publish any macosx
plug-ins, just win32.x86 specific plug-ins. Therefore, the update site
works fine with Win32 program, but doesn't work with macosx program.

We do the Build inside eclipse on a Windows XP computer. Is there any
further setting needed to make it work?

Thank you so much in advance! Have a great day!

Best Regards,
Frank Du
Re: PDE build issues with multiple platforms [message #58857 is a reply to message #58704] Wed, 29 April 2009 18:17 Go to previous message
Andrew Niefer is currently offline Andrew NieferFriend
Messages: 990
Registered: July 2009
Senior Member
The update site build in the workspace only does one platform at a time.
You can do multiple platforms if you set up a headless build.

You could also try building the update site, go to the target platform
preferences and change the target to be a different environment, then
build the update site again.

-Andrew

Frank Du wrote:
> Hi, All,
>
> I encountered a build issue with multiple platforms. We have a feature
> which has platform specific fragments, such as:
>
> org.eclipse.core.filesystem.macosx
> org.eclipse.core.filesystem.win32.x86
>
> Both has set proper "Operating System" and "Architecture" information.
> Then we created an update site, and include the feature. The problem is
> that update site "Build" action doesn't include publish any macosx
> plug-ins, just win32.x86 specific plug-ins. Therefore, the update site
> works fine with Win32 program, but doesn't work with macosx program.
>
> We do the Build inside eclipse on a Windows XP computer. Is there any
> further setting needed to make it work?
> Thank you so much in advance! Have a great day!
>
> Best Regards,
> Frank Du
>
Re: PDE build issues with multiple platforms [message #596515 is a reply to message #58704] Wed, 29 April 2009 18:17 Go to previous message
Andrew Niefer is currently offline Andrew NieferFriend
Messages: 990
Registered: July 2009
Senior Member
The update site build in the workspace only does one platform at a time.
You can do multiple platforms if you set up a headless build.

You could also try building the update site, go to the target platform
preferences and change the target to be a different environment, then
build the update site again.

-Andrew

Frank Du wrote:
> Hi, All,
>
> I encountered a build issue with multiple platforms. We have a feature
> which has platform specific fragments, such as:
>
> org.eclipse.core.filesystem.macosx
> org.eclipse.core.filesystem.win32.x86
>
> Both has set proper "Operating System" and "Architecture" information.
> Then we created an update site, and include the feature. The problem is
> that update site "Build" action doesn't include publish any macosx
> plug-ins, just win32.x86 specific plug-ins. Therefore, the update site
> works fine with Win32 program, but doesn't work with macosx program.
>
> We do the Build inside eclipse on a Windows XP computer. Is there any
> further setting needed to make it work?
> Thank you so much in advance! Have a great day!
>
> Best Regards,
> Frank Du
>
Previous Topic:JAR a feature from PDE
Next Topic:Do we need different update sites for Windows and MacOSX?
Goto Forum:
  


Current Time: Sat Jun 19 16:47:11 GMT 2021

Powered by FUDForum. Page generated in 0.01634 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top