Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IAM (Eclipse Integration for Apache Maven) » Classpath container suddenly vanished and I cannot get it back
Classpath container suddenly vanished and I cannot get it back [message #569074] Thu, 21 May 2009 00:05
BenH is currently offline BenHFriend
Messages: 39
Registered: July 2009
Member
Classpath container suddenly vanished and I cannot get it back. Ie, my
project has no dependencies in its classpath and thus every source file
has errors.

The change happened immediately after made a change to my pom.xml that was
invalid according to the schema (leaving out 'version' of a dependency).

Since then, I have Re-Enabled "Maven Dependency Management", Re-Installed
the IAM 0.9 plugin, and Deleted and Imported my project again, but the
issue remains.

This effectively renders me unable to proceed using the plugin, so unless
I can quickly find a workaround, Im going to have to install m2eclipse to
keep working while I get this resolved.

I have looked in Error Log view and do not see anything that seems related
to it.

One thing I did notice is double entries in .project and .classpath:

<nature>org.devzuz.q.maven.jdt.core.mavenNature</nature>
<nature>org.eclipse.iam.jdt.core.mavenNature</nature>

<classpathentry kind="con"
path="org.eclipse.iam.jdt.core.mavenClasspathContainer"/>
<classpathentry kind="con"
path="org.devzuz.q.maven.jdt.core.mavenClasspathContainer"/ >

-Ben
Previous Topic:IAM doesnt run surefire-report:report correctly
Next Topic:IAM looking for Java tools in wrong place?
Goto Forum:
  


Current Time: Wed Nov 14 05:33:41 GMT 2018

Powered by FUDForum. Page generated in 0.02382 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top