Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Java Workflow Tooling » Can't install JWT on a fresh version of eclipse
Can't install JWT on a fresh version of eclipse [message #552577] Thu, 12 August 2010 16:57 Go to next message
Darwin is currently offline DarwinFriend
Messages: 4
Registered: July 2009
Junior Member
I'm trying to install JWT with the eclipse updater from the p2 servers. Since I was having trouble, I decided to do it on a fresh install of eclipse.

I resolved the dependencies by adding the ATL and GEF sites and it looked like all the dependencies were resolved, but when it was mostly done with installation, it gave me this the following error:

Quote:
OK
Cannot complete the install because one or more required items could not be found.
Software currently installed: Java Workflow Tooling 1.0.0.v20100719-0900-7N--FJdMh0gj33jLjjgg (org.eclipse.jwt.feature.feature.group 1.0.0.v20100719-0900-7N--FJdMh0gj33jLjjgg)
Missing requirement: ATL Parser and Compiler 3.1.0.v201006150240 (org.eclipse.m2m.atl.engine 3.1.0.v201006150240) requires 'bundle org.eclipse.m2m.atl.common 0.0.0' but it could not be found
Cannot satisfy dependency:
From: Java Workflow Tooling 1.0.0.v20100719-0900-7N--FJdMh0gj33jLjjgg (org.eclipse.jwt.feature.feature.group 1.0.0.v20100719-0900-7N--FJdMh0gj33jLjjgg)
To: org.eclipse.m2m.atl.engine 3.0.0


I am running Windows 7 32 bit with the Java EE IDE Helios version of eclipse.

Most of the installation guides are out of date. So I was going blind.

I tried to install it by adding the following sites:

http://download.eclipse.org/tools/gef/updates/releases/
http://download.eclipse.org/modeling/m2m/updates/site.xml
http://download.eclipse.org/jwt/update-site/

And then selecting "JWT 1.0.0 R20100719-0900" to install.

Any help is appreciated.
Re: Can't install JWT on a fresh version of eclipse [message #553085 is a reply to message #552577] Mon, 16 August 2010 12:16 Go to previous messageGo to next message
Marc Dutoo is currently offline Marc DutooFriend
Messages: 71
Registered: July 2009
Member
Hi Darwin

That's strange, I'll have a look at it.

Did you already read http://wiki.eclipse.org/JWT_SVN , which documents
dependencies ?

Regards,
Marc

Darwin a écrit :
> I'm trying to install JWT with the eclipse updater from the p2 servers.
> Since I was having trouble, I decided to do it on a fresh install of
> eclipse.
>
> I resolved the dependencies by adding the ATL and GEF sites and it
> looked like all the dependencies were resolved, but when it was mostly
> done with installation, it gave me this the following error:
>
> Quote:
>> OK
>> Cannot complete the install because one or more required items could
>> not be found.
>> Software currently installed: Java Workflow Tooling
>> 1.0.0.v20100719-0900-7N--FJdMh0gj33jLjjgg
>> (org.eclipse.jwt.feature.feature.group
>> 1.0.0.v20100719-0900-7N--FJdMh0gj33jLjjgg)
>> Missing requirement: ATL Parser and Compiler 3.1.0.v201006150240
>> (org.eclipse.m2m.atl.engine 3.1.0.v201006150240) requires 'bundle
>> org.eclipse.m2m.atl.common 0.0.0' but it could not be found
>> Cannot satisfy dependency:
>> From: Java Workflow Tooling 1.0.0.v20100719-0900-7N--FJdMh0gj33jLjjgg
>> (org.eclipse.jwt.feature.feature.group
>> 1.0.0.v20100719-0900-7N--FJdMh0gj33jLjjgg)
>> To: org.eclipse.m2m.atl.engine 3.0.0
>
>
> I am running Windows 7 32 bit with the Java EE IDE Helios version of
> eclipse.
>
> Most of the installation guides are out of date. So I was going blind.
>
> I tried to install it by adding the following sites:
>
> http://download.eclipse.org/tools/gef/updates/releases/
> http://download.eclipse.org/modeling/m2m/updates/site.xml
> http://download.eclipse.org/jwt/update-site/
>
> And then selecting "JWT 1.0.0 R20100719-0900" to install.
>
> Any help is appreciated.
Re: Can't install JWT on a fresh version of eclipse [message #553108 is a reply to message #552577] Mon, 16 August 2010 13:40 Go to previous message
Darwin is currently offline DarwinFriend
Messages: 4
Registered: July 2009
Junior Member
Thanks for the link.

I was able to get it to install without errors eventually without the above dependency link.I believe what made the difference was manually installing the m2m package first.

So there does seem to be some dependency issues that don't get identified before installation.
Previous Topic:Welcome to eclipse.jwt
Next Topic:Can't install JWT on a fresh version of eclipse
Goto Forum:
  


Current Time: Mon Dec 11 23:00:44 GMT 2017

Powered by FUDForum. Page generated in 0.01648 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software