Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Project Open event not getting fired - wrong flag for IResourceDelta.getFlags()(In a particular case of project, wrong event/flag being fired for the Resource Change Listener and hence my project open action is not getting triggered)
Project Open event not getting fired - wrong flag for IResourceDelta.getFlags() [message #551469] Fri, 06 August 2010 14:42
Rahul Kamdar is currently offline Rahul KamdarFriend
Messages: 63
Registered: July 2009
Member
I'll first provide a brief description of my code:

After each project open (POST_BUILD) I need to run some code so I have added my Resource Change Listener. The resource delta is filtered to be checked only if:

1] resourceDelta.getResource is a project
2] resourceDelta.getFlags() == iResourceDelta.OPEN
3] if project.isOpen()

This works as expected for all cases except for one case that I have encountered now.

I have a project checked out from a Serena Dimensions CM Repository (Team / RCS). This project when closed and re-opened, *only* in this first project close-reopen the event fired and checked results in resourceDelta.getFlags() = 81920.

If I close the project again and reopen it the problem doesn't occur, the right events are fired.

I have spent a good amount of time trying to figure out what's going different but no reason/solution identified yet. I'll appreciate any help/information.

The Eclipse version in question is 3.4. I checked the source code for Resource Delta and the value returned for getFlags = status & ~KIND_MASK. So the status for the 81920 returned value seems to be MOVED_TO while the values returned by resourceDelta.getMovedFromPath / resourceDelta.getMovedToPath = null.

Grateful for any pointers/help.
Previous Topic:How to customize menu and toolbar in RCP application
Next Topic:Target file ignored if timestamp changes
Goto Forum:
  


Current Time: Wed Oct 17 23:28:21 GMT 2018

Powered by FUDForum. Page generated in 0.01781 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top