Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » update SDK to 3.4.2 from 3.4.1
update SDK to 3.4.2 from 3.4.1 [message #55311] Wed, 15 April 2009 15:16
David  is currently offline David Friend
Messages: 88
Registered: July 2009
Member
Hello, we have an internally managed update site where we distribute
Eclipse 3.4.1

Version: 3.4.1
Build id: M20080911-1700

I need to update this update site to 3.4.2 + a ton of other external
plugins.

i updated one of my Eclipse clients to this version via
http://download.eclipse.org/eclipse/updates/3.4

i checked the Eclipse SDK and it got updated to

Version: 3.4.2
Build id: M20090211-1700

so far all is good!

I created a new updatesite project, added org.eclipse.sdk version
3.4.2.R342_v20090122-7O7S7GApJ3_vCyk7ETmsfcmjhz0eHnqw7MIjk9V dhe4Ic

pressed build to just test to install in an 3.4.1 client.

when trying to update the 3.4.1 client i get:

Cannot complete the request. See the details.
Eclipse Project SDK is already installed, so an update will be performed
instead.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.sdk.feature.jar/[3.4.2 .R342_v20090122-7O7S7GApJ3_vCyk7ETmsfcmjhz0eHnqw7MIjk9Vdhe4I c,3.4.2.R342_v20090122-7O7S7GApJ3_vCyk7ETmsfcmjhz0eHnqw7MIjk 9Vdhe4Ic]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.sdk.feature.jar/[3.4.1 .R34x_v20080827-7O7S78C2J40sK2o_ALcK8tLN_yZSJeg0P-3EtL4Ra90k v,3.4.1.R34x_v20080827-7O7S78C2J40sK2o_ALcK8tLN_yZSJeg0P-3Et L4Ra90kv]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.sdk/[3.4.2.v2009021117 00,3.4.2.v200902111700]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.sdk/[3.4.1.v2008091117 00,3.4.1.v200809111700]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.source.feature.jar /[3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI,3.4.2.r3 42_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.source.feature.jar /[3.4.1.r341_v20080709-0800-7o7tEAfEF_U5qyUgrb2HAp539P97,3.4 .1.r341_v20080709-0800-7o7tEAfEF_U5qyUgrb2HAp539P97]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.update.ui/[3.2.101.R34 x_v20081128,3.2.101.R34x_v20081128]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.update.ui/[3.2.100.v20 080318,3.2.100.v20080318]]
can be satisfied.
+2 more A4s of this.....etc

whats the right way to do this? i assume i am doing something wrong, but
after +3 days of looking at FAQs,reading up on P2, mirroring the entire
SDK site and still failing to create my own update site i think i need
some help :-)

is there an easy step by step instruction to do this? I guess i need to
add JDT, Eclipse platform and others as well?

thanks for any help!

/Dave
Previous Topic:Don't succeed to fetch bundles with p2IU
Next Topic:update SDK to 3.4.2 from 3.4.1
Goto Forum:
  


Current Time: Mon Jun 21 02:28:55 GMT 2021

Powered by FUDForum. Page generated in 0.01847 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top