Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » RCP headless build, launcher name
RCP headless build, launcher name [message #542007] Wed, 23 June 2010 14:08 Go to next message
No real name is currently offline No real nameFriend
Messages: 33
Registered: July 2009
Member
Hi all,

I am trying to set up a headless build for my rcp application. At the
beginning, I started with a simple example to get the build working and
finally I was able to build my rcp for multiple target platforms.

Now I am trying to further customize the product, but have some
problems. Whenever I set the 'Launcher name' in the .product file, the
launcher of the build rcp doesn't bring up the gui, but fails with the
error messages (and very long stack traces) listed at the end of this
post. Before I set the 'Launcher name', the created rcp works fine. Do I
have to include additional plugins to be able to use the 'Launcher
name'? Has someone else observed such a behaviour or perhaps a hint for
me, how to solve this problem?


Thanks a lot
Sebastian




!ENTRY org.eclipse.osgi 4 0 2010-06-23 15:49:48.598
!MESSAGE An error occurred while automatically activating bundle
org.eclipse.ui.workbench (74).
!STACK 0
org.osgi.framework.BundleException: The activator
org.eclipse.ui.internal.WorkbenchPlugin for bundle
org.eclipse.ui.workbench is invalid
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:157)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:751)
[...]
Root exception:
java.lang.NoClassDefFoundError: org/eclipse/swt/SWTError
at java.lang.Class.getDeclaredConstructors0(Native Method)
at java.lang.Class.privateGetDeclaredConstructors(Class.java:24 06)
[...]
!ENTRY org.eclipse.osgi 2 0 2010-06-23 15:49:48.681
!MESSAGE One or more bundles are not resolved because the following root
constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.681
!MESSAGE Bundle
initial@reference :file:plugins/org.eclipse.core.runtime.compatibility_3.2.0.v 20090413.jar/
was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime.compatibility 2 0 2010-06-23
15:49:48.682
!MESSAGE Missing required bundle
org.eclipse.update.configurator_[3.1.100,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.682
!MESSAGE Bundle
initial@reference :file:plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0 .200.v20090520/
was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2010-06-23
15:49:48.682
!MESSAGE Missing host org.eclipse.equinox.launcher_[1.0.0,1.1.0).

!ENTRY org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
!MESSAGE The following is a complete list of bundles which are not
resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
!MESSAGE Bundle
org.eclipse.core.filesystem.linux.x86_1.3.0.R35x_v20091203-1 235 [23] was
not resolved.
!SUBENTRY 2 org.eclipse.core.filesystem.linux.x86 2 0 2010-06-23
15:49:48.683
!MESSAGE Platform filter did not match: (& (osgi.os=linux) (osgi.arch=x86))
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
!MESSAGE Bundle org.eclipse.core.runtime.compatibility_3.2.0.v20090413
[28] was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime.compatibility 2 0 2010-06-23
15:49:48.683
!MESSAGE Missing required bundle
org.eclipse.update.configurator_[3.1.100,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
!MESSAGE Bundle
org.eclipse.equinox.launcher.gtk.linux.x86_1.0.200.v20090520 [46] was
not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2010-06-23
15:49:48.683
!MESSAGE Missing host org.eclipse.equinox.launcher_[1.0.0,1.1.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
!MESSAGE Bundle org.eclipse.swt.gtk.linux.x86_3.5.2.v3557f [65] was not
resolved.
!SUBENTRY 2 org.eclipse.swt.gtk.linux.x86 2 0 2010-06-23 15:49:48.684
!MESSAGE Platform filter did not match: (& (osgi.ws=gtk) (osgi.os=linux)
(osgi.arch=x86))
Re: RCP headless build, launcher name [message #542025 is a reply to message #542007] Wed, 23 June 2010 14:48 Go to previous messageGo to next message
Andrew Niefer is currently offline Andrew NieferFriend
Messages: 990
Registered: July 2009
Senior Member
The stack trace looks like the problem is that the swt fragment did not
resolve, which causes the NoClassDefFoundError for the workbench.

The fragment did not resolve because the platform filter didn't match.
Normally the error log prints out the command line used at the very
beginning and you should see the -os, -ws, -arch values there.

This looks a lot like other posts here where the problem is having
${target.os}, ${target.ws} and ${target.arch} in the eclipse.ini file.

However, I don't see how that is related to changing the name of the
launcher.

Sebastian Gebhardt wrote:

> Hi all,
>
> I am trying to set up a headless build for my rcp application. At the
> beginning, I started with a simple example to get the build working and
> finally I was able to build my rcp for multiple target platforms.
>
> Now I am trying to further customize the product, but have some
> problems. Whenever I set the 'Launcher name' in the .product file, the
> launcher of the build rcp doesn't bring up the gui, but fails with the
> error messages (and very long stack traces) listed at the end of this
> post. Before I set the 'Launcher name', the created rcp works fine. Do I
> have to include additional plugins to be able to use the 'Launcher
> name'? Has someone else observed such a behaviour or perhaps a hint for
> me, how to solve this problem?
>
>
> Thanks a lot
> Sebastian
>
>
>
>
> !ENTRY org.eclipse.osgi 4 0 2010-06-23 15:49:48.598
> !MESSAGE An error occurred while automatically activating bundle
> org.eclipse.ui.workbench (74).
> !STACK 0
> org.osgi.framework.BundleException: The activator
> org.eclipse.ui.internal.WorkbenchPlugin for bundle
> org.eclipse.ui.workbench is invalid
> at
>
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:157)
> at
>
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:751)
> [...]
> Root exception:
> java.lang.NoClassDefFoundError: org/eclipse/swt/SWTError
> at java.lang.Class.getDeclaredConstructors0(Native Method)
> at java.lang.Class.privateGetDeclaredConstructors(Class.java:24 06)
> [...]
> !ENTRY org.eclipse.osgi 2 0 2010-06-23 15:49:48.681
> !MESSAGE One or more bundles are not resolved because the following root
> constraints are not resolved:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.681
> !MESSAGE Bundle
>
initial@reference :file:plugins/org.eclipse.core.runtime.compatibility_3.2.0.v 20090413.jar/
> was not resolved.
> !SUBENTRY 2 org.eclipse.core.runtime.compatibility 2 0 2010-06-23
> 15:49:48.682
> !MESSAGE Missing required bundle
> org.eclipse.update.configurator_[3.1.100,4.0.0).
> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.682
> !MESSAGE Bundle
>
initial@reference :file:plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0 .200.v20090520/
> was not resolved.
> !SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2010-06-23
> 15:49:48.682
> !MESSAGE Missing host org.eclipse.equinox.launcher_[1.0.0,1.1.0).
>
> !ENTRY org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
> !MESSAGE The following is a complete list of bundles which are not
> resolved, see the prior log entry for the root cause if it exists:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
> !MESSAGE Bundle
> org.eclipse.core.filesystem.linux.x86_1.3.0.R35x_v20091203-1 235 [23] was
> not resolved.
> !SUBENTRY 2 org.eclipse.core.filesystem.linux.x86 2 0 2010-06-23
> 15:49:48.683
> !MESSAGE Platform filter did not match: (& (osgi.os=linux)
> (osgi.arch=x86)) !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
> !MESSAGE Bundle org.eclipse.core.runtime.compatibility_3.2.0.v20090413
> [28] was not resolved.
> !SUBENTRY 2 org.eclipse.core.runtime.compatibility 2 0 2010-06-23
> 15:49:48.683
> !MESSAGE Missing required bundle
> org.eclipse.update.configurator_[3.1.100,4.0.0).
> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
> !MESSAGE Bundle
> org.eclipse.equinox.launcher.gtk.linux.x86_1.0.200.v20090520 [46] was
> not resolved.
> !SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2010-06-23
> 15:49:48.683
> !MESSAGE Missing host org.eclipse.equinox.launcher_[1.0.0,1.1.0).
> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
> !MESSAGE Bundle org.eclipse.swt.gtk.linux.x86_3.5.2.v3557f [65] was not
> resolved.
> !SUBENTRY 2 org.eclipse.swt.gtk.linux.x86 2 0 2010-06-23 15:49:48.684
> !MESSAGE Platform filter did not match: (& (osgi.ws=gtk) (osgi.os=linux)
> (osgi.arch=x86))
Re: RCP headless build, launcher name [message #542168 is a reply to message #542025] Thu, 24 June 2010 06:26 Go to previous messageGo to next message
No real name is currently offline No real nameFriend
Messages: 33
Registered: July 2009
Member
Hi Andrew,

in fact, this seems to be the problem, thank you. I have -os
${target.os}, -ws ${target.ws} and -arch ${target.arch} in the
eclipse.ini file. The lines are also in my .product file as program
arguments for all platforms. But I never touched this option. Should I
remove this lines? What should be the proper content of the eclipse.ini?

On 23.06.2010 16:48, Andrew Niefer wrote:
> The stack trace looks like the problem is that the swt fragment did not
> resolve, which causes the NoClassDefFoundError for the workbench.
>
> The fragment did not resolve because the platform filter didn't match.
> Normally the error log prints out the command line used at the very
> beginning and you should see the -os, -ws, -arch values there.
>
> This looks a lot like other posts here where the problem is having
> ${target.os}, ${target.ws} and ${target.arch} in the eclipse.ini file.
>
> However, I don't see how that is related to changing the name of the
> launcher.
>
> Sebastian Gebhardt wrote:
>
>> Hi all,
>>
>> I am trying to set up a headless build for my rcp application. At the
>> beginning, I started with a simple example to get the build working and
>> finally I was able to build my rcp for multiple target platforms.
>>
>> Now I am trying to further customize the product, but have some
>> problems. Whenever I set the 'Launcher name' in the .product file, the
>> launcher of the build rcp doesn't bring up the gui, but fails with the
>> error messages (and very long stack traces) listed at the end of this
>> post. Before I set the 'Launcher name', the created rcp works fine. Do I
>> have to include additional plugins to be able to use the 'Launcher
>> name'? Has someone else observed such a behaviour or perhaps a hint for
>> me, how to solve this problem?
>>
>>
>> Thanks a lot
>> Sebastian
>>
>>
>>
>>
>> !ENTRY org.eclipse.osgi 4 0 2010-06-23 15:49:48.598
>> !MESSAGE An error occurred while automatically activating bundle
>> org.eclipse.ui.workbench (74).
>> !STACK 0
>> org.osgi.framework.BundleException: The activator
>> org.eclipse.ui.internal.WorkbenchPlugin for bundle
>> org.eclipse.ui.workbench is invalid
>> at
>>
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:157)
>> at
>>
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:751)
>> [...]
>> Root exception:
>> java.lang.NoClassDefFoundError: org/eclipse/swt/SWTError
>> at java.lang.Class.getDeclaredConstructors0(Native Method)
>> at java.lang.Class.privateGetDeclaredConstructors(Class.java:24 06)
>> [...]
>> !ENTRY org.eclipse.osgi 2 0 2010-06-23 15:49:48.681
>> !MESSAGE One or more bundles are not resolved because the following root
>> constraints are not resolved:
>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.681
>> !MESSAGE Bundle
>>
> initial@reference :file:plugins/org.eclipse.core.runtime.compatibility_3.2.0.v 20090413.jar/
>> was not resolved.
>> !SUBENTRY 2 org.eclipse.core.runtime.compatibility 2 0 2010-06-23
>> 15:49:48.682
>> !MESSAGE Missing required bundle
>> org.eclipse.update.configurator_[3.1.100,4.0.0).
>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.682
>> !MESSAGE Bundle
>>
> initial@reference :file:plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0 .200.v20090520/
>> was not resolved.
>> !SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2010-06-23
>> 15:49:48.682
>> !MESSAGE Missing host org.eclipse.equinox.launcher_[1.0.0,1.1.0).
>>
>> !ENTRY org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
>> !MESSAGE The following is a complete list of bundles which are not
>> resolved, see the prior log entry for the root cause if it exists:
>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
>> !MESSAGE Bundle
>> org.eclipse.core.filesystem.linux.x86_1.3.0.R35x_v20091203-1 235 [23] was
>> not resolved.
>> !SUBENTRY 2 org.eclipse.core.filesystem.linux.x86 2 0 2010-06-23
>> 15:49:48.683
>> !MESSAGE Platform filter did not match: (& (osgi.os=linux)
>> (osgi.arch=x86)) !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
>> !MESSAGE Bundle org.eclipse.core.runtime.compatibility_3.2.0.v20090413
>> [28] was not resolved.
>> !SUBENTRY 2 org.eclipse.core.runtime.compatibility 2 0 2010-06-23
>> 15:49:48.683
>> !MESSAGE Missing required bundle
>> org.eclipse.update.configurator_[3.1.100,4.0.0).
>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
>> !MESSAGE Bundle
>> org.eclipse.equinox.launcher.gtk.linux.x86_1.0.200.v20090520 [46] was
>> not resolved.
>> !SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2010-06-23
>> 15:49:48.683
>> !MESSAGE Missing host org.eclipse.equinox.launcher_[1.0.0,1.1.0).
>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
>> !MESSAGE Bundle org.eclipse.swt.gtk.linux.x86_3.5.2.v3557f [65] was not
>> resolved.
>> !SUBENTRY 2 org.eclipse.swt.gtk.linux.x86 2 0 2010-06-23 15:49:48.684
>> !MESSAGE Platform filter did not match: (& (osgi.ws=gtk) (osgi.os=linux)
>> (osgi.arch=x86))
>
Re: RCP headless build, launcher name [message #542365 is a reply to message #542168] Thu, 24 June 2010 15:26 Go to previous messageGo to next message
Andrew Niefer is currently offline Andrew NieferFriend
Messages: 990
Registered: July 2009
Senior Member
Yes you should remove those lines, this is bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=278598
It comes from initializing the .product file from a launch configuration.

The native launcher does not substiture for ${...}, any instances of that in
the .product file launcher arguments should probably be removed.

-Andrew
Sebastian Gebhardt wrote:

> Hi Andrew,
>
> in fact, this seems to be the problem, thank you. I have -os
> ${target.os}, -ws ${target.ws} and -arch ${target.arch} in the
> eclipse.ini file. The lines are also in my .product file as program
> arguments for all platforms. But I never touched this option. Should I
> remove this lines? What should be the proper content of the eclipse.ini?
>
> On 23.06.2010 16:48, Andrew Niefer wrote:
>> The stack trace looks like the problem is that the swt fragment did not
>> resolve, which causes the NoClassDefFoundError for the workbench.
>>
>> The fragment did not resolve because the platform filter didn't match.
>> Normally the error log prints out the command line used at the very
>> beginning and you should see the -os, -ws, -arch values there.
>>
>> This looks a lot like other posts here where the problem is having
>> ${target.os}, ${target.ws} and ${target.arch} in the eclipse.ini file.
>>
>> However, I don't see how that is related to changing the name of the
>> launcher.
>>
>> Sebastian Gebhardt wrote:
>>
>>> Hi all,
>>>
>>> I am trying to set up a headless build for my rcp application. At the
>>> beginning, I started with a simple example to get the build working and
>>> finally I was able to build my rcp for multiple target platforms.
>>>
>>> Now I am trying to further customize the product, but have some
>>> problems. Whenever I set the 'Launcher name' in the .product file, the
>>> launcher of the build rcp doesn't bring up the gui, but fails with the
>>> error messages (and very long stack traces) listed at the end of this
>>> post. Before I set the 'Launcher name', the created rcp works fine. Do I
>>> have to include additional plugins to be able to use the 'Launcher
>>> name'? Has someone else observed such a behaviour or perhaps a hint for
>>> me, how to solve this problem?
>>>
>>>
>>> Thanks a lot
>>> Sebastian
>>>
>>>
>>>
>>>
>>> !ENTRY org.eclipse.osgi 4 0 2010-06-23 15:49:48.598
>>> !MESSAGE An error occurred while automatically activating bundle
>>> org.eclipse.ui.workbench (74).
>>> !STACK 0
>>> org.osgi.framework.BundleException: The activator
>>> org.eclipse.ui.internal.WorkbenchPlugin for bundle
>>> org.eclipse.ui.workbench is invalid
>>> at
>>>
>>
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:157)
>>> at
>>>
>>
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:751)
>>> [...]
>>> Root exception:
>>> java.lang.NoClassDefFoundError: org/eclipse/swt/SWTError
>>> at java.lang.Class.getDeclaredConstructors0(Native Method)
>>> at
>>> java.lang.Class.privateGetDeclaredConstructors(Class.java:24 06)
>>> [...]
>>> !ENTRY org.eclipse.osgi 2 0 2010-06-23 15:49:48.681
>>> !MESSAGE One or more bundles are not resolved because the following root
>>> constraints are not resolved:
>>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.681
>>> !MESSAGE Bundle
>>>
>>
initial@reference :file:plugins/org.eclipse.core.runtime.compatibility_3.2.0.v 20090413.jar/
>>> was not resolved.
>>> !SUBENTRY 2 org.eclipse.core.runtime.compatibility 2 0 2010-06-23
>>> 15:49:48.682
>>> !MESSAGE Missing required bundle
>>> org.eclipse.update.configurator_[3.1.100,4.0.0).
>>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.682
>>> !MESSAGE Bundle
>>>
>>
initial@reference :file:plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0 .200.v20090520/
>>> was not resolved.
>>> !SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2010-06-23
>>> 15:49:48.682
>>> !MESSAGE Missing host org.eclipse.equinox.launcher_[1.0.0,1.1.0).
>>>
>>> !ENTRY org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
>>> !MESSAGE The following is a complete list of bundles which are not
>>> resolved, see the prior log entry for the root cause if it exists:
>>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
>>> !MESSAGE Bundle
>>> org.eclipse.core.filesystem.linux.x86_1.3.0.R35x_v20091203-1 235 [23] was
>>> not resolved.
>>> !SUBENTRY 2 org.eclipse.core.filesystem.linux.x86 2 0 2010-06-23
>>> 15:49:48.683
>>> !MESSAGE Platform filter did not match: (& (osgi.os=linux)
>>> (osgi.arch=x86)) !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23
>>> 15:49:48.683 !MESSAGE Bundle
>>> org.eclipse.core.runtime.compatibility_3.2.0.v20090413
>>> [28] was not resolved.
>>> !SUBENTRY 2 org.eclipse.core.runtime.compatibility 2 0 2010-06-23
>>> 15:49:48.683
>>> !MESSAGE Missing required bundle
>>> org.eclipse.update.configurator_[3.1.100,4.0.0).
>>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
>>> !MESSAGE Bundle
>>> org.eclipse.equinox.launcher.gtk.linux.x86_1.0.200.v20090520 [46] was
>>> not resolved.
>>> !SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2010-06-23
>>> 15:49:48.683
>>> !MESSAGE Missing host org.eclipse.equinox.launcher_[1.0.0,1.1.0).
>>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
>>> !MESSAGE Bundle org.eclipse.swt.gtk.linux.x86_3.5.2.v3557f [65] was not
>>> resolved.
>>> !SUBENTRY 2 org.eclipse.swt.gtk.linux.x86 2 0 2010-06-23 15:49:48.684
>>> !MESSAGE Platform filter did not match: (& (osgi.ws=gtk) (osgi.os=linux)
>>> (osgi.arch=x86))
>>
Re: RCP headless build, launcher name [message #542503 is a reply to message #542365] Fri, 25 June 2010 06:42 Go to previous message
No real name is currently offline No real nameFriend
Messages: 33
Registered: July 2009
Member
Ok, thanks for your help

On 24.06.2010 17:26, Andrew Niefer wrote:
> Yes you should remove those lines, this is bug
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=278598
> It comes from initializing the .product file from a launch configuration.
>
> The native launcher does not substiture for ${...}, any instances of that in
> the .product file launcher arguments should probably be removed.
>
> -Andrew
> Sebastian Gebhardt wrote:
>
>> Hi Andrew,
>>
>> in fact, this seems to be the problem, thank you. I have -os
>> ${target.os}, -ws ${target.ws} and -arch ${target.arch} in the
>> eclipse.ini file. The lines are also in my .product file as program
>> arguments for all platforms. But I never touched this option. Should I
>> remove this lines? What should be the proper content of the eclipse.ini?
>>
>> On 23.06.2010 16:48, Andrew Niefer wrote:
>>> The stack trace looks like the problem is that the swt fragment did not
>>> resolve, which causes the NoClassDefFoundError for the workbench.
>>>
>>> The fragment did not resolve because the platform filter didn't match.
>>> Normally the error log prints out the command line used at the very
>>> beginning and you should see the -os, -ws, -arch values there.
>>>
>>> This looks a lot like other posts here where the problem is having
>>> ${target.os}, ${target.ws} and ${target.arch} in the eclipse.ini file.
>>>
>>> However, I don't see how that is related to changing the name of the
>>> launcher.
>>>
>>> Sebastian Gebhardt wrote:
>>>
>>>> Hi all,
>>>>
>>>> I am trying to set up a headless build for my rcp application. At the
>>>> beginning, I started with a simple example to get the build working and
>>>> finally I was able to build my rcp for multiple target platforms.
>>>>
>>>> Now I am trying to further customize the product, but have some
>>>> problems. Whenever I set the 'Launcher name' in the .product file, the
>>>> launcher of the build rcp doesn't bring up the gui, but fails with the
>>>> error messages (and very long stack traces) listed at the end of this
>>>> post. Before I set the 'Launcher name', the created rcp works fine. Do I
>>>> have to include additional plugins to be able to use the 'Launcher
>>>> name'? Has someone else observed such a behaviour or perhaps a hint for
>>>> me, how to solve this problem?
>>>>
>>>>
>>>> Thanks a lot
>>>> Sebastian
>>>>
>>>>
>>>>
>>>>
>>>> !ENTRY org.eclipse.osgi 4 0 2010-06-23 15:49:48.598
>>>> !MESSAGE An error occurred while automatically activating bundle
>>>> org.eclipse.ui.workbench (74).
>>>> !STACK 0
>>>> org.osgi.framework.BundleException: The activator
>>>> org.eclipse.ui.internal.WorkbenchPlugin for bundle
>>>> org.eclipse.ui.workbench is invalid
>>>> at
>>>>
>>>
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:157)
>>>> at
>>>>
>>>
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:751)
>>>> [...]
>>>> Root exception:
>>>> java.lang.NoClassDefFoundError: org/eclipse/swt/SWTError
>>>> at java.lang.Class.getDeclaredConstructors0(Native Method)
>>>> at
>>>> java.lang.Class.privateGetDeclaredConstructors(Class.java:24 06)
>>>> [...]
>>>> !ENTRY org.eclipse.osgi 2 0 2010-06-23 15:49:48.681
>>>> !MESSAGE One or more bundles are not resolved because the following root
>>>> constraints are not resolved:
>>>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.681
>>>> !MESSAGE Bundle
>>>>
>>>
> initial@reference :file:plugins/org.eclipse.core.runtime.compatibility_3.2.0.v 20090413.jar/
>>>> was not resolved.
>>>> !SUBENTRY 2 org.eclipse.core.runtime.compatibility 2 0 2010-06-23
>>>> 15:49:48.682
>>>> !MESSAGE Missing required bundle
>>>> org.eclipse.update.configurator_[3.1.100,4.0.0).
>>>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.682
>>>> !MESSAGE Bundle
>>>>
>>>
> initial@reference :file:plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0 .200.v20090520/
>>>> was not resolved.
>>>> !SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2010-06-23
>>>> 15:49:48.682
>>>> !MESSAGE Missing host org.eclipse.equinox.launcher_[1.0.0,1.1.0).
>>>>
>>>> !ENTRY org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
>>>> !MESSAGE The following is a complete list of bundles which are not
>>>> resolved, see the prior log entry for the root cause if it exists:
>>>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
>>>> !MESSAGE Bundle
>>>> org.eclipse.core.filesystem.linux.x86_1.3.0.R35x_v20091203-1 235 [23] was
>>>> not resolved.
>>>> !SUBENTRY 2 org.eclipse.core.filesystem.linux.x86 2 0 2010-06-23
>>>> 15:49:48.683
>>>> !MESSAGE Platform filter did not match: (& (osgi.os=linux)
>>>> (osgi.arch=x86)) !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23
>>>> 15:49:48.683 !MESSAGE Bundle
>>>> org.eclipse.core.runtime.compatibility_3.2.0.v20090413
>>>> [28] was not resolved.
>>>> !SUBENTRY 2 org.eclipse.core.runtime.compatibility 2 0 2010-06-23
>>>> 15:49:48.683
>>>> !MESSAGE Missing required bundle
>>>> org.eclipse.update.configurator_[3.1.100,4.0.0).
>>>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
>>>> !MESSAGE Bundle
>>>> org.eclipse.equinox.launcher.gtk.linux.x86_1.0.200.v20090520 [46] was
>>>> not resolved.
>>>> !SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2010-06-23
>>>> 15:49:48.683
>>>> !MESSAGE Missing host org.eclipse.equinox.launcher_[1.0.0,1.1.0).
>>>> !SUBENTRY 1 org.eclipse.osgi 2 0 2010-06-23 15:49:48.683
>>>> !MESSAGE Bundle org.eclipse.swt.gtk.linux.x86_3.5.2.v3557f [65] was not
>>>> resolved.
>>>> !SUBENTRY 2 org.eclipse.swt.gtk.linux.x86 2 0 2010-06-23 15:49:48.684
>>>> !MESSAGE Platform filter did not match: (& (osgi.ws=gtk) (osgi.os=linux)
>>>> (osgi.arch=x86))
>>>
>
Previous Topic:Adding New tab to web browser in Eclipse
Next Topic:HandlerUtil.currentSelection returns null
Goto Forum:
  


Current Time: Sun Dec 05 21:53:07 GMT 2021

Powered by FUDForum. Page generated in 0.01559 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top