Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Service Component Architecture (SCA) Tools » Build SCA Tools from source
Build SCA Tools from source [message #536070] Wed, 26 May 2010 20:55 Go to next message
No real name is currently offline No real nameFriend
Messages: 4
Registered: May 2010
Junior Member
Hi

I am trying to build SCA tools based on the instructions at,

http://wiki.eclipse.org/STP/SCA_Component/SCA_Build

Trying to build using Site Map - Build All does nothing.

The Build All button is enabled, but selecting it does nothing. i don't see any errors or messages.

I checked out all the projects under ../org.eclipse.stp.sca-tools/org.eclipse.stp.sca/trunk/

Any pointers on what the issue might be or instructions to Build SCA Tools from source

Thanks
Nitya
Re: Build SCA Tools from source [message #536136 is a reply to message #536070] Thu, 27 May 2010 08:30 Go to previous messageGo to next message
Stephane Drapeau is currently offline Stephane DrapeauFriend
Messages: 199
Registered: July 2009
Senior Member
Hi Nitya,

Few hints:
- Do you have warnings in the feature.xml files?
- When you select a feature in the update site map, can you build it
using the button "Build"?
- Did you check out, in your workspace, all the directories that are
under trunk/ or did you check out all the projects that are under each
sub directories of trunk (trunk/plugins, trunk/features, trunk/samples,
....) ? Your workspace must contain projects named org.eclipse.stp.sca.*
(not a project named plugins, an other named features, ...).

Stephane Drapeau
Obeo

nitya.doraisamy@gmail.com a écrit :
> Hi
> I am trying to build SCA tools based on the instructions at,
>
> http://wiki.eclipse.org/STP/SCA_Component/SCA_Build
>
> Trying to build using Site Map - Build All does nothing.
>
> The Build All button is enabled, but selecting it does nothing. i don't
> see any errors or messages.
>
> I checked out all the projects under
> ../org.eclipse.stp.sca-tools/org.eclipse.stp.sca/trunk/
> Any pointers on what the issue might be or instructions to Build SCA
> Tools from source
>
> Thanks
> Nitya
>
Re: Build SCA Tools from source [message #536172 is a reply to message #536136] Thu, 27 May 2010 09:59 Go to previous messageGo to next message
Hugo A. Garcia is currently offline Hugo A. GarciaFriend
Messages: 258
Registered: July 2009
Senior Member
Hi

I ignored the warnings.

Works for me. Build successful. Tested installation from update site and
it works.

-H

On 05/27/2010 10:30 AM, Stephane Drapeau wrote:
> Hi Nitya,
>
> Few hints:
> - Do you have warnings in the feature.xml files?
> - When you select a feature in the update site map, can you build it
> using the button "Build"?
> - Did you check out, in your workspace, all the directories that are
> under trunk/ or did you check out all the projects that are under each
> sub directories of trunk (trunk/plugins, trunk/features, trunk/samples,
> ...) ? Your workspace must contain projects named org.eclipse.stp.sca.*
> (not a project named plugins, an other named features, ...).
>
> Stephane Drapeau
> Obeo
>
> nitya.doraisamy@gmail.com a écrit :
>> Hi
>> I am trying to build SCA tools based on the instructions at,
>>
>> http://wiki.eclipse.org/STP/SCA_Component/SCA_Build
>>
>> Trying to build using Site Map - Build All does nothing.
>>
>> The Build All button is enabled, but selecting it does nothing. i
>> don't see any errors or messages.
>>
>> I checked out all the projects under
>> ../org.eclipse.stp.sca-tools/org.eclipse.stp.sca/trunk/
>> Any pointers on what the issue might be or instructions to Build SCA
>> Tools from source
>>
>> Thanks
>> Nitya
>>
Re: Build SCA Tools from source [message #536601 is a reply to message #536070] Fri, 28 May 2010 20:20 Go to previous message
No real name is currently offline No real nameFriend
Messages: 4
Registered: May 2010
Junior Member
Thanks, I got it to build.

I was missing some projects in my workspace.

Nitya
Re: Build SCA Tools from source [message #577031 is a reply to message #536136] Thu, 27 May 2010 09:59 Go to previous message
Hugo A. Garcia is currently offline Hugo A. GarciaFriend
Messages: 258
Registered: July 2009
Senior Member
Hi

I ignored the warnings.

Works for me. Build successful. Tested installation from update site and
it works.

-H

On 05/27/2010 10:30 AM, Stephane Drapeau wrote:
> Hi Nitya,
>
> Few hints:
> - Do you have warnings in the feature.xml files?
> - When you select a feature in the update site map, can you build it
> using the button "Build"?
> - Did you check out, in your workspace, all the directories that are
> under trunk/ or did you check out all the projects that are under each
> sub directories of trunk (trunk/plugins, trunk/features, trunk/samples,
> ...) ? Your workspace must contain projects named org.eclipse.stp.sca.*
> (not a project named plugins, an other named features, ...).
>
> Stephane Drapeau
> Obeo
>
> nitya.doraisamy@gmail.com a écrit :
>> Hi
>> I am trying to build SCA tools based on the instructions at,
>>
>> http://wiki.eclipse.org/STP/SCA_Component/SCA_Build
>>
>> Trying to build using Site Map - Build All does nothing.
>>
>> The Build All button is enabled, but selecting it does nothing. i
>> don't see any errors or messages.
>>
>> I checked out all the projects under
>> ../org.eclipse.stp.sca-tools/org.eclipse.stp.sca/trunk/
>> Any pointers on what the issue might be or instructions to Build SCA
>> Tools from source
>>
>> Thanks
>> Nitya
>>
Previous Topic:customize the palette
Next Topic:Build SCA Tools from source
Goto Forum:
  


Current Time: Sat Sep 22 13:45:00 GMT 2018

Powered by FUDForum. Page generated in 0.01815 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top