Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » ServerTools (WTP) » Almost completed WTP Tutorials - Building and Running a Web Application(troubleshooting)
icon5.gif  Almost completed WTP Tutorials - Building and Running a Web Application [message #534097] Tue, 18 May 2010 02:54
derek winnicki is currently offline derek winnickiFriend
Messages: 2
Registered: May 2010
Junior Member
Hello everyone,

I did a lot of browsing around to try and solve my problem before posting here on the forum, so thank you for reading this. I recently began the WTP Tutorials - Building and Running a Web Application. It is the starting point for building and running a J2EE application. I did notice that the tutorial was written in 2004 so perhaps it is a little out of date for me to be working with. If you know of equivalent tutorials that deal with Eclipse Galileo, that might be the easiest solution to my problem.

Anyways, I will list the software versions I am using and then I will describe my problem.

Macbook Pro , Mac OSX 10.6.3
Eclipse Galileo
JDK soylatte16-i386-1.0.3
JOnAS 5.1.1 (for my server runtime and server)

I'm stuck on the very last step. I can start up my server using JOnAS and that works fine, but when I try to run my web app by doing "Run On Server..", nothing happens.
I also tried using my browser to access the web app. JOnAS spits this line out at the very end through the console when it's finished starting:

BaseWebContainerService.registerWar : War WTP-Tutorial-1.war available at the context /WTP-Tutorial-1.

it says its available at the context /WTP-Tutorial-1
in the WTP tutorial it says to enter this into your browser: "localhost:8080/tutorial/snoop"
that never worked for me, so I tried fiddling with it and still couldn't figure it out.
I also tried:

I figured that after I choose Run on Server from the WTP-Tutorial-1 folder that it would just appear in the web browser that comes with Eclipse.

Can anyone help me ? Thank you so much if you can.

Previous Topic:EclipseLink 2.0.2
Next Topic:'Updating JSP Index' has encountered a problem.
Goto Forum:

Current Time: Sat Mar 06 06:39:36 GMT 2021

Powered by FUDForum. Page generated in 0.01391 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top