Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Subversive 0.7.9 Released
Subversive 0.7.9 Released [message #533318] Thu, 13 May 2010 09:48 Go to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Dear Subversive Users,

We are glad to announce that Subversive 0.7.9.I20100512-1900 release has
been published and available for download at
http://www.eclipse.org/subversive web site.
SVN Team Provider update site:
http://download.eclipse.org/technology/subversive/0.7/update -site/
SVN Connectors update site:
http://community.polarion.com/projects/subversive/download/e clipse/2.0/update-site/

A complete changelog is available at:
http://www.eclipse.org/subversive/changelogs/releasenotes.tx t


Best Regards,
Subversive Team
Re: Subversive 0.7.9 Released [message #533342 is a reply to message #533318] Thu, 13 May 2010 13:22 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 129
Registered: July 2009
Senior Member
Quote:

Subversive requires JDK 1.5 or higher and supports following versions of Eclipse:
* 3.3 (tested with 3.3.2)
* 3.4 (tested with 3.4)


Eclipse 3.5 (galileo) is not supported ???
Re: Subversive 0.7.9 Released [message #533427 is a reply to message #533318] Thu, 13 May 2010 20:31 Go to previous messageGo to next message
David M. Karr is currently offline David M. KarrFriend
Messages: 537
Registered: July 2009
Senior Member
Installation of this set of updates is failing in my Eclipse 3.5.2 installation with the following:
--------------
An error occurred during the org.eclipse.equinox.internal.provisional.p2.engine.phases.Ch eckTrust phase.
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.pha ses.CheckTrust, operand=, action=).
One or more certificates rejected. Cannot proceed with installation.
--------------

When I step through the installation, I see one dialog that I don't believe I've ever seen while installing plugins, which is a "Selection Needed" dialog that asks me "Do you trust these certificates?". The cert is issued by "VeriSign\, Inc.", and it isn't expired. I clicked OK, and then immediately got this error dialog.
Re: Subversive 0.7.9 Released [message #533429 is a reply to message #533427] Thu, 13 May 2010 20:46 Go to previous messageGo to next message
David M. Karr is currently offline David M. KarrFriend
Messages: 537
Registered: July 2009
Senior Member
Oh. Duh. I suppose checking the checkbox for the certificate saying that I trust it would be useful. Smile

You'd think the process would be a little more intelligent, like telling me that I can't install the plugin if I don't check the checkbox.
Re: Subversive 0.7.9 Released [message #533440 is a reply to message #533429] Thu, 13 May 2010 22:05 Go to previous messageGo to next message
Stanimir Stamenkov is currently offline Stanimir StamenkovFriend
Messages: 254
Registered: July 2009
Senior Member
Thu, 13 May 2010 16:46:25 -0400, /David M. Karr/:

> Oh. Duh. I suppose checking the checkbox for the certificate saying that
> I trust it would be useful. :)
>
> You'd think the process would be a little more intelligent, like telling
> me that I can't install the plugin if I don't check the checkbox.

I get this certificate dialog using the 3.5.2 JEE package and if I'm
not mistaken not only while installing Subversive but with other
official Galileo packages, also. I don't get this with a bare 3.5.2
Platform Runtime which have my necessary Galileo packages installed
on top.

--
Stanimir
Re: Subversive 0.7.9 Released [message #533471 is a reply to message #533342] Fri, 14 May 2010 07:25 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello David,

Of course, Eclipse 3.5 and 3.6 are supported, I'll update changelog. Thanks.

> Quote:
>> Subversive requires JDK 1.5 or higher and supports following versions
>> of Eclipse:
>> * 3.3 (tested with 3.3.2)
>> * 3.4 (tested with 3.4)
>
> Eclipse 3.5 (galileo) is not supported ???


--
Best regards,
Igor Burilo
Re: Subversive 0.7.9 Released [message #533474 is a reply to message #533429] Fri, 14 May 2010 07:36 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello David,

Subversive doesn't require any certificates during installation, it's
some P2 issue.

> Oh. Duh. I suppose checking the checkbox for the certificate saying that
> I trust it would be useful. :)
>
> You'd think the process would be a little more intelligent, like telling
> me that I can't install the plugin if I don't check the checkbox.


--
Best regards,
Igor Burilo
Re: Subversive 0.7.9 Released [message #533484 is a reply to message #533318] Fri, 14 May 2010 08:44 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 129
Registered: July 2009
Senior Member
Hi!

Can all of you who posted here in this thread please tell how you replied?
- on the web : http://www.eclipse.org/forums/...
- over email
- NNTP
- other ?

This is to hunt down the cause of a bug, see:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=291441#c15


Thanks.
Re: Subversive 0.7.9 Released [message #533557 is a reply to message #533318] Fri, 14 May 2010 14:34 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 129
Registered: July 2009
Senior Member
I updated and now every time I start Eclipse (JEE 3.5.2) I get the SVN Connectop eselection dialog, where I select SVNKit 1.3.0.
Then installation fails with the message:

Cannot complete the request. See the error log for details.
"SVNKit 1.3.0 Implementation (Optional)" will be ignored because a newer version is already installed.
"Subversive SVN Connectors" will be ignored because a newer version is already installed.

I can only cancel the wizard.

If I try to use SVN functionality, I get an error:

org.eclipse.team.svn.core.operation.UnreportableException: Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are available or install and select pure Java Subversion connector from the plug-in connectors update site.
If connectors already installed then you can change the selected one at: Window->Preferences->Team->SVN->SVN Connector.
at org.eclipse.team.svn.core.extension.factory.ISVNConnectorFac tory$1.newInstance(ISVNConnectorFactory.java:105)
at org.eclipse.team.svn.core.svnstorage.SVNRepositoryLocation.n ewProxyInstance(SVNRepositoryLocation.java:750)
at org.eclipse.team.svn.core.svnstorage.SVNRepositoryLocation.a cquireSVNProxy(SVNRepositoryLocation.java:542)
at org.eclipse.team.svn.core.svnstorage.SVNRepositoryContainer. getChildren(SVNRepositoryContainer.java:77)


I checked and I have SVNKit 1.3.2 installed and also
Subversive SVN Connectors 2.2.2.I20100512-1900 org.polarion.eclipse.team.svn.connector.feature.group

I will now uninstall them and try again.

[Updated on: Fri, 14 May 2010 14:37]

Report message to a moderator

Re: Subversive 0.7.9 Released [message #533559 is a reply to message #533474] Fri, 14 May 2010 14:40 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 129
Registered: July 2009
Senior Member
Igor Burilo wrote on Fri, 14 May 2010 09:36
Hello David,

Subversive doesn't require any certificates during installation, it's
some P2 issue.

> Oh. Duh. I suppose checking the checkbox for the certificate saying that
> I trust it would be useful. Smile
>
> You'd think the process would be a little more intelligent, like telling
> me that I can't install the plugin if I don't check the checkbox.


I get a warning dialog about installing unsigned content.
With a click OK it continues.

Not sure if this is the same David reported.
Re: Subversive 0.7.9 Released [message #533560 is a reply to message #533557] Fri, 14 May 2010 14:44 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 129
Registered: July 2009
Senior Member
David Balažic wrote on Fri, 14 May 2010 16:34

I checked and I have SVNKit 1.3.2 installed and also
Subversive SVN Connectors 2.2.2.I20100512-1900 org.polarion.eclipse.team.svn.connector.feature.group

I will now uninstall them and try again.


That worked. I uninstalled those two, restarted Eclpse and again it showed the SVN connector dialog, I selected SVNKit 1.3.0* and it installed and works fine.

But!

If I click menu Help / Check for Updates, it finds and offers SVNKit 1.3.2 and Subversive SVN Connectors 2.2.2.I20100512-1900.
Is it safe to update?

This is all a bit confusing, I must admit.


* - (fixed typo: I installed SVNKit 1.3.0 , not 1.3.2. I fixed the text above)

[Updated on: Mon, 17 May 2010 08:26]

Report message to a moderator

Re: Subversive 0.7.9 Released [message #533812 is a reply to message #533557] Mon, 17 May 2010 07:42 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello David,

Could you please provide what Subversive, SVN Connectors version you
already have in Eclipse?
Please, try to completely unistall SVN Connectors.


> Can all of you who posted here in this thread please tell how you
> replied?
NNTP

> I updated and now every time I start Eclipse (JEE 3.5.2) I get the SVN
> Connectop eselection dialog, where I select SVNKit 1.3.0.
> Then installation fails with the message:
>
> Cannot complete the request. See the error log for details.
> "SVNKit 1.3.0 Implementation (Optional)" will be ignored because a newer
> version is already installed. "Subversive SVN Connectors" will be
> ignored because a newer version is already installed.
>
> I can only cancel the wizard.
>
> If I try to use SVN functionality, I get an error:
>
> org.eclipse.team.svn.core.operation.UnreportableException: Selected SVN
> connector library is not available or cannot be loaded.
> If you selected native JavaHL connector, please check if binaries are
> available or install and select pure Java Subversion connector from the
> plug-in connectors update site.
> If connectors already installed then you can change the selected one at:
> Window->Preferences->Team->SVN->SVN Connector.
> at org.eclipse.team.svn.core.extension.factory.ISVNConnectorFac
> tory$1.newInstance(ISVNConnectorFactory.java:105)
> at org.eclipse.team.svn.core.svnstorage.SVNRepositoryLocation.n
> ewProxyInstance(SVNRepositoryLocation.java:750)
> at org.eclipse.team.svn.core.svnstorage.SVNRepositoryLocation.a
> cquireSVNProxy(SVNRepositoryLocation.java:542)
> at org.eclipse.team.svn.core.svnstorage.SVNRepositoryContainer.
> getChildren(SVNRepositoryContainer.java:77)


--
Best regards,
Igor Burilo
Re: Subversive 0.7.9 Released [message #533813 is a reply to message #533560] Mon, 17 May 2010 07:47 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello David,

SVN Connectors 2.2.2.I20100512-1900 is latest connectors version from
release. But it's strange that you are proposed to install SVN
Connectors 2.2.2.I20100512-1900 in Menu/Check For Updates if you already
have this version.

> David Balažic wrote on Fri, 14 May 2010 16:34
>> I checked and I have SVNKit 1.3.2 installed and also
>> Subversive SVN Connectors 2.2.2.I20100512-1900
>> org.polarion.eclipse.team.svn.connector.feature.group
>>
>> I will now uninstall them and try again.
>
>
> That worked. I uninstalled those two, restarted Eclpse and again it
> showed the SVN connector dialog, I selected SVNKit 1.3.2 and it
> installed and works fine.
>
> But!
>
> If I click menu Help / Check for Updates, it finds and offers SVNKit
> 1.3.2 and Subversive SVN Connectors 2.2.2.I20100512-1900.
> Is it safe to update?
>
> This is all a bit confusing, I must admit.


--
Best regards,
Igor Burilo
Re: Subversive 0.7.9 Released [message #533821 is a reply to message #533318] Mon, 17 May 2010 08:23 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 129
Registered: July 2009
Senior Member
I guess you misread.

- first I had SVNKit 1.3.2
It did not work
- then I uninstalled it (SVNKit 1.3.2)

- then I installed SVNKit 1.3.0

That works.

But now when I do Find updates, it finds and offers SVNKit 1.3.2.


But as I had it before and did not work, I don't know if I should accept the offered update or not.
Re: Subversive 0.7.9 Released [message #533823 is a reply to message #533318] Mon, 17 May 2010 08:28 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 129
Registered: July 2009
Senior Member
Just to note, in the older message, I said that I installed SVNKit 1.3.2.

That was a typo. I actually selected and installed v1.3.0. (I edited the message on the forum now)

Sorry about that.

(my last message before this one has the versions correctly)

[Updated on: Mon, 17 May 2010 08:28]

Report message to a moderator

Re: Subversive 0.7.9 Released [message #534281 is a reply to message #533318] Tue, 18 May 2010 14:49 Go to previous messageGo to next message
Andreas Schoeneck is currently offline Andreas SchoeneckFriend
Messages: 22
Registered: July 2009
Junior Member
Galileo Update site doesn't provide an updated version of Subversive. So under normal circumstances only the connectors get updated.

Awkwardly, the most recent version of Subversive isn't willing to work together with these too new connectors.

What you need to do is to also update Subversive by manually entering the Update-Site URL from the first post

http://download.eclipse.org/technology/subversive/0.7/update -site/

and install the Subversive version from there (this will perform an update).

Hope this helps.

Regards
Andreas
Re: Subversive 0.7.9 Released [message #535049 is a reply to message #533823] Fri, 21 May 2010 07:50 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello David,

> I updated and now every time I start Eclipse (JEE 3.5.2) I get the
> SVN Connectop eselection dialog, where I select SVNKit 1.3.0.
> Then installation fails with the message:
When you have Subversive 0.7.9 installed then Connector Discovery dialog
has to propose to install SVN Kit 1.3.2 but not 1.3.0.
So, please check that you do have Subversive 0.7.9, and if not please,
update Subversive to 0.7.9 at first.


> Just to note, in the older message, I said that I installed SVNKit 1.3.2.
>
> That was a typo. I actually elected and installed v1.3.0. (I edited the
> message on the forum now)
>
> Sorry about that.
>
> (my last message before this one has the versions correctly)


--
Best regards,
Igor Burilo
Re: Subversive 0.7.9 Released [message #535052 is a reply to message #534281] Fri, 21 May 2010 07:54 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello Andreas,

We can't propogate latest Subversive release to galileo update site as
there're no more releases for Galileo. But latest Subversive release
will appear in Helios update site, until that you can get latest
Subversive from
http://download.eclipse.org/technology/subversive/0.7/update -site/ as
you wrote.

> Galileo Update site doesn't provide an updated version of Subversive. So
> under normal circumstances only the connectors get updated.
>
> Awkwardly, the most recent version of Subversive isn't willing to work
> together with these too new connectors.
>
> What you need to do is to also update Subversive by manually entering
> the Update-Site URL from the first post
>
> http://download.eclipse.org/technology/subversive/0.7/update -site/
>
> and install the Subversive version from there (this will perform an
> update).
>
> Hope this helps.
>
> Regards
> Andreas


--
Best regards,
Igor Burilo
Re: Subversive 0.7.9 Released [message #535064 is a reply to message #535049] Fri, 21 May 2010 08:24 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 129
Registered: July 2009
Senior Member
Igor Burilo wrote on Fri, 21 May 2010 09:50
Hello David,

> I updated and now every time I start Eclipse (JEE 3.5.2) I get the
> SVN Connectop eselection dialog, where I select SVNKit 1.3.0.
> Then installation fails with the message:
When you have Subversive 0.7.9 installed then Connector Discovery dialog
has to propose to install SVN Kit 1.3.2 but not 1.3.0.
So, please check that you do have Subversive 0.7.9, and if not please,
update Subversive to 0.7.9 at first.


I have 0.7.8.

Strange,I was 100% I installed the latest version.

Sorry for confusing information.

PS: Can you answer my question about the way you post here?
(in regards to https://bugs.eclipse.org/bugs/show_bug.cgi?id=291441#c15 )
Re: Subversive 0.7.9 Released [message #535680 is a reply to message #535064] Tue, 25 May 2010 09:00 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello David,

> PS: Can you answer my question about the way you post here?
> (in regards to https://bugs.eclipse.org/bugs/show_bug.cgi?id=291441#c15 )
I already answered, anyway I'm using Mozilla Thunderbird, NNTP. Or
should I answer directly in bug?


> Igor Burilo wrote on Fri, 21 May 2010 09:50
>> Hello David,
>>
>> > I updated and now every time I start Eclipse (JEE 3.5.2) I get the
>> > SVN Connectop eselection dialog, where I select SVNKit 1.3.0.
>> > Then installation fails with the message:
>> When you have Subversive 0.7.9 installed then Connector Discovery
>> dialog has to propose to install SVN Kit 1.3.2 but not 1.3.0.
>> So, please check that you do have Subversive 0.7.9, and if not please,
>> update Subversive to 0.7.9 at first.
>
> I have 0.7.8.
>
> Strange,I was 100% I installed the latest version.
>
> Sorry for confusing information.
>
> PS: Can you answer my question about the way you post here?
> (in regards to https://bugs.eclipse.org/bugs/show_bug.cgi?id=291441#c15 )


--
Best regards,
Igor Burilo
Re: Subversive 0.7.9 Released [message #535730 is a reply to message #535680] Tue, 25 May 2010 12:42 Go to previous messageGo to next message
David  Balažic is currently offline David BalažicFriend
Messages: 129
Registered: July 2009
Senior Member
Oh, sorry, I did not notice.
Re: Subversive 0.7.9 Released [message #537435 is a reply to message #533318] Wed, 02 June 2010 12:50 Go to previous messageGo to next message
Alexander Malic is currently offline Alexander MalicFriend
Messages: 29
Registered: July 2009
Junior Member
works very well (i can "tag" again).

my question is, why isn't it published into the default galileo-update site?
Re: Subversive 0.7.9 Released [message #537461 is a reply to message #537435] Wed, 02 June 2010 13:53 Go to previous message
Stanimir Stamenkov is currently offline Stanimir StamenkovFriend
Messages: 254
Registered: July 2009
Senior Member
Wed, 02 Jun 2010 08:50:59 -0400, /Alexander Malic/:

> my question is, why isn't it published into the default galileo-update
> site?

Already answered in this same thread:

http://www.eclipse.org/forums/index.php?t=msg&&th=16 8116&goto=534281#msg_535052

--
Stanimir
Previous Topic:Do not check missing resources in the commit dialog (was: Turn off auto commit of new files)
Next Topic:Recursion Hades Upgrading to 0.7.9
Goto Forum:
  


Current Time: Sat Jan 20 11:07:06 GMT 2018

Powered by FUDForum. Page generated in 0.02694 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software