Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Install of 2.2 fails
Install of 2.2 fails [message #530479] Thu, 29 April 2010 18:14
Jacob Weber is currently offline Jacob WeberFriend
Messages: 39
Registered: July 2009
Member
I currently have Eclipse 3.5.2 installed, and I already installed PDT 2.1. Now I'm trying to upgrade to 2.2, according to the instructions here:
http://wiki.eclipse.org/PDT/Installation#From_Update_Site

After I select the feature to install, I get this error:

Your original request has been modified.
"PHP Development Tools (PDT) Runtime Feature" is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: PHP Development Tools (PDT) Runtime Feature 2.2.0.v201004270700-7L7J-F8NcJTJJwdOKOJJ (org.eclipse.php.feature.group 2.2.0.v201004270700-7L7J-F8NcJTJJwdOKOJJ)
Software currently installed: PHP Development Tools (PDT) SDK Feature 2.1.1.v20090707-1108-51584QACJCRCUeNRkNYbOJecWK9O (org.eclipse.php.sdk.feature.group 2.1.1.v20090707-1108-51584QACJCRCUeNRkNYbOJecWK9O)
Only one of the following can be installed at once:
PDT Help Plug-in 2.1.1.v20090707-1108 (org.eclipse.php.help 2.1.1.v20090707-1108)
PDT Help Plug-in 2.2.0.v201004270700 (org.eclipse.php.help 2.2.0.v201004270700)
Cannot satisfy dependency:
From: PHP Development Tools (PDT) Runtime Feature 2.1.3.v20090914-1400-7L7979F8NcJKhKWS09TTK2 (org.eclipse.php.feature.group 2.1.3.v20090914-1400-7L7979F8NcJKhKWS09TTK2)
To: org.eclipse.php.help [2.1.1.v20090707-1108]
Cannot satisfy dependency:
From: PHP Development Tools (PDT) Runtime Feature 2.2.0.v201004270700-7L7J-F8NcJTJJwdOKOJJ (org.eclipse.php.feature.group 2.2.0.v201004270700-7L7J-F8NcJTJJwdOKOJJ)
To: org.eclipse.php.help [2.2.0.v201004270700]
Cannot satisfy dependency:
From: PHP Development Tools (PDT) SDK Feature 2.1.1.v20090707-1108-51584QACJCRCUeNRkNYbOJecWK9O (org.eclipse.php.sdk.feature.group 2.1.1.v20090707-1108-51584QACJCRCUeNRkNYbOJecWK9O)
To: org.eclipse.php.feature.group [2.1.3.v20090914-1400-7L7979F8NcJKhKWS09TTK2]

Do I need to uninstall 2.1 first? Shouldn't the installer do that?
Previous Topic:HTML in PHP files doesn't work in some case
Next Topic:Javascript Code Assist is not work?
Goto Forum:
  


Current Time: Mon May 17 20:45:50 GMT 2021

Powered by FUDForum. Page generated in 0.01396 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top