Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » No Resource found
No Resource found [message #530292] Thu, 29 April 2010 08:57
graa is currently offline graaFriend
Messages: 42
Registered: April 2010
Member
Hi,
when i execute my transformation with ATL,i have this problem:

No Resource found, unable to extract to platform:/resource/hhhhh/res.sysml

res.xmi is the target file.

i write my transformation rules and it accept my source file, I did not understand what resources are not found.

my source.sysml:

<?xml version="1.0" encoding="UTF-8"?>
<uml:Model xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:kaos="http://www.topcased.org/kaos/1" xmlns:uml="http://www.eclipse.org/uml2/3.0.0/UML">
<packagedElement xsi:type="kaos:AbstractGoal" name="goalpere" clientDependency="#//And1 #//And2"/>
<packagedElement xsi:type="kaos:ElementryGoal" name="fils"/>

</uml:Model>

transformation rules:

-- @path kaos=/hhhhh/modele/kaos.ecore
-- @path uml=platform:/plugin/org.eclipse.uml2.uml/model/UML.ecore
-- @path sysml=platform:/plugin/org.topcased.sysml/model/sysML.ecore
-- @path eventb=/hhhhh/modele/eventb.ecore


module far;
create OUT : eventb from IN :kaos, IN1 : uml, IN2 : sysml;

rule ElementToElement {
from
u : uml!Package
to
b : eventb!BNamedElement (name<-u.packagedElement.name)
}



thanks

[Updated on: Thu, 29 April 2010 09:01]

Report message to a moderator

Previous Topic:how to run the UML2OWL atl transformation using the ANT build tool
Next Topic:[QVTo] NEW BUG: Import of library in combination with access broken
Goto Forum:
  


Current Time: Mon Oct 14 15:34:00 GMT 2019

Powered by FUDForum. Page generated in 0.02980 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top