Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » run.director fails in eclipse SDK source build(run.director frequently fails during eclipse SDK source build)
run.director fails in eclipse SDK source build [message #530238] Thu, 29 April 2010 03:25 Go to next message
Mitsuki Touno is currently offline Mitsuki TounoFriend
Messages: 28
Registered: April 2010
Junior Member
Dear forum members,

I'm building eclipse SDK 3.6 M6 with source files included in eclipse-sourceBuild-srcIncluded-3.6M6.zip file that I downloaded from eclipse.org website.

As the final step of the build execution, "run.xml" is invoked and "run.director" target is defined in it. When I run the build, run.director fails with error messages like below so frequently.

If anyone has idea about how to avoid this or what is causing this, please let me know.

==== ERROR LOG FROM HERE ====
run.director:
[exec] This application is deprecated. Please use the org.eclipse.equinox.p2.director application.
[exec] Installing org.eclipse.sdk.ide 3.6.0.I20100312-1448.
[exec] Installation failed.
[exec] Application failed, log file location: F:\temp\runtime-New_configuration\eclipse\configuration\1272 511277663.log
[exec] !SESSION 2010-04-29 12:21:17.316 -----------------------------------------------
[exec] eclipse.buildId=I20100312-1448
[exec] java.version=1.5.0_21
[exec] java.vendor=Sun Microsystems Inc.
[exec] BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=ja_JP
[exec] Framework arguments: -application org.eclipse.equinox.p2.director.app.application -flavor tooling -installIU org.eclipse.sdk.ide -version 3.6.0.I20100312-1448 -p2.os win32 -p2.ws win32 -p2.arch x86 -roaming -profile SDKProfile -profileProperties org.eclipse.update.install.features=true -metadataRepository file:F:\temp\runtime-New_configuration\org.eclipse.releng.ec lipsebuilder.new/../src/updateSite/I20100312-1448 -artifactRepository file:F:\temp\runtime-New_configuration\org.eclipse.releng.ec lipsebuilder.new/../src/updateSite/I20100312-1448 -metadataRepositoryName Eclipse Project Test Site -artifactRepositoryName Eclipse Project Test Site -destination F:\temp\runtime-New_configuration\org.eclipse.releng.eclipse builder.new/../src/I20100312-1448/p2temp/equinox.p2.build/sd k.install/eclipse -bundlepool F:\temp\runtime-New_configuration\org.eclipse.releng.eclipse builder.new/../src/I20100312-1448/p2temp/equinox.p2.build/sd k.install/eclipse
[exec] Command-line arguments: -os win32 -ws win32 -arch x86_64 -application org.eclipse.equinox.p2.director.app.application -consoleLog -flavor tooling -installIU org.eclipse.sdk.ide -version 3.6.0.I20100312-1448 -p2.os win32 -p2.ws win32 -p2.arch x86 -roaming -profile SDKProfile -profileProperties org.eclipse.update.install.features=true -metadataRepository file:F:\temp\runtime-New_configuration\org.eclipse.releng.ec lipsebuilder.new/../src/updateSite/I20100312-1448 -artifactRepository file:F:\temp\runtime-New_configuration\org.eclipse.releng.ec lipsebuilder.new/../src/updateSite/I20100312-1448 -metadataRepositoryName Eclipse Project Test Site -artifactRepositoryName Eclipse Project Test Site -destination F:\temp\runtime-New_configuration\org.eclipse.releng.eclipse builder.new/../src/I20100312-1448/p2temp/equinox.p2.build/sd k.install/eclipse -bundlepool F:\temp\runtime-New_configuration\org.eclipse.releng.eclipse builder.new/../src/I20100312-1448/p2temp/equinox.p2.build/sd k.install/eclipse
[exec]
[exec] !ENTRY org.eclipse.equinox.p2.director 4 1 2010-04-29 12:21:26.473
[exec] !MESSAGE Cannot complete the install because one or more required items could not be found.
[exec] !SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2010-04-29 12:21:26.474
[exec] !MESSAGE Software being installed: Eclipse SDK 3.6.0.I20100312-1448 (org.eclipse.sdk.ide 3.6.0.I20100312-1448)
[exec] !SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2010-04-29 12:21:26.474
[exec] !MESSAGE Missing requirement for filter properties ~= $0: Eclipse Product Configuration 1.0.0.I20100312-1448 (org.eclipse.rcp.configuration.feature.group 1.0.0.I20100312-1448) requires 'org.eclipse.equinox.launcher.win32.win32.x86 [1.1.0.I20100312-1448]' but it could not be found
[exec] !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2010-04-29 12:21:26.474
[exec] !MESSAGE Cannot satisfy dependency:
[exec] !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2010-04-29 12:21:26.474
[exec] !MESSAGE From: Eclipse SDK 3.6.0.I20100312-1448 (org.eclipse.sdk.ide 3.6.0.I20100312-1448)
[exec] !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2010-04-29 12:21:26.475
[exec] !MESSAGE To: org.eclipse.rcp.configuration.feature.group [1.0.0.I20100312-1448]
[exec] Eclipse:
[exec] Java was started but returned exit code=13
[exec] E:/tools/java/jdk5_64/jre/bin/java.exe
[exec] -Declipse.p2.data.area=F:\temp\runtime-New_configuration\org .eclipse.releng.eclipsebuilder.new/../src/I20100312-1448/p2t emp/equinox.p2.build/sdk.install/eclipse/p2
[exec] -Declipse.p2.MD5Check=false
[exec] -Declipse.p2.profile=@none
[exec] -XX:MaxPermSize=256m
[exec] -jar F:\temp\runtime-New_configuration\eclipse\plugins/org.eclips e.equinox.launcher_1.1.0.v20100307.jar
[exec] -os win32
[exec] -ws win32
[exec] -arch x86_64
[exec] -launcher F:\temp\runtime-New_configuration\org.eclipse.releng.eclipse builder.new\..\eclipse\eclipse.exe
[exec] -name Eclipse
[exec] --launcher.library F:\temp\runtime-New_configuration\eclipse\plugins/org.eclips e.equinox.launcher.win32.win32.x86_64_1.1.0.v20100307\eclips e_1306.dll
[exec] -startup F:\temp\runtime-New_configuration\eclipse\plugins/org.eclips e.equinox.launcher_1.1.0.v20100307.jar
[exec] -exitdata 754_5c
[exec] -application org.eclipse.equinox.p2.director.app.application
[exec] -consoleLog
[exec] -flavor tooling
[exec] -installIU org.eclipse.sdk.ide
[exec] -version 3.6.0.I20100312-1448
[exec] -p2.os win32
[exec] -p2.ws win32
[exec] -p2.arch x86
[exec] -roaming
[exec] -profile SDKProfile
[exec] -profileProperties org.eclipse.update.install.features=true
[exec] -metadataRepository file:F:\temp\runtime-New_configuration\org.eclipse.releng.ec lipsebuilder.new/../src/updateSite/I20100312-1448
[exec] -artifactRepository file:F:\temp\runtime-New_configuration\org.eclipse.releng.ec lipsebuilder.new/../src/updateSite/I20100312-1448
[exec] -metadataRepositoryName Eclipse Project Test Site
[exec] -artifactRepositoryName Eclipse Project Test Site
[exec] -destination F:\temp\runtime-New_configuration\org.eclipse.releng.eclipse builder.new/../src/I20100312-1448/p2temp/equinox.p2.build/sd k.install/eclipse
[exec] -bundlepool F:\temp\runtime-New_configuration\org.eclipse.releng.eclipse builder.new/../src/I20100312-1448/p2temp/equinox.p2.build/sd k.install/eclipse
[exec] -vm E:/tools/java/jdk5_64/jre/bin/java.exe
[exec] -vmargs
[exec] -Declipse.p2.data.area=F:\temp\runtime-New_configuration\org .eclipse.releng.eclipsebuilder.new/../src/I20100312-1448/p2t emp/equinox.p2.build/sdk.install/eclipse/p2
[exec] -Declipse.p2.MD5Check=false
[exec] -Declipse.p2.profile=@none
[exec] -XX:MaxPermSize=256m
[exec] -jar F:\temp\runtime-New_configuration\eclipse\plugins/org.eclips e.equinox.launcher_1.1.0.v20100307.jar

==== ERROR LOG TO HERE ====

Thanks regards,

Mitsuki
Re: run.director fails in eclipse SDK source build [message #550100 is a reply to message #530238] Thu, 29 July 2010 07:14 Go to previous messageGo to next message
Mitsuki Touno is currently offline Mitsuki TounoFriend
Messages: 28
Registered: April 2010
Junior Member
Hi,

Can anyone help me with this issue?


Thanks regards,

Mitsuki
Re: run.director fails in eclipse SDK source build [message #551657 is a reply to message #530238] Mon, 09 August 2010 01:20 Go to previous messageGo to next message
Mitsuki Touno is currently offline Mitsuki TounoFriend
Messages: 28
Registered: April 2010
Junior Member
Hi Forum members,

For this issue, I have raised a bug with ID of 321673. Who should I inform this, or simply can I wait for any action from releng team?

Thanks regards,

Mitsuki
Re: run.director fails in eclipse SDK source build [message #553143 is a reply to message #551657] Mon, 16 August 2010 14:40 Go to previous message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

Mitsuki Touno wrote:
> Hi Forum members,
> For this issue, I have raised a bug with ID of 321673. Who should I
> inform this, or simply can I wait for any action from releng team?

They'll have bee notified, it'll take a while to get to.

PW

--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .platform.doc.isv/guide/workbench.htm


Previous Topic:How to contribute to someone else's action set?
Next Topic:Is there a way to override an existing adapterfactory / avoid it from adapting
Goto Forum:
  


Current Time: Wed Jan 27 20:04:45 GMT 2021

Powered by FUDForum. Page generated in 0.02322 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top