Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Updating 1.03 to 1.05 - cannot update wst
Updating 1.03 to 1.05 - cannot update wst [message #529199] Fri, 23 April 2010 12:06 Go to next message
Tony  is currently offline Tony Friend
Messages: 11
Registered: September 2009
Junior Member
Hello

I've been trying to upgrade from pdt 1.03 (with eclipse 3.3.2/europa) to 1.05, but cannot get the pdt update as it says it depends on an wst update, and when i attempt to update wst i get an error:

Quote:
Network connection problems encountered during search.
Unable to access "http://download.eclipse.org/webtools/updates".
Error accessing site stream. [Server returned HTTP response code: 503 for URL: http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd]
Server returned HTTP response code: 503 for URL: http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd
Error accessing site stream. [Server returned HTTP response code: 503 for URL: http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd]
Server returned HTTP response code: 503 for URL: http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd


My current wst is 2.0.2, and it needs wst 3.0.0.

Alternatively, is there an all-in-one package for 1.05

[Updated on: Fri, 23 April 2010 12:09]

Report message to a moderator

Re: Updating 1.03 to 1.05 - cannot update wst [message #529477 is a reply to message #529199] Mon, 26 April 2010 02:08 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 360
Registered: July 2009
Location: Japan
Senior Member
You need to install Eclipse 3.4.2 (Ganymede) first.
1. Install Eclipse 3.4.2. (with new workspace)
(you can download it from http://archive.eclipse.org/eclipse/downloads/ ->3.4.2->Platform Runtime Binary)
2. Install PDT 1.0.5.
(Help->Software Updates->Add Site-> http://download.eclipse.org/tools/pdt/updates/ ->PDT SDK 1.0.5)
3. Import projects from old workspace.
That's all.
Re: Updating 1.03 to 1.05 - cannot update wst [message #529573 is a reply to message #529477] Mon, 26 April 2010 13:01 Go to previous messageGo to next message
Tony  is currently offline Tony Friend
Messages: 11
Registered: September 2009
Junior Member
Hey that's great. Worked like a charm. Smile

Now i'm trying to install the Zend Debugger. I already have ZendServer Community Edition installed which has the debugger already downloaded, but they're not working together at the moment. Do i need to modify the php.ini as outlined in the wiki/ ibm pdf, or is it a different configuration if ZSCE is involved?

Also, i've added the link to the remote zend update site, and i get a message when trying to download the latest debugger (5.3.7):

Quote:
Cannot complete the request. See the details.
Zend Debugger Feature is already installed, so an update will be performed instead.
Unsatisfied dependency: [org.zend.php.debug_feature.feature.group 5.3.7.v20091116] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.php.feature.group/0.0. 0
Unsatisfied dependency: [org.zend.php.debug_feature.feature.group 5.3.7.v20091116] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.php.feature.group/0.0. 0

Re: Updating 1.03 to 1.05 - cannot update wst [message #529748 is a reply to message #529573] Tue, 27 April 2010 06:15 Go to previous message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 360
Registered: July 2009
Location: Japan
Senior Member
Hmm, I reinstalled PDT 1.0.5 today, and tested with Zend Server CE 5.0.0.
I have no problems. ZendDebugger works fine. No any special settings.
What's the problem?

As for debugger plugin...
I don't know about zend debugger plugin but you are not using *latest* PDT Wink
Maybe it requires PDT 2.0 or later.
Previous Topic:PDT, MySQL, Zend CE... it won't work :(
Next Topic:Eclipse PDT for Windows x86 & x64: appropriate msvcr71.dll version?
Goto Forum:
  


Current Time: Tue May 18 01:59:33 GMT 2021

Powered by FUDForum. Page generated in 0.01888 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top