Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] ant launch.xml problem with the AntPlugin
[ATL] ant launch.xml problem with the AntPlugin [message #53352] Thu, 19 July 2007 09:33 Go to next message
Eclipse UserFriend
Originally posted by: NewsgroupSPAM.iKupp.de

Hi,
when i start a launch.xml ant task, i ve got the following error:
With both ant files i ve tested (my own and the copydep.build.xml).

!MESSAGE The activator org.eclipse.gmt.am3.tools.ant.AntPlugin for
bundle org.eclipse.gmt.am3.tools.ant is invalid
!STACK 0
org.osgi.framework.BundleException: The activator
org.eclipse.gmt.am3.tools.ant.AntPlugin for bundle
org.eclipse.gmt.am3.tools.ant is invalid
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:970)
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:346)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:260)
at
org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:400)
....

the copydep.build.xml copies the files to the project but with the error
message.
My launch.xml file (which should load, transform and save) only create a
blank file.

Ive installed Eclipse 3.3 on a Mac with OS X.4.10
emf 2.3.0
o.e.g.am3.tools.ant_1.0.0
atl from the website (the bundle from feb 07)
and now with o.e.m2m.atl... installed with the installer guide and files
from the cvs (its was the same error message without the cvs files before)
....
any ideas?
thanks
Ina
Re: [ATL] ant launch.xml problem with the AntPlugin [message #53383 is a reply to message #53352] Thu, 19 July 2007 10:21 Go to previous messageGo to next message
William Piers is currently offline William PiersFriend
Messages: 297
Registered: July 2009
Senior Member
Ina Kupp a écrit :
> Hi,
> when i start a launch.xml ant task, i ve got the following error:
> With both ant files i ve tested (my own and the copydep.build.xml).
>
> !MESSAGE The activator org.eclipse.gmt.am3.tools.ant.AntPlugin for
> bundle org.eclipse.gmt.am3.tools.ant is invalid
> !STACK 0
> org.osgi.framework.BundleException: The activator
> org.eclipse.gmt.am3.tools.ant.AntPlugin for bundle
> org.eclipse.gmt.am3.tools.ant is invalid
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
>
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:970)
>
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:346)
>
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:260)
>
> at
> org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:400)
> ...
>
> the copydep.build.xml copies the files to the project but with the error
> message.
> My launch.xml file (which should load, transform and save) only create a
> blank file.
>
> Ive installed Eclipse 3.3 on a Mac with OS X.4.10
> emf 2.3.0
> o.e.g.am3.tools.ant_1.0.0
> atl from the website (the bundle from feb 07)
> and now with o.e.m2m.atl... installed with the installer guide and files
> from the cvs (its was the same error message without the cvs files before)
> ...
> any ideas?
> thanks
> Ina
Hello,

I'm afraid that ATL is not compatible with Eclipse 3.3 yet.
You must use Eclipse 3.2.

Regards,
William Piers
Re: [ATL] ant launch.xml problem with the AntPlugin [message #53435 is a reply to message #53383] Thu, 19 July 2007 13:40 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: NewsgroupSPAM.iKupp.de

William Piers schrieb:
> Ina Kupp a écrit :
>> Hi,
>> when i start a launch.xml ant task, i ve got the following error:
>> With both ant files i ve tested (my own and the copydep.build.xml).
>>
>> !MESSAGE The activator org.eclipse.gmt.am3.tools.ant.AntPlugin for
>> bundle org.eclipse.gmt.am3.tools.ant is invalid
>> !STACK 0
>> org.osgi.framework.BundleException: The activator
>> org.eclipse.gmt.am3.tools.ant.AntPlugin for bundle
>> org.eclipse.gmt.am3.tools.ant is invalid
>> at
>> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
>>
>> at
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:970)
>>
>> at
>> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:346)
>>
>> at
>> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:260)
>>
>> at
>> org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:400)
>> ...
>>
>> the copydep.build.xml copies the files to the project but with the
>> error message.
>> My launch.xml file (which should load, transform and save) only create
>> a blank file.
>>
>> Ive installed Eclipse 3.3 on a Mac with OS X.4.10
>> emf 2.3.0
>> o.e.g.am3.tools.ant_1.0.0
>> atl from the website (the bundle from feb 07)
>> and now with o.e.m2m.atl... installed with the installer guide and
>> files from the cvs (its was the same error message without the cvs
>> files before)
>> ...
>> any ideas?
>> thanks
>> Ina
> Hello,
>
> I'm afraid that ATL is not compatible with Eclipse 3.3 yet.
> You must use Eclipse 3.2.
>
> Regards,
> William Piers
ok
thanks for the quick answer.
Ina
Re: [ATL] ant launch.xml problem with the AntPlugin [message #53542 is a reply to message #53435] Thu, 19 July 2007 15:04 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: NewsgroupSPAM.iKupp.de

Ina Kupp schrieb:
> William Piers schrieb:
>> Ina Kupp a écrit :
>>> Hi,
>>> when i start a launch.xml ant task, i ve got the following error:
>>> With both ant files i ve tested (my own and the copydep.build.xml).
>>>
>>> !MESSAGE The activator org.eclipse.gmt.am3.tools.ant.AntPlugin for
>>> bundle org.eclipse.gmt.am3.tools.ant is invalid
>>> !STACK 0
>>> org.osgi.framework.BundleException: The activator
>>> org.eclipse.gmt.am3.tools.ant.AntPlugin for bundle
>>> org.eclipse.gmt.am3.tools.ant is invalid
>>> at
>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
>>>
>>> at
>>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:970)
>>>
>>> at
>>> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:346)
>>>
>>> at
>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:260)
>>>
>>> at
>>> org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:400)
>>>
>>> ...
>>>
>>> the copydep.build.xml copies the files to the project but with the
>>> error message.
>>> My launch.xml file (which should load, transform and save) only
>>> create a blank file.
>>>
>>> Ive installed Eclipse 3.3 on a Mac with OS X.4.10
>>> emf 2.3.0
>>> o.e.g.am3.tools.ant_1.0.0
>>> atl from the website (the bundle from feb 07)
>>> and now with o.e.m2m.atl... installed with the installer guide and
>>> files from the cvs (its was the same error message without the cvs
>>> files before)
>>> ...
>>> any ideas?
>>> thanks
>>> Ina
>> Hello,
>>
>> I'm afraid that ATL is not compatible with Eclipse 3.3 yet.
>> You must use Eclipse 3.2.
>>
>> Regards,
>> William Piers
> ok
> thanks for the quick answer.
> Ina
Hi,
now I installed Eclipse 3.2.2 with emf 2.2.3 and the actual atl bundle
and am3 from the website and its the same errormessage.
Do I realy need the original 3.2 or is there another problem?
Ina
Re: [ATL] ant launch.xml problem with the AntPlugin [message #53596 is a reply to message #53542] Thu, 19 July 2007 18:15 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: NewsgroupSPAM.iKupp.de

Ina Kupp schrieb:
> Ina Kupp schrieb:
>> William Piers schrieb:
>>> Ina Kupp a écrit :
>>>> Hi,
>>>> when i start a launch.xml ant task, i ve got the following error:
>>>> With both ant files i ve tested (my own and the copydep.build.xml).
>>>>
>>>> !MESSAGE The activator org.eclipse.gmt.am3.tools.ant.AntPlugin for
>>>> bundle org.eclipse.gmt.am3.tools.ant is invalid
>>>> !STACK 0
>>>> org.osgi.framework.BundleException: The activator
>>>> org.eclipse.gmt.am3.tools.ant.AntPlugin for bundle
>>>> org.eclipse.gmt.am3.tools.ant is invalid
>>>> at
>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
>>>>
>>>> at
>>>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:970)
>>>>
>>>> at
>>>> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:346)
>>>>
>>>> at
>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:260)
>>>>
>>>> at
>>>> org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:400)
>>>>
>>>> ...
>>>>
>>>> the copydep.build.xml copies the files to the project but with the
>>>> error message.
>>>> My launch.xml file (which should load, transform and save) only
>>>> create a blank file.
>>>>
>>>> Ive installed Eclipse 3.3 on a Mac with OS X.4.10
>>>> emf 2.3.0
>>>> o.e.g.am3.tools.ant_1.0.0
>>>> atl from the website (the bundle from feb 07)
>>>> and now with o.e.m2m.atl... installed with the installer guide and
>>>> files from the cvs (its was the same error message without the cvs
>>>> files before)
>>>> ...
>>>> any ideas?
>>>> thanks
>>>> Ina
>>> Hello,
>>>
>>> I'm afraid that ATL is not compatible with Eclipse 3.3 yet.
>>> You must use Eclipse 3.2.
>>>
>>> Regards,
>>> William Piers
>> ok
>> thanks for the quick answer.
>> Ina
> Hi,
> now I installed Eclipse 3.2.2 with emf 2.2.3 and the actual atl bundle
> and am3 from the website and its the same errormessage.
> Do I realy need the original 3.2 or is there another problem?
> Ina
ok now with the eclipse 3.2 there is exactly the same error message. So
this wasnt the solution.
Any other ideas?
I included for testing the am3ToolsAnt.jar in the classpath in the run
dialog but nothing changed. And this jar File is already in the
additional tasks & support library, and this file isnt marked as invalid
or something like this. If I remove the jar, another error message said
that the atl support is missing.
Ina
Re: [ATL] ant launch.xml problem with the AntPlugin [message #54037 is a reply to message #53596] Fri, 20 July 2007 16:10 Go to previous messageGo to next message
William Piers is currently offline William PiersFriend
Messages: 297
Registered: July 2009
Senior Member
Ina Kupp a écrit :
> Ina Kupp schrieb:
>> Ina Kupp schrieb:
>>> William Piers schrieb:
>>>> Ina Kupp a écrit :
>>>>> Hi,
>>>>> when i start a launch.xml ant task, i ve got the following error:
>>>>> With both ant files i ve tested (my own and the copydep.build.xml).
>>>>>
>>>>> !MESSAGE The activator org.eclipse.gmt.am3.tools.ant.AntPlugin for
>>>>> bundle org.eclipse.gmt.am3.tools.ant is invalid
>>>>> !STACK 0
>>>>> org.osgi.framework.BundleException: The activator
>>>>> org.eclipse.gmt.am3.tools.ant.AntPlugin for bundle
>>>>> org.eclipse.gmt.am3.tools.ant is invalid
>>>>> at
>>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
>>>>>
>>>>> at
>>>>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:970)
>>>>>
>>>>> at
>>>>> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:346)
>>>>>
>>>>> at
>>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:260)
>>>>>
>>>>> at
>>>>> org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:400)
>>>>>
>>>>> ...
>>>>>
>>>>> the copydep.build.xml copies the files to the project but with the
>>>>> error message.
>>>>> My launch.xml file (which should load, transform and save) only
>>>>> create a blank file.
>>>>>
>>>>> Ive installed Eclipse 3.3 on a Mac with OS X.4.10
>>>>> emf 2.3.0
>>>>> o.e.g.am3.tools.ant_1.0.0
>>>>> atl from the website (the bundle from feb 07)
>>>>> and now with o.e.m2m.atl... installed with the installer guide and
>>>>> files from the cvs (its was the same error message without the cvs
>>>>> files before)
>>>>> ...
>>>>> any ideas?
>>>>> thanks
>>>>> Ina
>>>> Hello,
>>>>
>>>> I'm afraid that ATL is not compatible with Eclipse 3.3 yet.
>>>> You must use Eclipse 3.2.
>>>>
>>>> Regards,
>>>> William Piers
>>> ok
>>> thanks for the quick answer.
>>> Ina
>> Hi,
>> now I installed Eclipse 3.2.2 with emf 2.2.3 and the actual atl bundle
>> and am3 from the website and its the same errormessage.
>> Do I realy need the original 3.2 or is there another problem?
>> Ina
> ok now with the eclipse 3.2 there is exactly the same error message. So
> this wasnt the solution.
> Any other ideas?
> I included for testing the am3ToolsAnt.jar in the classpath in the run
> dialog but nothing changed. And this jar File is already in the
> additional tasks & support library, and this file isnt marked as invalid
> or something like this. If I remove the jar, another error message said
> that the atl support is missing.
> Ina

Hi,

Could you please check if your plugins are correctly installed ?
To do this you can open the plugin registry view and look for errors,
and check if atl and am3 plugins are present.

Regards,
William Piers
Re: [ATL] ant launch.xml problem with the AntPlugin [message #54139 is a reply to message #54037] Fri, 20 July 2007 17:44 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: NewsgroupSPAM.iKupp.de

William Piers schrieb:
> Ina Kupp a écrit :
>> Ina Kupp schrieb:
>>> Ina Kupp schrieb:
>>>> William Piers schrieb:
>>>>> Ina Kupp a écrit :
>>>>>> Hi,
>>>>>> when i start a launch.xml ant task, i ve got the following error:
>>>>>> With both ant files i ve tested (my own and the copydep.build.xml).
>>>>>>
>>>>>> !MESSAGE The activator org.eclipse.gmt.am3.tools.ant.AntPlugin for
>>>>>> bundle org.eclipse.gmt.am3.tools.ant is invalid
>>>>>> !STACK 0
>>>>>> org.osgi.framework.BundleException: The activator
>>>>>> org.eclipse.gmt.am3.tools.ant.AntPlugin for bundle
>>>>>> org.eclipse.gmt.am3.tools.ant is invalid
>>>>>> at
>>>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
>>>>>>
>>>>>> at
>>>>>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:970)
>>>>>>
>>>>>> at
>>>>>> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:346)
>>>>>>
>>>>>> at
>>>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:260)
>>>>>>
>>>>>> at
>>>>>> org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:400)
>>>>>>
>>>>>> ...
>>>>>>
>>>>>> the copydep.build.xml copies the files to the project but with the
>>>>>> error message.
>>>>>> My launch.xml file (which should load, transform and save) only
>>>>>> create a blank file.
>>>>>>
>>>>>> Ive installed Eclipse 3.3 on a Mac with OS X.4.10
>>>>>> emf 2.3.0
>>>>>> o.e.g.am3.tools.ant_1.0.0
>>>>>> atl from the website (the bundle from feb 07)
>>>>>> and now with o.e.m2m.atl... installed with the installer guide and
>>>>>> files from the cvs (its was the same error message without the cvs
>>>>>> files before)
>>>>>> ...
>>>>>> any ideas?
>>>>>> thanks
>>>>>> Ina
>>>>> Hello,
>>>>>
>>>>> I'm afraid that ATL is not compatible with Eclipse 3.3 yet.
>>>>> You must use Eclipse 3.2.
>>>>>
>>>>> Regards,
>>>>> William Piers
>>>> ok
>>>> thanks for the quick answer.
>>>> Ina
>>> Hi,
>>> now I installed Eclipse 3.2.2 with emf 2.2.3 and the actual atl
>>> bundle and am3 from the website and its the same errormessage.
>>> Do I realy need the original 3.2 or is there another problem?
>>> Ina
>> ok now with the eclipse 3.2 there is exactly the same error message.
>> So this wasnt the solution.
>> Any other ideas?
>> I included for testing the am3ToolsAnt.jar in the classpath in the run
>> dialog but nothing changed. And this jar File is already in the
>> additional tasks & support library, and this file isnt marked as
>> invalid or something like this. If I remove the jar, another error
>> message said that the atl support is missing.
>> Ina
>
> Hi,
>
> Could you please check if your plugins are correctly installed ?
> To do this you can open the plugin registry view and look for errors,
> and check if atl and am3 plugins are present.
>
> Regards,
> William Piers
Hi
there are no errors shown (no red boxes with a cross inside) in the
plugin registry view.
All atl and am3 plugins are present (see list below).
But not all are active
active:
# org.atl.eclipse.adt.builder
# org.atl.eclipse.adt.debug
# org.atl.eclipse.adt.editor
# org.atl.eclipse.adt.wizard
# org.atl.eclipse.engine
# org.atl.eclipse.km3
# org.atl.engine.vm
# org.eclipse.am3.core
# org.eclipse.am3.ui


inactive (no green triangle):
# org.atl.eclipse.adt.doc.developer
# org.atl.eclipse.adt.doc.user
# org.atl.eclipse.adt.perspective
# org.atl.engine.repositories.emf4atl
# org.atl.engine.repositories.mdr4atl
# org.eclipse.am3.tools.tge
org.eclipse.gmt.am3.tools.ant
org.eclipse.gmt.atl.atl2006
org.eclipse.gmt.atl.oclquery.core

How can i change the status to active? Or is it normal that this plugins
are inactive? (in total 78 of 167 plugins are active).
Many thanks
Ina
Re: [ATL] ant launch.xml problem with the AntPlugin [message #54431 is a reply to message #54139] Mon, 23 July 2007 12:11 Go to previous messageGo to next message
William Piers is currently offline William PiersFriend
Messages: 297
Registered: July 2009
Senior Member
Ina Kupp a écrit :
> William Piers schrieb:
>> Ina Kupp a écrit :
>>> Ina Kupp schrieb:
>>>> Ina Kupp schrieb:
>>>>> William Piers schrieb:
>>>>>> Ina Kupp a écrit :
>>>>>>> Hi,
>>>>>>> when i start a launch.xml ant task, i ve got the following error:
>>>>>>> With both ant files i ve tested (my own and the copydep.build.xml).
>>>>>>>
>>>>>>> !MESSAGE The activator org.eclipse.gmt.am3.tools.ant.AntPlugin
>>>>>>> for bundle org.eclipse.gmt.am3.tools.ant is invalid
>>>>>>> !STACK 0
>>>>>>> org.osgi.framework.BundleException: The activator
>>>>>>> org.eclipse.gmt.am3.tools.ant.AntPlugin for bundle
>>>>>>> org.eclipse.gmt.am3.tools.ant is invalid
>>>>>>> at
>>>>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
>>>>>>>
>>>>>>> at
>>>>>>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:970)
>>>>>>>
>>>>>>> at
>>>>>>> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:346)
>>>>>>>
>>>>>>> at
>>>>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:260)
>>>>>>>
>>>>>>> at
>>>>>>> org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:400)
>>>>>>>
>>>>>>> ...
>>>>>>>
>>>>>>> the copydep.build.xml copies the files to the project but with
>>>>>>> the error message.
>>>>>>> My launch.xml file (which should load, transform and save) only
>>>>>>> create a blank file.
>>>>>>>
>>>>>>> Ive installed Eclipse 3.3 on a Mac with OS X.4.10
>>>>>>> emf 2.3.0
>>>>>>> o.e.g.am3.tools.ant_1.0.0
>>>>>>> atl from the website (the bundle from feb 07)
>>>>>>> and now with o.e.m2m.atl... installed with the installer guide
>>>>>>> and files from the cvs (its was the same error message without
>>>>>>> the cvs files before)
>>>>>>> ...
>>>>>>> any ideas?
>>>>>>> thanks
>>>>>>> Ina
>>>>>> Hello,
>>>>>>
>>>>>> I'm afraid that ATL is not compatible with Eclipse 3.3 yet.
>>>>>> You must use Eclipse 3.2.
>>>>>>
>>>>>> Regards,
>>>>>> William Piers
>>>>> ok
>>>>> thanks for the quick answer.
>>>>> Ina
>>>> Hi,
>>>> now I installed Eclipse 3.2.2 with emf 2.2.3 and the actual atl
>>>> bundle and am3 from the website and its the same errormessage.
>>>> Do I realy need the original 3.2 or is there another problem?
>>>> Ina
>>> ok now with the eclipse 3.2 there is exactly the same error message.
>>> So this wasnt the solution.
>>> Any other ideas?
>>> I included for testing the am3ToolsAnt.jar in the classpath in the
>>> run dialog but nothing changed. And this jar File is already in the
>>> additional tasks & support library, and this file isnt marked as
>>> invalid or something like this. If I remove the jar, another error
>>> message said that the atl support is missing.
>>> Ina
>>
>> Hi,
>>
>> Could you please check if your plugins are correctly installed ?
>> To do this you can open the plugin registry view and look for errors,
>> and check if atl and am3 plugins are present.
>>
>> Regards,
>> William Piers
> Hi
> there are no errors shown (no red boxes with a cross inside) in the
> plugin registry view.
> All atl and am3 plugins are present (see list below).
> But not all are active
> active:
> # org.atl.eclipse.adt.builder
> # org.atl.eclipse.adt.debug
> # org.atl.eclipse.adt.editor
> # org.atl.eclipse.adt.wizard
> # org.atl.eclipse.engine
> # org.atl.eclipse.km3
> # org.atl.engine.vm
> # org.eclipse.am3.core
> # org.eclipse.am3.ui
>
>
> inactive (no green triangle):
> # org.atl.eclipse.adt.doc.developer
> # org.atl.eclipse.adt.doc.user
> # org.atl.eclipse.adt.perspective
> # org.atl.engine.repositories.emf4atl
> # org.atl.engine.repositories.mdr4atl
> # org.eclipse.am3.tools.tge
> org.eclipse.gmt.am3.tools.ant
> org.eclipse.gmt.atl.atl2006
> org.eclipse.gmt.atl.oclquery.core
>
> How can i change the status to active? Or is it normal that this plugins
> are inactive? (in total 78 of 167 plugins are active).
> Many thanks
> Ina
Hi,
active/inactive is not a problem.
But your error message seems to be an incompatibility. If you tried to
install several versions of the plugins, Eclipse could have kept an old
configuration. You can force it to rebuild configuration by launching
Eclipse with the -clean option.

Regards,
--
William Piers
MDA Consultant, Obeo (http://www.obeo.fr)
Re: [ATL] ant launch.xml problem with the AntPlugin [message #54486 is a reply to message #54431] Mon, 23 July 2007 19:38 Go to previous message
Eclipse UserFriend
Originally posted by: NewsgroupSPAM.iKupp.de

William Piers schrieb:
> Ina Kupp a écrit :
>> William Piers schrieb:
>>> Ina Kupp a écrit :
>>>> Ina Kupp schrieb:
>>>>> Ina Kupp schrieb:
>>>>>> William Piers schrieb:
>>>>>>> Ina Kupp a écrit :
>>>>>>>> Hi,
>>>>>>>> when i start a launch.xml ant task, i ve got the following error:
>>>>>>>> With both ant files i ve tested (my own and the copydep.build.xml).
>>>>>>>>
>>>>>>>> !MESSAGE The activator org.eclipse.gmt.am3.tools.ant.AntPlugin
>>>>>>>> for bundle org.eclipse.gmt.am3.tools.ant is invalid
>>>>>>>> !STACK 0
>>>>>>>> org.osgi.framework.BundleException: The activator
>>>>>>>> org.eclipse.gmt.am3.tools.ant.AntPlugin for bundle
>>>>>>>> org.eclipse.gmt.am3.tools.ant is invalid
>>>>>>>> at
>>>>>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
>>>>>>>>
>>>>>>>> at
>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:970)
>>>>>>>>
>>>>>>>> at
>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:346)
>>>>>>>>
>>>>>>>> at
>>>>>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:260)
>>>>>>>>
>>>>>>>> at
>>>>>>>> org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:400)
>>>>>>>>
>>>>>>>> ...
>>>>>>>>
>>>>>>>> the copydep.build.xml copies the files to the project but with
>>>>>>>> the error message.
>>>>>>>> My launch.xml file (which should load, transform and save) only
>>>>>>>> create a blank file.
>>>>>>>>
>>>>>>>> Ive installed Eclipse 3.3 on a Mac with OS X.4.10
>>>>>>>> emf 2.3.0
>>>>>>>> o.e.g.am3.tools.ant_1.0.0
>>>>>>>> atl from the website (the bundle from feb 07)
>>>>>>>> and now with o.e.m2m.atl... installed with the installer guide
>>>>>>>> and files from the cvs (its was the same error message without
>>>>>>>> the cvs files before)
>>>>>>>> ...
>>>>>>>> any ideas?
>>>>>>>> thanks
>>>>>>>> Ina
>>>>>>> Hello,
>>>>>>>
>>>>>>> I'm afraid that ATL is not compatible with Eclipse 3.3 yet.
>>>>>>> You must use Eclipse 3.2.
>>>>>>>
>>>>>>> Regards,
>>>>>>> William Piers
>>>>>> ok
>>>>>> thanks for the quick answer.
>>>>>> Ina
>>>>> Hi,
>>>>> now I installed Eclipse 3.2.2 with emf 2.2.3 and the actual atl
>>>>> bundle and am3 from the website and its the same errormessage.
>>>>> Do I realy need the original 3.2 or is there another problem?
>>>>> Ina
>>>> ok now with the eclipse 3.2 there is exactly the same error message.
>>>> So this wasnt the solution.
>>>> Any other ideas?
>>>> I included for testing the am3ToolsAnt.jar in the classpath in the
>>>> run dialog but nothing changed. And this jar File is already in the
>>>> additional tasks & support library, and this file isnt marked as
>>>> invalid or something like this. If I remove the jar, another error
>>>> message said that the atl support is missing.
>>>> Ina
>>>
>>> Hi,
>>>
>>> Could you please check if your plugins are correctly installed ?
>>> To do this you can open the plugin registry view and look for errors,
>>> and check if atl and am3 plugins are present.
>>>
>>> Regards,
>>> William Piers
>> Hi
>> there are no errors shown (no red boxes with a cross inside) in the
>> plugin registry view.
>> All atl and am3 plugins are present (see list below).
>> But not all are active
>> active:
>> # org.atl.eclipse.adt.builder
>> # org.atl.eclipse.adt.debug
>> # org.atl.eclipse.adt.editor
>> # org.atl.eclipse.adt.wizard
>> # org.atl.eclipse.engine
>> # org.atl.eclipse.km3
>> # org.atl.engine.vm
>> # org.eclipse.am3.core
>> # org.eclipse.am3.ui
>>
>>
>> inactive (no green triangle):
>> # org.atl.eclipse.adt.doc.developer
>> # org.atl.eclipse.adt.doc.user
>> # org.atl.eclipse.adt.perspective
>> # org.atl.engine.repositories.emf4atl
>> # org.atl.engine.repositories.mdr4atl
>> # org.eclipse.am3.tools.tge
>> org.eclipse.gmt.am3.tools.ant
>> org.eclipse.gmt.atl.atl2006
>> org.eclipse.gmt.atl.oclquery.core
>>
>> How can i change the status to active? Or is it normal that this
>> plugins are inactive? (in total 78 of 167 plugins are active).
>> Many thanks
>> Ina
> Hi,
> active/inactive is not a problem.
> But your error message seems to be an incompatibility. If you tried to
> install several versions of the plugins, Eclipse could have kept an old
> configuration. You can force it to rebuild configuration by launching
> Eclipse with the -clean option.
>
> Regards,
Hi,
thanks very much, this was the solution ;-), now it works.
Ina
Previous Topic:[M2M - QVT] Where is the Borland Initial Code contribution
Next Topic:[ATL] Launch a transformation from a java application using metamodel by URI
Goto Forum:
  


Current Time: Fri Jan 22 14:03:29 GMT 2021

Powered by FUDForum. Page generated in 0.01736 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top