Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » SWT Browser Control is not available
icon5.gif  SWT Browser Control is not available [message #526874] Tue, 13 April 2010 11:32 Go to next message
Ethereal1m Mising name is currently offline Ethereal1m Mising nameFriend
Messages: 37
Registered: January 2010
Member
Dear all,
My Eclipse PDT debugger doesn't show its Browser Output saying that "SWT Browser Control is not available". I look at SWT FAQ page and I found that for Eclipse 3.5.2 (I'm using that version) it requires:

Mozilla 1.4 GTK2 - 1.7.x GTK2 and XULRunner 1.8.x - 1.9.2.x.

Currently I have Firefox 3.5.2 installed with GTK2.2.14.7 but I don't have XULRunner installed. I'm running Eclipse 3.5.2 on Linux Slackware 13.0 64.

I assume Mozilla 1.4 is part of Firefox 3.5.2, am I right?
Do I need to install XULRunner to make it work, or the problem lies on something else?

Regards,
ethereal1m
Re: SWT Browser Control is not available [message #528643 is a reply to message #526874] Wed, 21 April 2010 11:00 Go to previous message
Jacek Pospychala is currently offline Jacek PospychalaFriend
Messages: 159
Registered: July 2009
Senior Member
hi Ethereal1m,
XULRunner is not required and Firefox should be enough.
Possible causes are that either Eclipse can't find Firefox libraries, or
that they're 32bit (and you can't mix 32 and 64 bit native libraries,
like SWT and Firefox)
Is this Firefox 64bit?

HTH

Jacek


Ethereal1m wrote:
> Dear all,
> My Eclipse PDT debugger doesn't show its Browser Output saying that
> "SWT Browser Control is not available". I look at SWT FAQ page and I
> found that for Eclipse 3.5.2 (I'm using that version) it requires:
>
> Mozilla 1.4 GTK2 - 1.7.x GTK2 and XULRunner 1.8.x - 1.9.2.x.
>
> Currently I have Firefox 3.5.2 installed with GTK2.2.14.7 but I don't
> have XULRunner installed. I'm running Eclipse 3.5.2 on Linux Slackware
> 13.0 64.
>
> I assume Mozilla 1.4 is part of Firefox 3.5.2, am I right?
> Do I need to install XULRunner to make it work, or the problem lies on
> something else?
> Regards,
> ethereal1m
Previous Topic:launching JUnit plugin-test from command Prompt
Next Topic:Building php projects...
Goto Forum:
  


Current Time: Sat May 15 04:27:41 GMT 2021

Powered by FUDForum. Page generated in 0.01849 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top