Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Push to... operation fails
Push to... operation fails [message #525242] Mon, 05 April 2010 19:44 Go to next message
Francisco  Gortázar is currently offline Francisco GortázarFriend
Messages: 20
Registered: July 2009
Location: Spain
Junior Member

I'm trying to push to a remote server we are configuring. I have ssh access to the server. The server has git-core installed, and there is a git repository in /var/git/test2.git created with:

git init --bare

I first tried with the git+ssh protocol, but got the following error:

Can't connect to any repository: git+ssh:// (Transport error occured during push operation: git+ssh:// error occurred during unpacking on the remote end: unpacker exited with error code)

Then, I tried the sftp protocol, and got an NPE:

An internal error occurred during: "Pushing to...s".

Exception stack trace:
at org.eclipse.jgit.lib.ObjectIdSubclassMap.index(ObjectIdSubcl
at org.eclipse.jgit.lib.ObjectIdSubclassMap.get(ObjectIdSubclas
at org.eclipse.jgit.revwalk.RevWalk.parseAny(
at org.eclipse.jgit.lib.PackWriter.setUpWalker( 838)
at org.eclipse.jgit.lib.PackWriter.preparePack( 497)
at org.eclipse.jgit.transport.WalkPushConnection.sendpack(WalkP
at org.eclipse.jgit.transport.WalkPushConnection.push(WalkPushC
at org.eclipse.jgit.transport.PushProcess.execute(PushProcess.j ava:137)
at org.eclipse.jgit.transport.Transport.push( )
at a:129)
at org.eclipse.egit.ui.internal.push.PushWizard$

I wonder if there is any additional software that the server needs (like some unpackager [unzip?] as it is suggested by the error in my first approach). Am I doing something wrong? How can I push to a remote server? What does egit expects regarding the server?


Re: Push to... operation fails [message #525263 is a reply to message #525242] Mon, 05 April 2010 21:42 Go to previous message
Francisco  Gortázar is currently offline Francisco GortázarFriend
Messages: 20
Registered: July 2009
Location: Spain
Junior Member
My fault: it was a problem with file permissions. egit pushes to my remote repository now perfectly using git+ssh protocol. Anyway, I have a couple of suggestions:

* It could be useful to have more information on remote operations in order to know why remote commands failed

* The wiki pages provide information related to github repository hosting. However, it would be nice to have information for other kind of remote repositories (for instance, we have currently one ssh account per user)

Great job.

Previous Topic:Missing dependency on JSch when installing EGit on 3.5.2
Next Topic:Push to... operation fails
Goto Forum:

Current Time: Wed Jul 08 06:05:42 GMT 2020

Powered by FUDForum. Page generated in 0.01956 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top