Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Label displayed Incorrectly in KDE/Gnome
Label displayed Incorrectly in KDE/Gnome [message #522567] Tue, 23 March 2010 07:41 Go to next message
Sumit  is currently offline Sumit Friend
Messages: 2
Registered: March 2010
Junior Member
Hi,

So I ran a software in both KDE and Gnome respectively and it seems both of them have separate displays. By that I mean, one is displaying a part of the string(a Label) and the other is not displaying the string at all. I will include some relevant information such as the software uses SWT kit. Also the string is displayed perfect in Windows. If it's still not clear I will sum it up in a sentence. I am trying to display a label using SWT kit and, its being displayed correctly on Windows,partially correct on KDE(Half of the string) and not displayed on Gnome.

I have tried grabExcessHorizontalSpace=true, but it didn't. I have no idea how to approach the problem otherwise?

Thanks.

PS- I have also posted the same topic in linux forums, just in case it's related to Desktop Environment.
Re: Label displayed Incorrectly in KDE/Gnome [message #522639 is a reply to message #522567] Tue, 23 March 2010 13:14 Go to previous messageGo to next message
Praveen  is currently offline Praveen Friend
Messages: 86
Registered: July 2009
Member
Sumit wrote:
> I have tried grabExcessHorizontalSpace=true, but it didn't. I have no
> idea how to approach the problem otherwise?
Can you post a simple snippet that showcase the problem. In that way, it
would be greatly helpful to us in debugging the problem.
Re: Label displayed Incorrectly in KDE/Gnome [message #522722 is a reply to message #522639] Tue, 23 March 2010 17:55 Go to previous messageGo to next message
Sumit  is currently offline Sumit Friend
Messages: 2
Registered: March 2010
Junior Member
On KDE

http://i.imgur.com/210MU.jpg

On Gnome

http://i.imgur.com/5L0oA.jpg

On Windows

http://imgur.com/44b3w.jpg
Re: Label displayed Incorrectly in KDE/Gnome [message #522850 is a reply to message #522722] Wed, 24 March 2010 08:27 Go to previous message
Praveen  is currently offline Praveen Friend
Messages: 86
Registered: July 2009
Member
I have requested you to send SWT *code* snippet that might be helpful to
recreate the scenario here and get to the root of the problem. In that
way, we can see the set of APIs used by you for achieving the result.
Thanks.
Previous Topic:Strange behavior of gc.setForeground() and a table in Cocoa SWT
Next Topic:Label Text Vertical Alignment Problem
Goto Forum:
  


Current Time: Tue Aug 20 05:18:59 GMT 2019

Powered by FUDForum. Page generated in 0.02327 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top