Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » SWT.CENTER doesn't work with SWT.PASSWORD
SWT.CENTER doesn't work with SWT.PASSWORD [message #521661] Thu, 18 March 2010 12:41 Go to next message
Michael  is currently offline Michael Friend
Messages: 7
Registered: January 2010
Junior Member
Hi,

i want to create a password field with centered text, but the code
Text txtPassword = new Text(composite, SWT.BORDER | SWT.CENTER | SWT.PASSWORD);

does not work with RAP (the text is always left oriented). With RCP it works. What is the problem?

Thanks in advance.

Michael
Re: SWT.CENTER doesn't work with SWT.PASSWORD [message #521677 is a reply to message #521661] Thu, 18 March 2010 13:26 Go to previous messageGo to next message
Holger Staudacher is currently offline Holger StaudacherFriend
Messages: 166
Registered: July 2009
Senior Member
Hi Michael,
sounds like a bug for. Can you file a bugzilla for this problem?

Regards Holger

On 2010-03-18 13:41:46 +0100, Michael <michael7@nurfuerspam.de> said:

> Hi,
>
> i want to create a password field with centered text, but the code
> Text txtPassword = new Text(composite, SWT.BORDER | SWT.CENTER | SWT.PASSWORD);
>
> does not work with RAP (the text is always left oriented). With RCP it
> works. What is the problem?
>
> Thanks in advance.
>
> Michael


--
-----------------------------------------

http://eclipsesource.com

http://twitter.com/eclipsesource
Re: SWT.CENTER doesn't work with SWT.PASSWORD [message #521741 is a reply to message #521661] Thu, 18 March 2010 16:03 Go to previous messageGo to next message
Michael  is currently offline Michael Friend
Messages: 7
Registered: January 2010
Junior Member
Thanks. I have opened a new bug.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=306386
Re: SWT.CENTER doesn't work with SWT.PASSWORD [message #521889 is a reply to message #521741] Fri, 19 March 2010 03:12 Go to previous message
Holger Staudacher is currently offline Holger StaudacherFriend
Messages: 166
Registered: July 2009
Senior Member
Great, thank you. We will address the problem soon.

Regards Holger

On 2010-03-18 17:03:19 +0100, Michael <michael7@nurfuerspam.de> said:

> Thanks. I have opened a new bug.
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=306386


--
-----------------------------------------

http://eclipsesource.com

http://twitter.com/eclipsesource
Previous Topic:UI-thread sleeping despite Runnables
Next Topic:Session cleared at browser reload.
Goto Forum:
  


Current Time: Sun Dec 05 21:45:06 GMT 2021

Powered by FUDForum. Page generated in 0.02628 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top