Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Import Git Repository
Import Git Repository [message #518707] Thu, 04 March 2010 19:25 Go to next message
Sandro Weiser is currently offline Sandro WeiserFriend
Messages: 105
Registered: July 2009
Senior Member
I'm able to import projects with the "Import Git Repository"-Wizard
(using file: protocol), but the projects aren't connected to the git
repository.

Any ideas?

--

ARC Solutions GmbH

Sandro Weiser
sandro.weiser@arcsolutions.de

www.arcsolutions.de

Handelsregister
Amtsgericht Chemnitz HRB 19907
Geschäftsführer der ARC Solutions GmbH: Alexander Hoffmann
Re: Import Git Repository [message #518712 is a reply to message #518707] Thu, 04 March 2010 19:29 Go to previous messageGo to next message
Sandro Weiser is currently offline Sandro WeiserFriend
Messages: 105
Registered: July 2009
Senior Member
I'm using eclipse 3.5.2 with org.eclipse.egit_0.6.0.201002030558

--

ARC Solutions GmbH

Sandro Weiser
sandro.weiser@arcsolutions.de

www.arcsolutions.de

Handelsregister
Amtsgericht Chemnitz HRB 19907
Geschäftsführer der ARC Solutions GmbH: Alexander Hoffmann
Re: Import Git Repository [message #518743 is a reply to message #518712] Thu, 04 March 2010 20:58 Go to previous messageGo to next message
ekkehard gentz is currently offline ekkehard gentzFriend
Messages: 118
Registered: July 2009
Location: rosenheim, Germany, bavar...
Senior Member

This is a multi-part message in MIME format.
--------------060207040204000000020701
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Am 04.03.10 20:29, schrieb Sandro Weiser:
> I'm using eclipse 3.5.2 with org.eclipse.egit_0.6.0.201002030558
>
>
Sandro,

please try the newest nightly build
I had an issue where it wasn't possible to connect repositories
( http://ekkescorner.wordpress.com/2010/02/16/dvcs-part-2-init ialize-and-import-from-local-repositories-egit-hgeclipse/)

now this works

--

ekke (ekkehard gentz)
independent software-architect
senior erp-consultant
eclipse | osgi | equinox | mdsd | oaw | emf | uml
max-josefs-platz 30, D-83022 rosenheim, germany
mailto:ekke@ekkes-corner.org
homepage (de): http://gentz-software.de
blog (en): http://ekkes-corner.org
twitter: @ekkescorner
skype: ekkes-corner
Steuer-Nr: 156/220/30931 FA Rosenheim, UST-ID: DE189929490


--------------060207040204000000020701
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 7bit

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html; charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Am 04.03.10 20:29, schrieb Sandro Weiser:
<blockquote cite="mid:hmp1m2$ui0$1@build.eclipse.org" type="cite">
<pre wrap="">I'm using eclipse 3.5.2 with org.eclipse.egit_0.6.0.201002030558

</pre>
</blockquote>
Sandro,<br>
<br>
please try the newest nightly build<br>
I had an issue where it wasn't possible to connect repositories<br>
(<a class="moz-txt-link-freetext" href=" http://ekkescorner.wordpress.com/2010/02/16/dvcs-part-2-init ialize-and-import-from-local-repositories-egit-hgeclipse/"> http://ekkescorner.wordpress.com/2010/02/16/dvcs-part-2-init ialize-and-import-from-local-repositories-egit-hgeclipse/</a>)<br>
<br>
now this works<br>
<br>
<div class="moz-signature">-- <br>
<p style="margin-bottom: 0cm;"> <font ,="" color="#808080"
face="Verdana, sans-serif"> <font size="4">ekke (ekkehard gentz)<br>
</font> <font size="3"> independent software-architect<br>
senior erp-consultant<br>
</font> <font size="2">eclipse | osgi | equinox | mdsd | oaw | emf |
uml<br>
max-josefs-platz 30, D-83022 rosenheim, germany<br>
<a class="moz-txt-link-freetext" href="mailto:ekke@ekkes-corner.org">mailto:ekke@ekkes-corner.org</a><br>
homepage (de): <a class="moz-txt-link-freetext" href="http://gentz-software.de">http://gentz-software.de</a><br>
blog (en): <a class="moz-txt-link-freetext" href="http://ekkes-corner.org">http://ekkes-corner.org</a><br>
twitter: @ekkescorner<br>
skype: ekkes-corner<br>
</font> <font size="1"> Steuer-Nr: 156/220/30931 FA Rosenheim, UST-ID:
DE189929490<br>
</font> </font> </p>
</div>
</body>
</html>

--------------060207040204000000020701--


ekke
independent software architect

blog: http://ekkes-corner.org
twitter: @ekkescorner
Re: Import Git Repository [message #518952 is a reply to message #518743] Fri, 05 March 2010 14:45 Go to previous messageGo to next message
Sandro Weiser is currently offline Sandro WeiserFriend
Messages: 105
Registered: July 2009
Senior Member
Am 04.03.2010 21:58, schrieb ekke:
> Am 04.03.10 20:29, schrieb Sandro Weiser:
>> I'm using eclipse 3.5.2 with org.eclipse.egit_0.6.0.201002030558
>>
>>
> Sandro,
>
> please try the newest nightly build
> I had an issue where it wasn't possible to connect repositories
> ( http://ekkescorner.wordpress.com/2010/02/16/dvcs-part-2-init ialize-and-import-from-local-repositories-egit-hgeclipse/)
>
> now this works
tried org.eclipse.egit_0.6.0.201003032003:
there it's even worse: in the Import Git Repository-Wizard after getting
remote branches, none where found. :(

--

ARC Solutions GmbH

Sandro Weiser
sandro.weiser@arcsolutions.de

www.arcsolutions.de

Handelsregister
Amtsgericht Chemnitz HRB 19907
Geschäftsführer der ARC Solutions GmbH: Alexander Hoffmann
Re: Import Git Repository [message #519200 is a reply to message #518952] Mon, 08 March 2010 00:18 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1072
Registered: July 2009
Senior Member
I just tried to clone git://egit.eclipse.org/jgit.git using the latest build which you may install from the update site at http://download.eclipse.org/egit/updates-nightly

Eclipse EGit Feature (Incubation) 0.6.0.201003051509
Eclipse JGit Feature (Incubation) 0.6.0.201002172119

This worked as expected and when "Import projects after clone" and "Enable Git Team operations on imported projects" are checked the projects are also imported and shared as expected.
Re: Import Git Repository [message #519305 is a reply to message #518707] Mon, 08 March 2010 13:00 Go to previous messageGo to next message
Lars Vogel is currently offline Lars VogelFriend
Messages: 1054
Registered: July 2009
Senior Member

Hi Sandro,

this has been recently fixed. It should be working the latest and
greatest version. See http://www.vogella.de/articles/EGit/article.html
for the installation URL.

Cheers, Lars

--
http://www.vogella.de/ - Eclipse plugin and Eclipse RCP Tutorials
http://www.twitter.com/vogella - vogella on Twitter


On 04.03.2010 11:25, Sandro Weiser wrote:
> I'm able to import projects with the "Import Git Repository"-Wizard
> (using file: protocol), but the projects aren't connected to the git
> repository.
>
> Any ideas?
>
Re: Import Git Repository [message #519306 is a reply to message #519305] Mon, 08 March 2010 13:02 Go to previous message
Lars Vogel is currently offline Lars VogelFriend
Messages: 1054
Registered: July 2009
Senior Member

Ups, sorry. For some reason my newsreader did not show that their are
already answers with the same content like my response.

--
http://www.vogella.de/ - Eclipse plugin and Eclipse RCP Tutorials
http://www.twitter.com/vogella - vogella on Twitter


On 08.03.2010 05:00, Lars Vogel wrote:
> Hi Sandro,
>
> this has been recently fixed. It should be working the latest and
> greatest version. See http://www.vogella.de/articles/EGit/article.html
> for the installation URL.
>
> Cheers, Lars
>
Re: Import Git Repository [message #577868 is a reply to message #518707] Thu, 04 March 2010 19:29 Go to previous message
Sandro Weiser is currently offline Sandro WeiserFriend
Messages: 105
Registered: July 2009
Senior Member
I'm using eclipse 3.5.2 with org.eclipse.egit_0.6.0.201002030558

--

ARC Solutions GmbH

Sandro Weiser
sandro.weiser@arcsolutions.de

www.arcsolutions.de

Handelsregister
Amtsgericht Chemnitz HRB 19907
Geschäftsführer der ARC Solutions GmbH: Alexander Hoffmann
Re: Import Git Repository [message #577878 is a reply to message #518712] Thu, 04 March 2010 20:58 Go to previous message
ekkehard gentz is currently offline ekkehard gentzFriend
Messages: 118
Registered: July 2009
Location: rosenheim, Germany, bavar...
Senior Member

This is a multi-part message in MIME format.
--------------060207040204000000020701
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Am 04.03.10 20:29, schrieb Sandro Weiser:
> I'm using eclipse 3.5.2 with org.eclipse.egit_0.6.0.201002030558
>
>
Sandro,

please try the newest nightly build
I had an issue where it wasn't possible to connect repositories
( http://ekkescorner.wordpress.com/2010/02/16/dvcs-part-2-init ialize-and-import-from-local-repositories-egit-hgeclipse/)

now this works

--

ekke (ekkehard gentz)
independent software-architect
senior erp-consultant
eclipse | osgi | equinox | mdsd | oaw | emf | uml
max-josefs-platz 30, D-83022 rosenheim, germany
mailto:ekke@ekkes-corner.org
homepage (de): http://gentz-software.de
blog (en): http://ekkes-corner.org
twitter: @ekkescorner
skype: ekkes-corner
Steuer-Nr: 156/220/30931 FA Rosenheim, UST-ID: DE189929490


--------------060207040204000000020701
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 7bit

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html; charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Am 04.03.10 20:29, schrieb Sandro Weiser:
<blockquote cite="mid:hmp1m2$ui0$1@build.eclipse.org" type="cite">
<pre wrap="">I'm using eclipse 3.5.2 with org.eclipse.egit_0.6.0.201002030558

</pre>
</blockquote>
Sandro,<br>
<br>
please try the newest nightly build<br>
I had an issue where it wasn't possible to connect repositories<br>
(<a class="moz-txt-link-freetext" href=" http://ekkescorner.wordpress.com/2010/02/16/dvcs-part-2-init ialize-and-import-from-local-repositories-egit-hgeclipse/"> http://ekkescorner.wordpress.com/2010/02/16/dvcs-part-2-init ialize-and-import-from-local-repositories-egit-hgeclipse/</a>)<br>
<br>
now this works<br>
<br>
<div class="moz-signature">-- <br>
<p style="margin-bottom: 0cm;"> <font ,="" color="#808080"
face="Verdana, sans-serif"> <font size="4">ekke (ekkehard gentz)<br>
</font> <font size="3"> independent software-architect<br>
senior erp-consultant<br>
</font> <font size="2">eclipse | osgi | equinox | mdsd | oaw | emf |
uml<br>
max-josefs-platz 30, D-83022 rosenheim, germany<br>
<a class="moz-txt-link-freetext" href="mailto:ekke@ekkes-corner.org">mailto:ekke@ekkes-corner.org</a><br>
homepage (de): <a class="moz-txt-link-freetext" href="http://gentz-software.de">http://gentz-software.de</a><br>
blog (en): <a class="moz-txt-link-freetext" href="http://ekkes-corner.org">http://ekkes-corner.org</a><br>
twitter: @ekkescorner<br>
skype: ekkes-corner<br>
</font> <font size="1"> Steuer-Nr: 156/220/30931 FA Rosenheim, UST-ID:
DE189929490<br>
</font> </font> </p>
</div>
</body>
</html>

--------------060207040204000000020701--


ekke
independent software architect

blog: http://ekkes-corner.org
twitter: @ekkescorner
Re: Import Git Repository [message #577916 is a reply to message #518743] Fri, 05 March 2010 14:45 Go to previous message
Sandro Weiser is currently offline Sandro WeiserFriend
Messages: 105
Registered: July 2009
Senior Member
Am 04.03.2010 21:58, schrieb ekke:
> Am 04.03.10 20:29, schrieb Sandro Weiser:
>> I'm using eclipse 3.5.2 with org.eclipse.egit_0.6.0.201002030558
>>
>>
> Sandro,
>
> please try the newest nightly build
> I had an issue where it wasn't possible to connect repositories
> ( http://ekkescorner.wordpress.com/2010/02/16/dvcs-part-2-init ialize-and-import-from-local-repositories-egit-hgeclipse/)
>
> now this works
tried org.eclipse.egit_0.6.0.201003032003:
there it's even worse: in the Import Git Repository-Wizard after getting
remote branches, none where found. :(

--

ARC Solutions GmbH

Sandro Weiser
sandro.weiser@arcsolutions.de

www.arcsolutions.de

Handelsregister
Amtsgericht Chemnitz HRB 19907
Geschäftsführer der ARC Solutions GmbH: Alexander Hoffmann
Re: Import Git Repository [message #578028 is a reply to message #518952] Mon, 08 March 2010 00:18 Go to previous message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1072
Registered: July 2009
Senior Member
I just tried to clone git://egit.eclipse.org/jgit.git using the latest build which you may install from the update site at http://download.eclipse.org/egit/updates-nightly

Eclipse EGit Feature (Incubation) 0.6.0.201003051509
Eclipse JGit Feature (Incubation) 0.6.0.201002172119

This worked as expected and when "Import projects after clone" and "Enable Git Team operations on imported projects" are checked the projects are also imported and shared as expected.
Re: Import Git Repository [message #578051 is a reply to message #518707] Mon, 08 March 2010 13:00 Go to previous message
Lars Vogel is currently offline Lars VogelFriend
Messages: 1054
Registered: July 2009
Senior Member

Hi Sandro,

this has been recently fixed. It should be working the latest and
greatest version. See http://www.vogella.de/articles/EGit/article.html
for the installation URL.

Cheers, Lars

--
http://www.vogella.de/ - Eclipse plugin and Eclipse RCP Tutorials
http://www.twitter.com/vogella - vogella on Twitter


On 04.03.2010 11:25, Sandro Weiser wrote:
> I'm able to import projects with the "Import Git Repository"-Wizard
> (using file: protocol), but the projects aren't connected to the git
> repository.
>
> Any ideas?
>
Re: Import Git Repository [message #578069 is a reply to message #519305] Mon, 08 March 2010 13:02 Go to previous message
Lars Vogel is currently offline Lars VogelFriend
Messages: 1054
Registered: July 2009
Senior Member

Ups, sorry. For some reason my newsreader did not show that their are
already answers with the same content like my response.

--
http://www.vogella.de/ - Eclipse plugin and Eclipse RCP Tutorials
http://www.twitter.com/vogella - vogella on Twitter


On 08.03.2010 05:00, Lars Vogel wrote:
> Hi Sandro,
>
> this has been recently fixed. It should be working the latest and
> greatest version. See http://www.vogella.de/articles/EGit/article.html
> for the installation URL.
>
> Cheers, Lars
>
Previous Topic:.gitignore file
Next Topic:EGit not remember URI settings ?
Goto Forum:
  


Current Time: Mon Aug 26 00:46:53 GMT 2019

Powered by FUDForum. Page generated in 0.02676 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top