Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » eclipse core 3.6
eclipse core 3.6 [message #515554] Fri, 19 February 2010 06:12 Go to next message
Markus  rüger is currently offline Markus rügerFriend
Messages: 369
Registered: July 2009
Senior Member
Hi there,

why is now eclipse core 3.6 needed for rap in CVS? This means I have to use
eclipse's milestones builds to keep up working with RAP CVS.
Actually I didn't want to switch to 3.6 yet.

Regards,
Markus
Re: eclipse core 3.6 [message #515572 is a reply to message #515554] Fri, 19 February 2010 12:14 Go to previous messageGo to next message
Benjamin Muskalla is currently offline Benjamin MuskallaFriend
Messages: 338
Registered: July 2009
Senior Member
Hi,

this dependency was introduced with the usage of the new LocaleProvider
of Equinox, see the following bug:

295630: Provide session-aware LocaleProvider implementation
https://bugs.eclipse.org/bugs/show_bug.cgi?id=295630

Regards,
Ben

Markus Krüger wrote:
> Hi there,
>
> why is now eclipse core 3.6 needed for rap in CVS? This means I have to use
> eclipse's milestones builds to keep up working with RAP CVS.
> Actually I didn't want to switch to 3.6 yet.
>
> Regards,
> Markus
>
>


--
Benjamin Muskalla | EclipseSource Karlsruhe
http://www.eclipsesource.com | http://twitter.com/eclipsesource
Re: eclipse core 3.6 [message #515825 is a reply to message #515572] Sun, 21 February 2010 13:23 Go to previous messageGo to next message
Markus  rüger is currently offline Markus rügerFriend
Messages: 369
Registered: July 2009
Senior Member
I thought only equinox 3.6 was required ([ANN] Equinox 3.6M4 needed for CVS
HEAD) and not org.eclipse.core.runtime 3.6!

???

Regards,
Markus


"Benjamin Muskalla" <bmuskalla@eclipsesource.com> schrieb im Newsbeitrag
news:hllvaj$ata$1@build.eclipse.org...
> Hi,
>
> this dependency was introduced with the usage of the new LocaleProvider of
> Equinox, see the following bug:
>
> 295630: Provide session-aware LocaleProvider implementation
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=295630
>
> Regards,
> Ben
>
> Markus Kr
Re: eclipse core 3.6 [message #515923 is a reply to message #515825] Mon, 22 February 2010 09:06 Go to previous messageGo to next message
Markus  rüger is currently offline Markus rügerFriend
Messages: 369
Registered: July 2009
Senior Member
Using the latest RAP runtime now works. Anyways, the annotation "[ANN]
Equinox 3.6M4 needed for CVS HEAD" just stated the use of equinox 3.6 which
not includes org.eclipse.core.runtime 3.6.

"Markus Kr
Re: eclipse core 3.6 [message #516028 is a reply to message #515923] Mon, 22 February 2010 09:30 Go to previous message
Benjamin Muskalla is currently offline Benjamin MuskallaFriend
Messages: 338
Registered: July 2009
Senior Member
Hi Markus,

in fact only Equinox 3.6 is needed as the LocaleProvider interface is
part of the OSGi system bundle. Due to the dependency graph we rely on
core.runtime to reexport the OSGi system bundle. Another alternative
would be to to do an import package for 3.6 OSGi packages and leave
core.runtime as is. But I don't see why there is such a problem for you
using the RAP target as is.
In case this is a real blocker, please comment on bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=303118

Regards,
Ben

Markus Krüger wrote:
> Using the latest RAP runtime now works. Anyways, the annotation "[ANN]
> Equinox 3.6M4 needed for CVS HEAD" just stated the use of equinox 3.6 which
> not includes org.eclipse.core.runtime 3.6.
>
> "Markus Krüger" <krueger@ion.ag> schrieb im Newsbeitrag
> news:hlrc4s$mip$1@build.eclipse.org...
>> I thought only equinox 3.6 was required ([ANN] Equinox 3.6M4 needed for CVS
>> HEAD) and not org.eclipse.core.runtime 3.6!
>>
>> ???
>>
>> Regards,
>> Markus
>>
>>
>> "Benjamin Muskalla" <bmuskalla@eclipsesource.com> schrieb im Newsbeitrag
>> news:hllvaj$ata$1@build.eclipse.org...
>>> Hi,
>>>
>>> this dependency was introduced with the usage of the new LocaleProvider
>>> of Equinox, see the following bug:
>>>
>>> 295630: Provide session-aware LocaleProvider implementation
>>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=295630
>>>
>>> Regards,
>>> Ben
>>>
>>> Markus Krüger wrote:
>>>> Hi there,
>>>>
>>>> why is now eclipse core 3.6 needed for rap in CVS? This means I have to
>>>> use eclipse's milestones builds to keep up working with RAP CVS.
>>>> Actually I didn't want to switch to 3.6 yet.
>>>>
>>>> Regards,
>>>> Markus
>>>
>>> --
>>> Benjamin Muskalla | EclipseSource Karlsruhe
>>> http://www.eclipsesource.com | http://twitter.com/eclipsesource
>>
>
>


--
Benjamin Muskalla | EclipseSource Karlsruhe
http://www.eclipsesource.com | http://twitter.com/eclipsesource
Previous Topic:Missing API from 3.5 in IWorkbenchPage
Next Topic:[Upload] Upload widget after latest update
Goto Forum:
  


Current Time: Wed Dec 01 21:21:15 GMT 2021

Powered by FUDForum. Page generated in 0.02007 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top