Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Does Eclipse PDT has a bug ?
icon5.gif  Does Eclipse PDT has a bug ? [message #510432] Wed, 27 January 2010 14:16 Go to next message
pyx-84  is currently offline pyx-84 Friend
Messages: 3
Registered: January 2010
Junior Member
I have just downloaded http:// www.eclipse.org/downloads/download.php?file=/technology/epp/ downloads/release/galileo/SR1/eclipse-php-galileo-SR1-linux- gtk-x86_64.tar.gz

While I'm trying to go Window->Preferences->PHP->PHP Manual->New->Local directory and click ... button nothing happens. Is it a bug ?

I am using Ubuntu 9.10 x64. On Vista x64 it works fine.

[Updated on: Wed, 27 January 2010 14:31]

Report message to a moderator

Re: Does Eclipse PDT has a bug ? [message #510437 is a reply to message #510432] Wed, 27 January 2010 14:22 Go to previous messageGo to next message
Basil Gohar is currently offline Basil GoharFriend
Messages: 24
Registered: July 2009
Junior Member
On 01/27/2010 09:16 AM, pyx-84 wrote:
> I have just downloaded
> http://www.eclipse.org/downloads/download.php?file=/technolo gy/epp/downloads/release/galileo/SR1/eclipse-php-galileo-SR1 -linux-gtk-x86_64.tar.gz
>
>
> While I'm trying to go Window->Preferences->PHP->PHP Manual->New->Local
> directory and click ... button nothing happens. Is it a bug ?
>
> I am using Ubuntu 9.01 x64. On Vista x64 it works fine.

I had a similar experience using Eclipse PDT on Fedora 12, also 64-bit.
I'm using Eclipse PDT on Fedora 11, 32-bit, and I do not have this same
problem.

I think the problem is with Eclipse itself, not so much PDT directly. I
believe I posted a bug on the bugtracker for this issue, but I've not
heard back yet.
Re: Does Eclipse PDT has a bug ? [message #510447 is a reply to message #510437] Wed, 27 January 2010 14:59 Go to previous messageGo to next message
pyx-84  is currently offline pyx-84 Friend
Messages: 3
Registered: January 2010
Junior Member
Basil Gohar wrote on Wed, 27 January 2010 09:22
I think the problem is with Eclipse itself, not so much PDT directly. I believe I posted a bug on the bugtracker for this issue, but I've not heard back yet.


I'v installed Eclipse from Ubuntu repo and everyting works fine.
In eclipse:
Eclipse SDK
Version: 3.5.1
Build id: M20090917-0800

Moreover, installing a new software from a web site http://download.eclipse.org/technology/dltk/updates-dev/2.0/ (Help->Install New Software...) I mark PHP Development Tools (PDT) Runtime Feature -> Next -> In Details section i see :
Cannot complete the install because one or more required items could not be found.
Software being installed: PHP Development Tools (PDT) Runtime Feature 2.2.0.v200912030932-7L7J-F8NcJKhTcJmKhmc (org.eclipse.php.feature.group 2.2.0.v200912030932-7L7J-F8NcJKhTcJmKhmc)
Missing requirement: PHP Development Tools (PDT) Runtime Feature 2.2.0.v200912030932-7L7J-F8NcJKhTcJmKhmc (org.eclipse.php.feature.group 2.2.0.v200912030932-7L7J-F8NcJKhTcJmKhmc) requires 'org.eclipse.wst.xsl.feature.feature.group [1.0.0,2.0.0)' but it could not be found

Of course on Vista x64 everything works fine and have no errors. I followed this http:// wiki.eclipse.org/PDT/Installation#Eclipse_3.5_.2F_Galileo_.2 F_PDT_2.1

[Updated on: Wed, 27 January 2010 15:01]

Report message to a moderator

Re: Does Eclipse PDT has a bug ? [message #510499 is a reply to message #510432] Wed, 27 January 2010 16:16 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: dkel50.hotremovemail.com

Both Fedora 12 and Ubuntu 9.10 have a new version of GTK which causes
eclipse 3.5.1 some problems. A workaround to address the issue is
export GDK_NATIVE_WINDOWS=1
then run eclipse.

Dave Kelsey

On 27/01/10 14:16, pyx-84 wrote:
> I have just downloaded
> http://www.eclipse.org/downloads/download.php?file=/technolo gy/epp/downloads/release/galileo/SR1/eclipse-php-galileo-SR1 -linux-gtk-x86_64.tar.gz
>
>
> While I'm trying to go Window->Preferences->PHP->PHP Manual->New->Local
> directory and click ... button nothing happens. Is it a bug ?
>
> I am using Ubuntu 9.01 x64. On Vista x64 it works fine.
Re: Does Eclipse PDT has a bug ? [message #510504 is a reply to message #510499] Wed, 27 January 2010 16:34 Go to previous messageGo to next message
Basil Gohar is currently offline Basil GoharFriend
Messages: 24
Registered: July 2009
Junior Member
On 01/27/2010 11:16 AM, dave kelsey wrote:
> Both Fedora 12 and Ubuntu 9.10 have a new version of GTK which causes
> eclipse 3.5.1 some problems. A workaround to address the issue is
> export GDK_NATIVE_WINDOWS=1
> then run eclipse.
>
> Dave Kelsey

Dave,

Thank you very much for this tip. I'll try it once I get home. If it
does indeed fix the issue I'm having it'll be a real hassle undone, as
the interface in Eclipse has gotten to be quite cumbersome to deal with
with this bug.
Re: Does Eclipse PDT has a bug ? [message #510523 is a reply to message #510504] Wed, 27 January 2010 17:24 Go to previous message
pyx-84  is currently offline pyx-84 Friend
Messages: 3
Registered: January 2010
Junior Member
Basil Gohar wrote on Wed, 27 January 2010 11:34

> Both Fedora 12 and Ubuntu 9.10 have a new version of GTK which causes
> eclipse 3.5.1 some problems. A workaround to address the issue is
> export GDK_NATIVE_WINDOWS=1
> then run eclipse.
>
> Dave Kelsey


Thx! It works great !
In terminal (in eclipse folder) :
export GDK_NATIVE_WINDOWS=1; ./eclipse


And as I wrote above :
Cannot complete the install because one or more required items could not be found.
Software being installed: PHP Development Tools (PDT) Runtime Feature 2.2.0.v200912030932-7L7J-F8NcJKhTcJmKhmc (org.eclipse.php.feature.group 2.2.0.v200912030932-7L7J-F8NcJKhTcJmKhmc)
Missing requirement: PHP Development Tools (PDT) Runtime Feature 2.2.0.v200912030932-7L7J-F8NcJKhTcJmKhmc (org.eclipse.php.feature.group 2.2.0.v200912030932-7L7J-F8NcJKhTcJmKhmc) requires 'org.eclipse.wst.xsl.feature.feature.group [1.0.0,2.0.0)' but it could not be found


It's solved too !

Great thx to Dave Kelsey

[Updated on: Wed, 27 January 2010 17:43]

Report message to a moderator

Previous Topic:Log Writes
Next Topic:debian 4.0 and PDT
Goto Forum:
  


Current Time: Mon May 17 20:39:02 GMT 2021

Powered by FUDForum. Page generated in 0.02243 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top