Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Can't load unknown source libswt-win32-3617.so (I've been trying to fix this error during two days but can't find a proper way)
Can't load unknown source libswt-win32-3617.so [message #507938] Fri, 15 January 2010 09:17 Go to next message
jaume  is currently offline jaume Friend
Messages: 1
Registered: January 2010
Junior Member
Hi all,

in my workplace I'm trying to run our main project in linux (we usually work with XP), I exported it with a WAR using tomcat and then call it from our server making a .jnlp.

There were some functionalities that were not working fine, so I decided to install Eclipse( galileo ) and tomcat( 5.5.12 ) in a linux VM ( ubuntu 9.10 ) to be able to debug it.

I downloaded the project from our CVS and the problem comes when I try to run it, everything works fine till it tries to load the swt libraries:

Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
no swt-win32-3617 in java.library.path
no swt-win32 in java.library.path
Can't load library: /tmp/swtlib-32/libswt-win32-3617.so
Can't load library: /tmp/swtlib-32/libswt-win32.so

at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.C.<clinit>(Unknown Source)
at org.eclipse.swt.widgets.Widget.<clinit>(Unknown Source)


What the f... are those win32..so? They should be gtk..so!! I've been searching for config files containing win32 and can't find nothing strange :S.

I've created "hello world project" using the same SWT libraries and it worked fine... I don't know what to do!!!
I've tried lot of things searching on ggl and nothing works..., hope you could help me.

Thank you all for your time.

[Updated on: Fri, 15 January 2010 09:18]

Report message to a moderator

Re: Can't load unknown source libswt-win32-3617.so [message #508008 is a reply to message #507938] Fri, 15 January 2010 09:44 Go to previous message
Grant Gayed is currently offline Grant GayedFriend
Messages: 2150
Registered: July 2009
Senior Member
Hi,

When swt decides on the name of a library to load, it fills in the name's ws
portion ("win32", "gtk", etc.) with the ws-specific hardcoded value in
Platform.PLATFORM, so there's no way that swt's gtk release would try to
load its win32 libraries. The swt jar that's being referenced in your case
must not be the one that you think. This is some kind of setup problem in
your context, which is pointing at the wrong swt jar.

Grant


"jaume" <jaume_calm@hotmail.com> wrote in message
news:hipbqj$l10$1@build.eclipse.org...
> Hi all,
>
> in my workplace I'm trying to run our main project in linux (we usually
work with XP), I exported it with a WAR using tomcat and then call it from
our server making a .jnlp.
>
> There were some functionalities that were not working fine, so I decided
to install Eclipse( galileo ) and tomcat( 5.5.12 ) in a linux VM ( ubuntu
9.10 ) to be able to debug it.
>
> I downloaded the project from our CVS and the problem comes when I try to
run it, every works fine till it tries to load the swt libraries:
>
> Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError:
Could not load SWT library. Reasons:
> no swt-win32-3617 in java.library.path
> no swt-win32 in java.library.path
> Can't load library: /tmp/swtlib-32/libswt-win32-3617.so
> Can't load library: /tmp/swtlib-32/libswt-win32.so
>
> at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
> at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
> at org.eclipse.swt.internal.C.<clinit>(Unknown Source)
> at org.eclipse.swt.widgets.Widget.<clinit>(Unknown Source)
>
> What the f... are those win32..so? They should be gtk..so!! I've been
searching for config files containing win32 and can't find nothing strange
:S.
>
> I've created "hello world project" using the same SWT libraries and it
worked fine... I don't know what to do!!!
> I've tried lot of things searching on ggl and nothing works..., hope you
could help me.
>
> Thank you all for your time.
>
Previous Topic:SWT Browser Control loosing focus on Enter key press
Next Topic:Menu bar is invisible in standalone SWT application (MacOS)
Goto Forum:
  


Current Time: Fri Jul 10 20:09:17 GMT 2020

Powered by FUDForum. Page generated in 0.02107 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top