Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Menu bar is invisible in standalone SWT application (MacOS)(Since I tried to upgrade to SWT 3.5.1)
Menu bar is invisible in standalone SWT application (MacOS) [message #507382] Wed, 13 January 2010 10:09 Go to next message
Alexander v. Zitzewitz is currently offline Alexander v. ZitzewitzFriend
Messages: 2
Registered: January 2010
Junior Member
I am currently upgrading our application from SWT 3.4 to SWT 3.5.1 on Mac-OS (Leopard). Now after replacing swt.jar the menu bar becomes invisible. Only the Apple menu and the menu with the application name are visible. The other ones are there, if you click into the empty bar area the menus show up, but the menu titles are invisible. As soon as I switch back to SWT 3.4 everything is working fine. Any hint for a solution would be highly appreciated.

What makes it even more frustrating; when I run the same application from Eclipse the menu shows up normally. Only when it is started standalone the problem occurs.

[Updated on: Wed, 13 January 2010 10:50]

Report message to a moderator

Re: Menu bar is invisible in standalone SWT application (MacOS) [message #508022 is a reply to message #507382] Fri, 15 January 2010 10:20 Go to previous message
Grant Gayed is currently offline Grant GayedFriend
Messages: 2150
Registered: July 2009
Senior Member
Your description sounds like
https://bugs.eclipse.org/bugs/show_bug.cgi?id=271029 , but this was fixed in
eclipse/swt 3.5 (I don't know if you're using an SWT.MOZILLA Browser or not,
this was just the case in this report).

Aside from the case above I've never heard of this happening. It could be a
bug in swt, but since other apps don't see this you'll have to provide a way
to reproduce it. If you can provide one (ideal template:
http://www.eclipse.org/swt/faq.php#whatisasnippet ) then please log a report
with swt at
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform &component=SWT .

Thanks,
Grant


"Alexander v. Zitzewitz" <a.zitzewitz@hello2morrow.com> wrote in message
news:hik64e$2rk$1@build.eclipse.org...
> I am currently upgrading our application from SWT 3.4 to SWT 3.5.1 on
Mac-OS (Leopard). Now after replacing swt.jar the menu bar becomes
invisible. Only the Apple menu and the menu with the application name are
visible. The other ones are there, if you click into the empty bar area the
menus show up, but the menu titles are invisible. As soon as I switch back
to SWT 3.4 everything is working fine. Any hint for a solution would be
highly appreciated.
Previous Topic:Can't load unknown source libswt-win32-3617.so
Next Topic:Delayed resize of TableEditor widgets
Goto Forum:
  


Current Time: Sun Jul 12 15:48:37 GMT 2020

Powered by FUDForum. Page generated in 0.01888 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top