Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Re: Cross Document References persistence with Translator
Re: Cross Document References persistence with Translator [message #506835] Sun, 10 January 2010 20:45 Go to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3525
Registered: July 2009
Senior Member

Nidhi wrote:
> I am using Translators to persist my EMF model entities.
> This works fine otherwise but for the case of Cross Document References.
> In this case, I was expecting a similar to how EMF Resource persists as
> href with the location of the referenced document.
>
> However, instead of the location to the referenced document, the to
> string version of the referenced EMF entity is persisted.
>
> Please suggest what is going wrong in my case.

You may have better luck in an EMF newsgroup.

--
Nitin Dahyabhai
Eclipse WTP Source Editing
IBM Rational


Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Cross Document References persistence with Translator [message #506836 is a reply to message #506835] Sun, 10 January 2010 20:53 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30642
Registered: July 2009
Senior Member
Unfortunately I know nothing about how the translator does things...
One could produce a URI that references an object using
EcoreUtil.getURI(), but I don't know how one would specialize the
translator framework to produce that result.


Nitin Dahyabhai wrote:
> Nidhi wrote:
>> I am using Translators to persist my EMF model entities.
>> This works fine otherwise but for the case of Cross Document
>> References. In this case, I was expecting a similar to how EMF
>> Resource persists as href with the location of the referenced document.
>>
>> However, instead of the location to the referenced document, the to
>> string version of the referenced EMF entity is persisted.
>>
>> Please suggest what is going wrong in my case.
>
> You may have better luck in an EMF newsgroup.
>
Previous Topic:Strange behavior when class with name EPackage is used
Next Topic:Validation not happening
Goto Forum:
  


Current Time: Sun Nov 17 17:31:16 GMT 2019

Powered by FUDForum. Page generated in 0.01540 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top