Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » NPE on session shutdown
NPE on session shutdown [message #505705] Mon, 04 January 2010 15:21 Go to next message
Thomas Kratz is currently offline Thomas KratzFriend
Messages: 165
Registered: July 2009
Senior Member
HI I see the follwoing exception several times in my log, then my server goes up in smoke.

2010-01-04 10:43:52,498 ERROR  /webshop: Could not execute org.eclipse.ui.internal.Workbench$ShutdownHandler.beforeDestroy(SessionStoreEvent).
java.lang.NullPointerException
        at org.eclipse.rap.ui.internal.preferences.SessionScope.getNode(SessionScope.java:67)
        at org.eclipse.ui.preferences.ScopedPreferenceStoreCore.getStorePreferences(ScopedPreferenceStoreCore.java:225)
        at org.eclipse.ui.preferences.ScopedPreferenceStoreCore.getPreferenceNodes(ScopedPreferenceStoreCore.java:267)
        at org.eclipse.ui.preferences.ScopedPreferenceStoreCore.internalGet(ScopedPreferenceStoreCore.java:458)
        at org.eclipse.ui.preferences.ScopedPreferenceStoreCore.getBoolean(ScopedPreferenceStoreCore.java:370)
        at org.eclipse.ui.preferences.ScopedPreferenceStore.getBoolean(ScopedPreferenceStore.java:446)
        at org.eclipse.ui.internal.Workbench.busyClose(Workbench.java:814)
        at org.eclipse.ui.internal.Workbench.access$12(Workbench.java:788)
        at org.eclipse.ui.internal.Workbench$21.run(Workbench.java:1054)
        at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:66)
        at org.eclipse.ui.internal.Workbench.close(Workbench.java:1052)
        at org.eclipse.ui.internal.Workbench.close(Workbench.java:1014)
        at org.eclipse.ui.internal.Workbench$ShutdownHandler.beforeDestroy(Workbench.java:133)
        at org.eclipse.rwt.internal.service.SessionStoreImpl.doValueUnbound(SessionStoreImpl.java:174)
        at org.eclipse.rwt.internal.service.SessionStoreImpl.access$0(SessionStoreImpl.java:165)
        at org.eclipse.rwt.internal.service.SessionStoreImpl$1.run(SessionStoreImpl.java:50)
        at org.eclipse.rwt.internal.lifecycle.UIThread.processShutdown(UIThread.java:122)
        at org.eclipse.rwt.internal.lifecycle.RWTLifeCycle$UIThreadController.run(RWTLifeCycle.java:127)
        at java.lang.Thread.run(Thread.java:619)
        at org.eclipse.rwt.internal.lifecycle.UIThread.run(UIThread.java:68)


I don't have any preferences in my app, can anyone give me a hint on this ?
Re: NPE on session shutdown [message #505878 is a reply to message #505705] Tue, 05 January 2010 12:57 Go to previous messageGo to next message
Thomas Kratz is currently offline Thomas KratzFriend
Messages: 165
Registered: July 2009
Senior Member
I found that it must be something with the embedded jetty I use. If I run jetty with the tanuki wrapper everything seems to be fine. Strange thing, but it works now.
Re: NPE on session shutdown [message #507692 is a reply to message #505878] Thu, 14 January 2010 12:07 Go to previous messageGo to next message
Benjamin Muskalla is currently offline Benjamin MuskallaFriend
Messages: 338
Registered: July 2009
Senior Member
Hi Thomas,

do you have any further informations how to reproduce this problem? It
would be great to know if we can do anything about this.

Regards,
Benny

Thomas Kratz wrote:
> I found that it must be something with the embedded jetty I use. If I
> run jetty with the tanuki wrapper everything seems to be fine. Strange
> thing, but it works now.


--
Benjamin Muskalla | EclipseSource Karlsruhe
http://www.eclipsesource.com | http://twitter.com/eclipsesource
Re: NPE on session shutdown [message #507698 is a reply to message #507692] Thu, 14 January 2010 12:26 Go to previous message
Thomas Kratz is currently offline Thomas KratzFriend
Messages: 165
Registered: July 2009
Senior Member
Hi Benny,

sadly I have no idea what the heck the problem is. I found that when I run my app (that has jetty embedded and starts it programmatically) with the tanuki wrapper the problem disappears. So no idea how to reproduce it honestly. I saw another entry fromanother user that seems to be the same problem with an embedded jetty, but I don't know the reasons.

Sorry for the bad ideas Sad
Thomas
Re: NPE on session shutdown [message #507753 is a reply to message #507698] Thu, 14 January 2010 09:54 Go to previous message
Benjamin Muskalla is currently offline Benjamin MuskallaFriend
Messages: 338
Registered: July 2009
Senior Member
Hi Thomas,

no problem. Just in case you can reproduce use, feel free to open a bug
report.

Thanks!
Benny

Thomas Kratz wrote:
> Hi Benny,
>
> sadly I have no idea what the heck the problem is. I found that when I
> run my app (that has jetty embedded and starts it programmatically) with
> the tanuki wrapper the problem disappears. So no idea how to reproduce
> it honestly. I saw another entry fromanother user that seems to be the
> same problem with an embedded jetty, but I don't know the reasons.
> Sorry for the bad ideas :(
> Thomas


--
Benjamin Muskalla | EclipseSource Karlsruhe
http://www.eclipsesource.com | http://twitter.com/eclipsesource
Previous Topic:Rounded border wouldn't show up on certain widgets
Next Topic:Documentation for RAP on external server ?
Goto Forum:
  


Current Time: Fri Dec 03 07:36:49 GMT 2021

Powered by FUDForum. Page generated in 0.02588 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top