Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] Problem setting up target platform(emf-cdo-Update-N200912110230 dependency issue with Helios M4)
[CDO] Problem setting up target platform [message #505018] Thu, 24 December 2009 15:12 Go to next message
Joel Rosi-Schwartz is currently offline Joel Rosi-SchwartzFriend
Messages: 624
Registered: July 2009
Location: London. England
Senior Member
Hi,

This makes no sense to me, but...

I am setting up a development environment using emf-cdo-Update-N200912110230 against eclipse-SDK-3.6M4-macosx-cocoa-x86_64 as my Target Platform. org.eclipse.net4j.db.3.0.0 complains that bundle org.eclipse.core.runtime [3.4.0,4.0.0) can not be satisfied. Of course in fact org.eclipse.core.runtime (3.6.0.v20091204) is present and should satisfy the specified dependency.

Any ideas as to what is amis?

Thank,
Joel
Re: [CDO] Problem setting up target platform [message #505045 is a reply to message #505018] Fri, 25 December 2009 04:26 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6450
Registered: July 2009
Senior Member
Joel Rosi-Schwartz schrieb:
> Hi,
>
> This makes no sense to me, but...
>
> I am setting up a development environment using
> emf-cdo-Update-N200912110230 against
> eclipse-SDK-3.6M4-macosx-cocoa-x86_64 as my Target Platform.
> org.eclipse.net4j.db.3.0.0 complains that bundle
> org.eclipse.core.runtime [3.4.0,4.0.0) can not be satisfied. Of course
> in fact org.eclipse.core.runtime (3.6.0.v20091204) is present and
> should satisfy the specified dependency.
>
> Any ideas as to what is amis?
Sorry, it makes no sense to me, neither. Please try the usual tricks,
e.g. use a later CDO build (for instance
https://build.eclipse.org/hudson/job/cbi-emf-net4j-cdo-3.0/1 62/artifact/build/N200912240453
), reload the target platform, restart the IDE, consult the OSGi logs,
ask the equinox newsgroup, etc...

Good luck, merry christmas and

Cheers
/Eike

----
http://thegordian.blogspot.com
http://twitter.com/eikestepper


Re: [CDO] Problem setting up target platform [message #505046 is a reply to message #505045] Fri, 25 December 2009 05:14 Go to previous message
Joel Rosi-Schwartz is currently offline Joel Rosi-SchwartzFriend
Messages: 624
Registered: July 2009
Location: London. England
Senior Member
Thanks Eike,

I tried the newer build, now org.eclipse.net4j.http.3.0.0 cannot resolve org.apache.commons.codec[1.3.0,2.0.0) which is (of course) there.

The other suggestions were not fruitful. Guess I will ask the equinox group.

Have a great holidays Cool

Cheers,
Joel

Eike Stepper wrote on Fri, 25 December 2009 04:26
Joel Rosi-Schwartz schrieb:
> Hi,
>
> This makes no sense to me, but...
>
> I am setting up a development environment using
> emf-cdo-Update-N200912110230 against
> eclipse-SDK-3.6M4-macosx-cocoa-x86_64 as my Target Platform.
> org.eclipse.net4j.db.3.0.0 complains that bundle
> org.eclipse.core.runtime [3.4.0,4.0.0) can not be satisfied. Of course
> in fact org.eclipse.core.runtime (3.6.0.v20091204) is present and
> should satisfy the specified dependency.
>
> Any ideas as to what is amis?
Sorry, it makes no sense to me, neither. Please try the usual tricks,
e.g. use a later CDO build (for instance
https://build.eclipse.org/hudson/job/cbi-emf-net4j-cdo-3.0/1 62/artifact/build/N200912240453
), reload the target platform, restart the IDE, consult the OSGi logs,
ask the equinox newsgroup, etc...

Good luck, merry christmas and

Cheers
/Eike

----
http://thegordian.blogspot.com
http://twitter.com/eikestepper

[Updated on: Fri, 25 December 2009 10:16]

Report message to a moderator

Previous Topic:[CDO] Adding different models to the same ResourceNode concurrently
Next Topic:[CDO] Hudson Update zips do not contain source
Goto Forum:
  


Current Time: Tue Nov 12 10:35:21 GMT 2019

Powered by FUDForum. Page generated in 0.01437 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top