Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] Use CDO with Eclipse 3.3 and EMF 2.3
[CDO] Use CDO with Eclipse 3.3 and EMF 2.3 [message #502507] Tue, 08 December 2009 15:23 Go to next message
René is currently offline RenéFriend
Messages: 45
Registered: July 2009
Member
Hi all,

i m working in a Eclipse 3.3 (Europa) environment and unfortunately i can't migrate to newer versions. Is it still possible to use CDO in such a context and which version I have to use if it is possible?

I just found a older discussion about this topic here but it doesn't answers my question.


Thanks in advance and regards,
René

[Updated on: Tue, 08 December 2009 15:36]

Report message to a moderator

Re: [CDO] Use CDO with Eclipse 3.3 and EMF 2.3 [message #502528 is a reply to message #502507] Tue, 08 December 2009 17:24 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6451
Registered: July 2009
Senior Member
Hi René,

I know of users who had success with integrating CDO 3.0 and Net4j 3.0
in Eclipse 3.5 and EMF 2.5, although we (the CDO team) do not give
official support for such dependencies that we haven't built against and
haven't run our regression tests against. I have no idea how latest CDO
and Net4j versions operate against older environments. Generally CDO and
Net4j don't use a lot of the Platform functionality but I know of some
bug fixes or enhancements in EMF (2.5?) that CDO might rely on. Maybe
others can jump in with real experience...

Cheers
/Eike

----
http://thegordian.blogspot.com
http://twitter.com/eikestepper



René schrieb:
> Hi all,
>
> i m working in a Eclipse 3.3 (Europa) environment and unfortunately i
> can't migrate to newer versions. Is it possible to use CDO in such a
> context?
>
> Thanks in advance and regards,
> René


Re: [CDO] Use CDO with Eclipse 3.3 and EMF 2.3 [message #502941 is a reply to message #502528] Thu, 10 December 2009 11:29 Go to previous messageGo to next message
Victor Roldan Betancort is currently offline Victor Roldan BetancortFriend
Messages: 524
Registered: July 2009
Senior Member
Eike, René,

in the middle of the development of the 2.0 stream I could manage to
make I work in Eclipse Ganymede 3.4. However, I can't really confirm
that would work with the 2.0 final release, as we did this with the
2.0.0 M7 release.

Apparently, the version ranges are still defined with the EMF 2.4.0 and
Eclipse runtime 3.4.0 as lower bounds...

René, the best thing is to try it out :P Don't forget letting us know it
it worked for you! We will kindly assist you whenever possible :)

Cheers,
Víctor.

Eike Stepper escribió:
> Hi René,
>
> I know of users who had success with integrating CDO 3.0 and Net4j 3.0
> in Eclipse 3.5 and EMF 2.5, although we (the CDO team) do not give
> official support for such dependencies that we haven't built against and
> haven't run our regression tests against. I have no idea how latest CDO
> and Net4j versions operate against older environments. Generally CDO and
> Net4j don't use a lot of the Platform functionality but I know of some
> bug fixes or enhancements in EMF (2.5?) that CDO might rely on. Maybe
> others can jump in with real experience...
>
> Cheers
> /Eike
>
> ----
> http://thegordian.blogspot.com
> http://twitter.com/eikestepper
>
>
>
> René schrieb:
>> Hi all,
>>
>> i m working in a Eclipse 3.3 (Europa) environment and unfortunately i
>> can't migrate to newer versions. Is it possible to use CDO in such a
>> context?
>>
>> Thanks in advance and regards,
>> René
Re: [CDO] Use CDO with Eclipse 3.3 and EMF 2.3 [message #503499 is a reply to message #502941] Mon, 14 December 2009 09:23 Go to previous messageGo to next message
René is currently offline RenéFriend
Messages: 45
Registered: July 2009
Member
Hi Eike, Hi Victor,
Thanks for your very quick and interesting replies.

The last several days I was struggling with the integration from CDO 2.0 in my Eclipse 3.3 and EMF 2.3 environment. And at the end it wasn't so hard like I thought at the beginning. I will try to describe a little bit what I have done:

I imported the COD and Net4J Plug-ins as source projects into my workspace (I need a little Workaround to do that. I created the source projects with a Eclipse 3.5 and use the workspace, where the source plug-ins were located with Eclipse 3.3.) . Then I changed the versions of the dependencies to org.eclipse.core.runtime and org.eclipse.emf.ecore from 3.4 / 2.4 to 3.3. / 2.3 in all CDO- and Net4J-Plug-ins that i have to use (org.eclipse.emf.cdo, org.eclipse.emf.cdo.common, org.eclipse.net4j,org.eclipse.net4j.util and org.eclipse.net4j.tcp) The only errors I got after that are some missing classes that EMF 2.3 not contains. In detail these are org.eclipse.emf.ecore.impl. EstoreEObjectImpl# BasicEStoreEList, org.eclipse.emf.ecore.resource#URIHandler and org.eclipse.emf.ecore.resource.URIConverter (within the implementation classes). These missing classes I copied from EMF 2.4 into another source project of the plug-in org.eclipse.emf.ecore. After I got no more errors in all the opened plug-in projects I deployed them and copied them in to my development environment (of cause I had to override, the org.eclipse.emf.ecore plug-in from the 2.3. EMF version) and CDO works fine. So far at least. Smile

Thanks a lot for your help.
Best regards ,
René
Re: [CDO] Use CDO with Eclipse 3.3 and EMF 2.3 [message #503552 is a reply to message #503499] Mon, 14 December 2009 11:52 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6451
Registered: July 2009
Senior Member
Hi René,

I'm glad that it seems to work but I hope that you understand that we
can not invest a lot of time to analyze further problems with such
non-standard setups. I'm crossing my fingers ;-)

Cheers
/Eike

----
http://thegordian.blogspot.com
http://twitter.com/eikestepper



René schrieb:
> Hi Eike, Hi Victor,
> Thanks for your very quick and interesting replies.
> The last several days I was struggling with the integration from CDO
> 2.0 in my Eclipse 3.3 and EMF 2.3 environment. And at the end it
> wasn't so hard like I thought at the beginning. I will try to
> describe a little bit what I have done:
>
> I imported the COD and Net4J Plug-ins as source projects into my
> workspace (I need a little Workaround to do that. I created the source
> projects with a Eclipse 3.5 and use the workspace, where the source
> plug-ins were located with Eclipse 3.3.) . Then I changed the versions
> of the dependencies to org.eclipse.core.runtime and
> org.eclipse.emf.ecore from 3.4 / 2.4 to 3.3. / 2.3 in all CDO- and
> Net4J-Plug-ins that i have to use (org.eclipse.emf.cdo,
> org.eclipse.emf.cdo.common, org.eclipse.net4j,org.eclipse.net4j.util
> and org.eclipse.net4j.tcp) The only errors I got after that are some
> missing classes that EMF 2.3 not contains. In detail these are
> org.eclipse.emf.ecore.impl. EstoreEObjectImpl# BasicEStoreEList,
> org.eclipse.emf.ecore.resource#URIHandler and
> org.eclipse.emf.ecore.resource.URIConverter (within the implementation
> classes). These missing classes I copied from EMF 2.4 into another
> source project of the plug-in org.eclipse.emf.ecore. After I got no
> more errors in all the opened plug-in projects I deployed them and
> copied them in to my development environment (of cause I had to
> override, the org.eclipse.emf.ecore plug-in from the 2.3. EMF version)
> and CDO works fine. So far at least. :)
>
> Thanks a lot for your help. Best regards ,
> René
>


Re: [CDO] Use CDO with Eclipse 3.3 and EMF 2.3 [message #503938 is a reply to message #503552] Wed, 16 December 2009 15:00 Go to previous message
René is currently offline RenéFriend
Messages: 45
Registered: July 2009
Member
Hi Eike,

I fully understand that you can't support all old versions of Eclipse and EMF. The little test application which Í developed under Eclipse 3.5 + CDO 2.0 works fine under Eclipse 3.3 + CDO 2.0. I just hope the real application does that in the same way. Thanks a lot for crossing your fingers for me. Smile

Regards,
René
Previous Topic:[Announce] EMF Teneo Builds
Next Topic:[CDO] Does the Gastro sample work with current 3.0?
Goto Forum:
  


Current Time: Sun Nov 17 14:58:42 GMT 2019

Powered by FUDForum. Page generated in 0.01831 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top