Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Helios M3 with RAP - RAP launch configuration not working
Helios M3 with RAP - RAP launch configuration not working [message #501166] Tue, 01 December 2009 11:37 Go to next message
Lothar Werzinger is currently offline Lothar WerzingerFriend
Messages: 153
Registered: July 2009
Location: Bay Area
Senior Member
Hi,

I installed Helios M3 with RAP 1.3.0.20090929-1142 and when I try to edit a
RAP launch configuration I get an error dialog and the log contains the
following exception:

java.lang.NoSuchMethodError:
org.eclipse.pde.internal.ui.PDEPlugin.getOSGiFrameworkManage r()Lorg/eclipse/pde/internal/ui/launcher/OSGiFrameworkManage r;
at
org.eclipse.rap.ui.internal.launch.RAPLaunchConfigValidator. getOSGiFrameworkId(RAPLaunchConfigValidator.java:225)
at
org.eclipse.rap.ui.internal.launch.RAPLaunchConfigValidator. validateOSGiFramework(RAPLaunchConfigValidator.java:168)
at
org.eclipse.rap.ui.internal.launch.RAPLaunchConfigValidator. validate(RAPLaunchConfigValidator.java:60)
at
org.eclipse.rap.ui.internal.launch.tab.MainTab.validate(Main Tab.java:311)


Any help is much appreciated!

Lothar
Re: Helios M3 with RAP - RAP launch configuration not working [message #501179 is a reply to message #501166] Tue, 01 December 2009 12:12 Go to previous messageGo to next message
Benjamin Muskalla is currently offline Benjamin MuskallaFriend
Messages: 338
Registered: July 2009
Senior Member
Hi Lother,

this should have been fixed in newer version of the RAP tooling. See
https://bugs.eclipse.org/bugs/show_bug.cgi?id=291665 for details.
Could you please try to update your RAP tooling from the Helios update site?

Regards,
Benny

Lothar Werzinger wrote:
> Hi,
>
> I installed Helios M3 with RAP 1.3.0.20090929-1142 and when I try to edit a
> RAP launch configuration I get an error dialog and the log contains the
> following exception:
>
> java.lang.NoSuchMethodError:
> org.eclipse.pde.internal.ui.PDEPlugin.getOSGiFrameworkManage r()Lorg/eclipse/pde/internal/ui/launcher/OSGiFrameworkManage r;
> at
> org.eclipse.rap.ui.internal.launch.RAPLaunchConfigValidator. getOSGiFrameworkId(RAPLaunchConfigValidator.java:225)
> at
> org.eclipse.rap.ui.internal.launch.RAPLaunchConfigValidator. validateOSGiFramework(RAPLaunchConfigValidator.java:168)
> at
> org.eclipse.rap.ui.internal.launch.RAPLaunchConfigValidator. validate(RAPLaunchConfigValidator.java:60)
> at
> org.eclipse.rap.ui.internal.launch.tab.MainTab.validate(Main Tab.java:311)
>
>
> Any help is much appreciated!
>
> Lothar


--
Benjamin Muskalla | EclipseSource Karlsruhe
http://www.eclipsesource.com | http://twitter.com/eclipsesource
Re: Helios M3 with RAP - RAP launch configuration not working [message #501223 is a reply to message #501179] Tue, 01 December 2009 15:12 Go to previous message
Lothar Werzinger is currently offline Lothar WerzingerFriend
Messages: 153
Registered: July 2009
Location: Bay Area
Senior Member
Benjamin Muskalla wrote:

> Hi Lother,
>
> this should have been fixed in newer version of the RAP tooling. See
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=291665 for details.
> Could you please try to update your RAP tooling from the Helios update
> site?
>
> Regards,
> Benny

Yes, this fixes the problem.

Thanks!
Lothar
Previous Topic:RAP 1.3 M2 Target Platform download link
Next Topic:TreeViewer - setGrayed method
Goto Forum:
  


Current Time: Wed Dec 01 04:36:16 GMT 2021

Powered by FUDForum. Page generated in 0.01755 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top