Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Plugin udpate doesn't work
Plugin udpate doesn't work [message #500707] Fri, 27 November 2009 15:48
Xavier André is currently offline Xavier AndréFriend
Messages: 3
Registered: July 2009
Junior Member
Hi,

I developped 2 plugins wich are inside a feature. I created an update site and insert and build my feature. From an other instance of Eclipse, I try to install my plugins from update site but it doesn't work : feature is found but cannot be install because of a "missing" dependency :

Cannot complete the install because one or more required items could not be found.
  Missing requirement: 1259335873546 0.0.0.1259335873546 requires 'jm2.plugin.feature.feature.group [5.0.0]' but it could not be found


Feature version is 5.0.0
Plugins versions are the same : 5.0.0
In the folder containing the update site I have these files :

+ features
- jm2.plugin.feature_5.0.0.jar
- org.apache.maven_1.0.2.jar
- org.mevenide.feature_0.4.0.jar
+ plugins
- com.jm2.plugin_5.0.0.jar
- com.jm2.startup_5.0.0.jar
- ... (other plugins I need)
+ artifacts.jar
+ content.jar
+ site.xml

I also try from a local folder but same error.

Eclipse version : 3.5 SR1

Any help would be really appreciated.
Thanks in advance.

[Updated on: Fri, 27 November 2009 15:48]

Report message to a moderator

Previous Topic:Exporting and importing source bundle
Next Topic:Plugin udpate doesn't work
Goto Forum:
  


Current Time: Tue Aug 04 20:26:55 GMT 2020

Powered by FUDForum. Page generated in 0.01669 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top