Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Including ecore metamodel elements in a model/diagram
Including ecore metamodel elements in a model/diagram [message #496971] Wed, 11 November 2009 23:16 Go to next message
Milan Milanovich is currently offline Milan MilanovichFriend
Messages: 201
Registered: July 2009
Senior Member
Hi,

I'm creating one metamodel by using Ecore tools, but I need to reference some ecore meta-model classes from my metamodel classes in a diagram/model. How can I do this?

--
thx, Milan Milanovic
Re: Including ecore metamodel elements in a model/diagram [message #497043 is a reply to message #496971] Thu, 12 November 2009 11:10 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31900
Registered: July 2009
Senior Member
Milan,

Use Load Resource...


Milan Milanovich wrote:
> Hi,
>
> I'm creating one metamodel by using Ecore tools, but I need to
> reference some ecore meta-model classes from my metamodel classes in a
> diagram/model. How can I do this?
>
> --
> thx, Milan Milanovic


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Including ecore metamodel elements in a model/diagram [message #497149 is a reply to message #497043] Thu, 12 November 2009 16:46 Go to previous messageGo to next message
Milan Milanovich is currently offline Milan MilanovichFriend
Messages: 201
Registered: July 2009
Senior Member
Dear Mr. Merks,

I did on my ecordiag...right click and Load resource... http://www.eclipse.org/emf/2002/Ecore, however I cannot see ecore anywhere in my model or diagram? I did the same thing for my domain ecore metamodel, but also I cannot see it in Project Explorer.

--
Regards, Milan Milanovic
Re: Including ecore metamodel elements in a model/diagram [message #497154 is a reply to message #497149] Thu, 12 November 2009 17:21 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31900
Registered: July 2009
Senior Member
Milan,

Don't they show up in the outline? You can drag and drop from the
outline and those models should be available as choices in the properties...


Milan Milanovich wrote:
> Dear Mr. Merks,
>
> I did on my ecordiag...right click and Load resource...
> http://www.eclipse.org/emf/2002/Ecore, however I cannot see ecore
> anywhere in my model or diagram? I did the same thing for my domain
> ecore metamodel, but also I cannot see it in Project Explorer.
>
> --
> Regards, Milan Milanovic


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Including ecore metamodel elements in a model/diagram [message #497159 is a reply to message #497154] Thu, 12 November 2009 17:29 Go to previous messageGo to next message
Milan Milanovich is currently offline Milan MilanovichFriend
Messages: 201
Registered: July 2009
Senior Member
Dear Mr. Merks,

no, I can see only my metamodel packages, Diagram and Additional resources (emtpy) items in Outline. There is no Ecore metamodel there.

btw - I'm using latest Eclipse Modeling Galileo and JDK 1.6.


--
Best regards, Milan Milanovic
Re: Including ecore metamodel elements in a model/diagram [message #497173 is a reply to message #497159] Thu, 12 November 2009 17:44 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31900
Registered: July 2009
Senior Member
Milan,

When I use Load Resource... the new resource is added under "Additional
Resources". You're sure that's not the case?


Milan Milanovich wrote:
> Dear Mr. Merks,
>
> no, I can see only my metamodel packages, Diagram and Additional
> resources (emtpy) items in Outline. There is no Ecore metamodel there.
>
> btw - I'm using latest Eclipse Modeling Galileo and JDK 1.6.
>
>
> --
> Best regards, Milan Milanovic


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Including ecore metamodel elements in a model/diagram [message #497745 is a reply to message #497173] Fri, 13 November 2009 11:46 Go to previous messageGo to next message
Milan Milanovich is currently offline Milan MilanovichFriend
Messages: 201
Registered: July 2009
Senior Member
Dear Mr Merks,

When I Load Resource... in my ecore diagram with http://www.eclipse.org/emf/2002/Ecore value, Additional Resources in Outline remains empty. When I do the same thing for my ecore metamodel in Simple EMF editor, I see ecore metamodel below my metamodel, however when I close that file and open it again, I don't see ecore metamodel anymore. In Project Explorer I cannot see ecore metamodel in both cases. I tried the same Load resource... in Outline window, but again, there is no change.

--
Best regards, Milan Milanovic
Re: Including ecore metamodel elements in a model/diagram [message #497751 is a reply to message #497173] Fri, 13 November 2009 11:49 Go to previous messageGo to next message
Milan Milanovich is currently offline Milan MilanovichFriend
Messages: 201
Registered: July 2009
Senior Member
Dear Mr Merks,

When I Load Resource... in my ecore diagram with http://www.eclipse.org/emf/2002/Ecore value, Additional Resources in Outline remains empty. When I do the same thing for my ecore metamodel in Simple EMF editor, I see ecore metamodel below my metamodel, however when I close that file and open it again, I don't see ecore metamodel anymore. In Project Explorer I cannot see ecore metamodel in both cases. I tried the same Load resource... in Outline window, but again, there is no change.

--
Best regards, Milan Milanovic
Re: Including ecore metamodel elements in a model/diagram [message #498002 is a reply to message #497751] Fri, 13 November 2009 16:27 Go to previous messageGo to next message
Milan Milanovich is currently offline Milan MilanovichFriend
Messages: 201
Registered: July 2009
Senior Member
One more thing, what is corresponding class in ecore, for cmof Element? Is it EObject? Does all classes defined in ecore implicitly inherit EObject?

--
Regards, Milan Milanovic

[Updated on: Fri, 13 November 2009 16:28]

Report message to a moderator

Re: Including ecore metamodel elements in a model/diagram [message #498020 is a reply to message #498002] Fri, 13 November 2009 17:12 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31900
Registered: July 2009
Senior Member
Milan,

I'm not sure what CMOF Element is. Ecore corresponds to EMOF not to
CMOF. All generated implementation classes implement EObject and by
defined generated interfaces extends EObject, but that's not required
and can be changed with the Root Extends Interface to be blank or
something else.


Milan Milanovich wrote:
> One more thing, what is corresponding class in ecore, for cmof
> Element? Is it EObject? Does all classes in ecore inherit EObject?
>
> --
> Regards, Milan Milanovic


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Including ecore metamodel elements in a model/diagram [message #498043 is a reply to message #498020] Fri, 13 November 2009 20:16 Go to previous messageGo to next message
Milan Milanovich is currently offline Milan MilanovichFriend
Messages: 201
Registered: July 2009
Senior Member
Dear Mr. Merks,

O.K. But, does the ecore EObject corresponds to the emof Element?

--
Best regards, Milan Milanovic

[Updated on: Fri, 13 November 2009 20:18]

Report message to a moderator

Re: Including ecore metamodel elements in a model/diagram [message #498048 is a reply to message #498043] Fri, 13 November 2009 21:07 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31900
Registered: July 2009
Senior Member
Milan,

Yes.


Milan Milanovich wrote:
> Dear Mr. Merks,
>
> O.K. But, does the ecor EObject corresponds to the emof Element?
>
> --
> Best regards, Milan Milanovic


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Including ecore metamodel elements in a model/diagram [message #621586 is a reply to message #497043] Thu, 12 November 2009 16:46 Go to previous message
Milan Milanovich is currently offline Milan MilanovichFriend
Messages: 201
Registered: July 2009
Senior Member
Dear Mr. Merks,

I did on my ecordiag...right click and Load resource... http://www.eclipse.org/emf/2002/Ecore, however I cannot see ecore anywhere in my model or diagram? I did the same thing for my domain ecore metamodel, but also I cannot see it in Project Explorer.

--
Regards, Milan Milanovic
Re: Including ecore metamodel elements in a model/diagram [message #621587 is a reply to message #621586] Thu, 12 November 2009 17:21 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31900
Registered: July 2009
Senior Member
Milan,

Don't they show up in the outline? You can drag and drop from the
outline and those models should be available as choices in the properties...


Milan Milanovich wrote:
> Dear Mr. Merks,
>
> I did on my ecordiag...right click and Load resource...
> http://www.eclipse.org/emf/2002/Ecore, however I cannot see ecore
> anywhere in my model or diagram? I did the same thing for my domain
> ecore metamodel, but also I cannot see it in Project Explorer.
>
> --
> Regards, Milan Milanovic


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Including ecore metamodel elements in a model/diagram [message #621588 is a reply to message #497154] Thu, 12 November 2009 17:29 Go to previous message
Milan Milanovich is currently offline Milan MilanovichFriend
Messages: 201
Registered: July 2009
Senior Member
Dear Mr. Merks,

no, I can see only my metamodel packages, Diagram and Additional resources (emtpy) items in Outline. There is no Ecore metamodel there.

btw - I'm using latest Eclipse Modeling Galileo and JDK 1.6.


--
Best regards, Milan Milanovic
Re: Including ecore metamodel elements in a model/diagram [message #621589 is a reply to message #621588] Thu, 12 November 2009 17:44 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31900
Registered: July 2009
Senior Member
Milan,

When I use Load Resource... the new resource is added under "Additional
Resources". You're sure that's not the case?


Milan Milanovich wrote:
> Dear Mr. Merks,
>
> no, I can see only my metamodel packages, Diagram and Additional
> resources (emtpy) items in Outline. There is no Ecore metamodel there.
>
> btw - I'm using latest Eclipse Modeling Galileo and JDK 1.6.
>
>
> --
> Best regards, Milan Milanovic


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Including ecore metamodel elements in a model/diagram [message #621592 is a reply to message #498020] Fri, 13 November 2009 20:16 Go to previous message
Milan Milanovich is currently offline Milan MilanovichFriend
Messages: 201
Registered: July 2009
Senior Member
Dear Mr. Merks,

O.K. But, does the ecor EObject corresponds to the emof Element?

--
Best regards, Milan Milanovic
Re: Including ecore metamodel elements in a model/diagram [message #621593 is a reply to message #621592] Fri, 13 November 2009 21:07 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31900
Registered: July 2009
Senior Member
Milan,

Yes.


Milan Milanovich wrote:
> Dear Mr. Merks,
>
> O.K. But, does the ecor EObject corresponds to the emof Element?
>
> --
> Best regards, Milan Milanovic


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Re: Including ecore metamodel elements in a model/diagram
Next Topic:[Acceleo] Arguments list in Generator-API
Goto Forum:
  


Current Time: Sat Jun 12 11:34:45 GMT 2021

Powered by FUDForum. Page generated in 0.03287 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top