Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Does doc.zip no longer work in 3.5?
Does doc.zip no longer work in 3.5? [message #495732] Thu, 05 November 2009 20:47 Go to next message
Kristina Taylor is currently offline Kristina TaylorFriend
Messages: 15
Registered: July 2009
Junior Member
Is there something special I need to do to make help content that is
contained in a doc.zip file show up properly in Eclipse 3.5?

I have a help plugin structured like this:
doc.zip (contains html/filename.html and pdf/filename.pdf as well as a whole
pile of images that have semi-random automatically generated filenames)
plugin.xml
toc.xml
nl/ja/JP/doc.zip
nl/ja/JP/toc.xml

When you click on the link to the HTML or PDF documents in the toc.xml, you
get a "Help Content Not found" message claiming the link to be broken. If I
unzip the contents of the doc.zip file into the plugin's jar, it can resolve
the links.

The zipped up version works just fine in Eclipse 3.4.

Thanks,
Kristina Taylor
Re: Does doc.zip no longer work in 3.5? [message #496237 is a reply to message #495732] Mon, 09 November 2009 12:26 Go to previous messageGo to next message
Ankur Sharma is currently offline Ankur SharmaFriend
Messages: 68
Registered: July 2009
Member
Hi,

I am not replicate the behavior in 3.4. By the sound of it, it might be a bug we introduced in 3.5.
If you can send me a sample plug-in, I may look more into it and possibly fix it too.

Kristina Taylor wrote:
> Is there something special I need to do to make help content that is
> contained in a doc.zip file show up properly in Eclipse 3.5?
>
> I have a help plugin structured like this:
> doc.zip (contains html/filename.html and pdf/filename.pdf as well as a whole
> pile of images that have semi-random automatically generated filenames)
> plugin.xml
> toc.xml
> nl/ja/JP/doc.zip
> nl/ja/JP/toc.xml
>
> When you click on the link to the HTML or PDF documents in the toc.xml, you
> get a "Help Content Not found" message claiming the link to be broken. If I
> unzip the contents of the doc.zip file into the plugin's jar, it can resolve
> the links.
>
> The zipped up version works just fine in Eclipse 3.4.
>
> Thanks,
> Kristina Taylor
>
>


--
hth,
Ankur..
Eclipse PDE UI Committer ? IBM India Software Lab, Bangalore
+91-99456-94011 ? @ankur_sharma ? http://blog.ankursharma.org
Re: Does doc.zip no longer work in 3.5? [message #496291 is a reply to message #496237] Mon, 09 November 2009 15:48 Go to previous message
Kristina Taylor is currently offline Kristina TaylorFriend
Messages: 15
Registered: July 2009
Junior Member
I think I may have mischaracterized the problem. It turns out that this
doesn't work in Eclipse 3.4 either. I was basing that claim on what the QA
person told me, but it turns out she had the older version of our plugin
installed.

The older version of our plugin was packaged as a bunch of files loose in a
folder. The new version is all in one jar file (like the attached). If I
unzip the doc.zip file, and shove the contents back into the .jar, it can
find the HTML help file. Alternatively, if I unzip the entire .jar, but
leave the doc.zip content zipped up, it can find the HTML file. It looks
like the problem is that Eclipse won't handle a doc.zip file nested inside a
plugin.jar file. This is true in both Eclipse 3.4 and 3.5. I haven't
tested 3.3 and earlier.

Drop the attached file into your dropins/plugins directory, and you should
see the behaviour I'm talking about. I'm hoping there's something simple
I'm missing that I should be specifying in a manifest file or something to
get this to work.

Thanks,
Kristina

"Ankur Sharma" <ankur_sharma@in.ibm.com> wrote in message
news:4AF80A76.8040807@in.ibm.com...
> Hi,
>
> I am not replicate the behavior in 3.4. By the sound of it, it might be a
> bug we introduced in 3.5.
> If you can send me a sample plug-in, I may look more into it and possibly
> fix it too.
>
> Kristina Taylor wrote:
>> Is there something special I need to do to make help content that is
>> contained in a doc.zip file show up properly in Eclipse 3.5?
>>
>> I have a help plugin structured like this:
>> doc.zip (contains html/filename.html and pdf/filename.pdf as well as a
>> whole
>> pile of images that have semi-random automatically generated filenames)
>> plugin.xml
>> toc.xml
>> nl/ja/JP/doc.zip
>> nl/ja/JP/toc.xml
>>
>> When you click on the link to the HTML or PDF documents in the toc.xml,
>> you
>> get a "Help Content Not found" message claiming the link to be broken.
>> If I
>> unzip the contents of the doc.zip file into the plugin's jar, it can
>> resolve
>> the links.
>>
>> The zipped up version works just fine in Eclipse 3.4.
>>
>> Thanks,
>> Kristina Taylor
>>
>>
>
>
> --
> hth,
> Ankur..
> Eclipse PDE UI Committer ? IBM India Software Lab, Bangalore
> +91-99456-94011 ? @ankur_sharma ? http://blog.ankursharma.org


Re: Does doc.zip no longer work in 3.5? [message #603114 is a reply to message #495732] Mon, 09 November 2009 12:26 Go to previous message
Ankur Sharma is currently offline Ankur SharmaFriend
Messages: 68
Registered: July 2009
Member
Hi,

I am not replicate the behavior in 3.4. By the sound of it, it might be a bug we introduced in 3.5.
If you can send me a sample plug-in, I may look more into it and possibly fix it too.

Kristina Taylor wrote:
> Is there something special I need to do to make help content that is
> contained in a doc.zip file show up properly in Eclipse 3.5?
>
> I have a help plugin structured like this:
> doc.zip (contains html/filename.html and pdf/filename.pdf as well as a whole
> pile of images that have semi-random automatically generated filenames)
> plugin.xml
> toc.xml
> nl/ja/JP/doc.zip
> nl/ja/JP/toc.xml
>
> When you click on the link to the HTML or PDF documents in the toc.xml, you
> get a "Help Content Not found" message claiming the link to be broken. If I
> unzip the contents of the doc.zip file into the plugin's jar, it can resolve
> the links.
>
> The zipped up version works just fine in Eclipse 3.4.
>
> Thanks,
> Kristina Taylor
>
>


--
hth,
Ankur..
Eclipse PDE UI Committer ? IBM India Software Lab, Bangalore
+91-99456-94011 ? @ankur_sharma ? http://blog.ankursharma.org
Re: Does doc.zip no longer work in 3.5? [message #603120 is a reply to message #496237] Mon, 09 November 2009 15:48 Go to previous message
Kristina Taylor is currently offline Kristina TaylorFriend
Messages: 15
Registered: July 2009
Junior Member
I think I may have mischaracterized the problem. It turns out that this
doesn't work in Eclipse 3.4 either. I was basing that claim on what the QA
person told me, but it turns out she had the older version of our plugin
installed.

The older version of our plugin was packaged as a bunch of files loose in a
folder. The new version is all in one jar file (like the attached). If I
unzip the doc.zip file, and shove the contents back into the .jar, it can
find the HTML help file. Alternatively, if I unzip the entire .jar, but
leave the doc.zip content zipped up, it can find the HTML file. It looks
like the problem is that Eclipse won't handle a doc.zip file nested inside a
plugin.jar file. This is true in both Eclipse 3.4 and 3.5. I haven't
tested 3.3 and earlier.

Drop the attached file into your dropins/plugins directory, and you should
see the behaviour I'm talking about. I'm hoping there's something simple
I'm missing that I should be specifying in a manifest file or something to
get this to work.

Thanks,
Kristina

"Ankur Sharma" <ankur_sharma@in.ibm.com> wrote in message
news:4AF80A76.8040807@in.ibm.com...
> Hi,
>
> I am not replicate the behavior in 3.4. By the sound of it, it might be a
> bug we introduced in 3.5.
> If you can send me a sample plug-in, I may look more into it and possibly
> fix it too.
>
> Kristina Taylor wrote:
>> Is there something special I need to do to make help content that is
>> contained in a doc.zip file show up properly in Eclipse 3.5?
>>
>> I have a help plugin structured like this:
>> doc.zip (contains html/filename.html and pdf/filename.pdf as well as a
>> whole
>> pile of images that have semi-random automatically generated filenames)
>> plugin.xml
>> toc.xml
>> nl/ja/JP/doc.zip
>> nl/ja/JP/toc.xml
>>
>> When you click on the link to the HTML or PDF documents in the toc.xml,
>> you
>> get a "Help Content Not found" message claiming the link to be broken.
>> If I
>> unzip the contents of the doc.zip file into the plugin's jar, it can
>> resolve
>> the links.
>>
>> The zipped up version works just fine in Eclipse 3.4.
>>
>> Thanks,
>> Kristina Taylor
>>
>>
>
>
> --
> hth,
> Ankur..
> Eclipse PDE UI Committer ? IBM India Software Lab, Bangalore
> +91-99456-94011 ? @ankur_sharma ? http://blog.ankursharma.org


Previous Topic:Does doc.zip no longer work in 3.5?
Next Topic:Plug-in Fragment cannot resolve classes from host
Goto Forum:
  


Current Time: Sat Aug 08 11:06:58 GMT 2020

Powered by FUDForum. Page generated in 0.02508 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top