Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » zlinux - java.lang.UnsatisfiedLinkError: no swt-gtk-3555 or swt-gtk
icon14.gif  zlinux - java.lang.UnsatisfiedLinkError: no swt-gtk-3555 or swt-gtk [message #491366] Wed, 14 October 2009 11:07 Go to next message
joey  is currently offline joey Friend
Messages: 2
Registered: October 2009
Junior Member
Hello,

I developed a tool based on SWT. The GUI can be open in windows, normal linux and aix. But it failed to open in the zlinux. When i run my program, it said: Exception in thread "main" java.lang.UnsatisfiedLinkError: no swt-gtk-3555 or swt-gtk in swt.library.path, java.library.path or the jar file.

Bellow is my environment information:
# uname -a
Linux ptcs9p00 2.6.16.60-0.21-default #1 SMP Tue May 6 12:41:02 UTC 2008 s390x s390x s390x GNU/Linux

# rpm -q gtk2
gtk2-2.8.11-0.22

I tried two JVMs
# ./java -version
java version "1.5.0"
Java(TM) 2 Runtime Environment, Standard Edition (build pxz31dev-20090707 (SR10 ))
IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 Linux s390-31 j9vmxz3123-20090707 (JIT enabled)
J9VM - 20090706_38445_bHdSMr
JIT - 20090623_1334_r8
GC - 200906_09)
JCL - 20090705
and
# ./java -version
java version "1.5.0"
Java(TM) 2 Runtime Environment, Standard Edition (build pxz64dev-20090707 (SR10 ))
IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 Linux s390x-64 j9vmxz6423-20090707 (JIT enabled)
J9VM - 20090706_38445_BHdSMr
JIT - 20090623_1334_r8
GC - 200906_09)
JCL - 20090705

I tried all the jars downloaded from http://www.eclipse.org/swt/. What i tried are:
Linux (x86/GTK 2) swt-3.5.1-gtk-linux-x86
Linux (x86_64/GTK 2) swt-3.5.1-gtk-linux-x86_64
Linux (PPC/GTK 2) swt-3.5.1-gtk-linux-ppc
Linux (x86/Motif) swt-3.5.1-motif-linux-x86

I also tried the swt.jar under eclipse-SDK-3.5.1-linux-gtk-s390.tar.gz and eclipse-SDK-3.5.1-linux-gtk-s390x.tar.gz.

Could anybody give me suggestions?
Thanks very much!

[Updated on: Fri, 16 October 2009 03:12]

Report message to a moderator

icon14.gif  Re: zlinux - java.lang.UnsatisfiedLinkError: no swt-gtk-3555 or swt-gtk [message #491826 is a reply to message #491366] Fri, 16 October 2009 03:11 Go to previous message
joey  is currently offline joey Friend
Messages: 2
Registered: October 2009
Junior Member
The problem resolved.

The build of 3.5.1 for s390 and s390x do not work. We can try the build of 3.5. It works.

There is no independent swt binary package for downloading. I need to download the RCP first and then extract the swt package from it. Very Happy
Previous Topic:Excluding files/folders from problem marking
Next Topic:SWT controls and larger font
Goto Forum:
  


Current Time: Fri Aug 23 13:08:14 GMT 2019

Powered by FUDForum. Page generated in 0.01386 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top