Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Updated ProjectSet connector - availability
Updated ProjectSet connector - availability [message #490665] Fri, 09 October 2009 15:34 Go to next message
Steve Whatmore is currently offline Steve WhatmoreFriend
Messages: 95
Registered: July 2009
Member
Does anyone know when the updated ProjectSet connector will be available?

Currently I am getting the following conflict when I try to update my
connector.

Cannot complete the install because of a conflicting dependency.
Software being installed: Subversive Integration for the CSC Project Set
Project 2.0.2.I20090116-1600
(org.polarion.eclipse.team.svn.projectset.feature.group
2.0.2.I20090116-1600)
Software currently installed: ProjectSet 3.0.0.200905051715
(com.csc.dip.projectset.feature.group 3.0.0.200905051715)
Only one of the following can be installed at once:
Projectset 3.0.0.200905051715 (com.csc.dip.projectset
3.0.0.200905051715)
com.csc.dip.projectset 2.18.0.200811141124
Cannot satisfy dependency:
From: ProjectSet 2.18.0.200811141124
(com.csc.dip.projectset.feature.group 2.18.0.200811141124)
To: com.csc.dip.projectset
Cannot satisfy dependency:
From: ProjectSet 3.0.0.200905051715
(com.csc.dip.projectset.feature.group 3.0.0.200905051715)
To: com.csc.dip.projectset [3.0.0.200905051715]
Cannot satisfy dependency:
From: Subversive Integration for the CSC Project Set Project
2.0.2.I20090116-1600 (org.polarion.eclipse.team.svn.projectset.feature.group
2.0.2.I20090116-1600)
To: com.csc.dip.projectset.feature.group [2.18.0.200811141124,3.0.0)
Re: Updated ProjectSet connector - availability [message #491711 is a reply to message #490665] Thu, 15 October 2009 14:32 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello,

I created the corresponding bug on tracker:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=292407

> Does anyone know when the updated ProjectSet connector will be available?
>
> Currently I am getting the following conflict when I try to update my
> connector.
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Subversive Integration for the CSC Project Set
> Project 2.0.2.I20090116-1600
> (org.polarion.eclipse.team.svn.projectset.feature.group
> 2.0.2.I20090116-1600)
> Software currently installed: ProjectSet 3.0.0.200905051715
> (com.csc.dip.projectset.feature.group 3.0.0.200905051715)
> Only one of the following can be installed at once:
> Projectset 3.0.0.200905051715 (com.csc.dip.projectset
> 3.0.0.200905051715)
> com.csc.dip.projectset 2.18.0.200811141124
> Cannot satisfy dependency:
> From: ProjectSet 2.18.0.200811141124
> (com.csc.dip.projectset.feature.group 2.18.0.200811141124)
> To: com.csc.dip.projectset
> Cannot satisfy dependency:
> From: ProjectSet 3.0.0.200905051715
> (com.csc.dip.projectset.feature.group 3.0.0.200905051715)
> To: com.csc.dip.projectset [3.0.0.200905051715]
> Cannot satisfy dependency:
> From: Subversive Integration for the CSC Project Set Project
> 2.0.2.I20090116-1600
> (org.polarion.eclipse.team.svn.projectset.feature.group
> 2.0.2.I20090116-1600)
> To: com.csc.dip.projectset.feature.group [2.18.0.200811141124,3.0.0)
Re: Updated ProjectSet connector - availability [message #491881 is a reply to message #491711] Fri, 16 October 2009 11:29 Go to previous messageGo to next message
Steve Whatmore is currently offline Steve WhatmoreFriend
Messages: 95
Registered: July 2009
Member
Thank you, I guess I could have done that but I just assumed that the
connector lineup would have already been scheduled for the upgrade

"Igor Burilo" <igor.burilo@polarion.org> wrote in message
news:hb7bpa$bd3$1@build.eclipse.org...
> Hello,
>
> I created the corresponding bug on tracker:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=292407
>
>> Does anyone know when the updated ProjectSet connector will be available?
>>
>> Currently I am getting the following conflict when I try to update my
>> connector.
>>
>> Cannot complete the install because of a conflicting dependency.
>> Software being installed: Subversive Integration for the CSC Project Set
>> Project 2.0.2.I20090116-1600
>> (org.polarion.eclipse.team.svn.projectset.feature.group
>> 2.0.2.I20090116-1600)
>> Software currently installed: ProjectSet 3.0.0.200905051715
>> (com.csc.dip.projectset.feature.group 3.0.0.200905051715)
>> Only one of the following can be installed at once:
>> Projectset 3.0.0.200905051715 (com.csc.dip.projectset
>> 3.0.0.200905051715)
>> com.csc.dip.projectset 2.18.0.200811141124
>> Cannot satisfy dependency:
>> From: ProjectSet 2.18.0.200811141124
>> (com.csc.dip.projectset.feature.group 2.18.0.200811141124)
>> To: com.csc.dip.projectset
>> Cannot satisfy dependency:
>> From: ProjectSet 3.0.0.200905051715
>> (com.csc.dip.projectset.feature.group 3.0.0.200905051715)
>> To: com.csc.dip.projectset [3.0.0.200905051715]
>> Cannot satisfy dependency:
>> From: Subversive Integration for the CSC Project Set Project
>> 2.0.2.I20090116-1600
>> (org.polarion.eclipse.team.svn.projectset.feature.group
>> 2.0.2.I20090116-1600)
>> To: com.csc.dip.projectset.feature.group [2.18.0.200811141124,3.0.0)
>
>
Re: Updated ProjectSet connector - availability [message #492218 is a reply to message #491881] Mon, 19 October 2009 13:47 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello,

Thanks for the issue. I've already fixed this problem and updated 'update
site'. Please, try it.

> Thank you, I guess I could have done that but I just assumed that the
> connector lineup would have already been scheduled for the upgrade
>
> "Igor Burilo" <igor.burilo@polarion.org> wrote in message
> news:hb7bpa$bd3$1@build.eclipse.org...
>> Hello,
>>
>> I created the corresponding bug on tracker:
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=292407
>>
>>> Does anyone know when the updated ProjectSet connector will be
>>> available?
>>>
>>> Currently I am getting the following conflict when I try to update my
>>> connector.
>>>
>>> Cannot complete the install because of a conflicting dependency.
>>> Software being installed: Subversive Integration for the CSC Project
>>> Set Project 2.0.2.I20090116-1600
>>> (org.polarion.eclipse.team.svn.projectset.feature.group
>>> 2.0.2.I20090116-1600)
>>> Software currently installed: ProjectSet 3.0.0.200905051715
>>> (com.csc.dip.projectset.feature.group 3.0.0.200905051715)
>>> Only one of the following can be installed at once:
>>> Projectset 3.0.0.200905051715 (com.csc.dip.projectset
>>> 3.0.0.200905051715)
>>> com.csc.dip.projectset 2.18.0.200811141124
>>> Cannot satisfy dependency:
>>> From: ProjectSet 2.18.0.200811141124
>>> (com.csc.dip.projectset.feature.group 2.18.0.200811141124)
>>> To: com.csc.dip.projectset
>>> Cannot satisfy dependency:
>>> From: ProjectSet 3.0.0.200905051715
>>> (com.csc.dip.projectset.feature.group 3.0.0.200905051715)
>>> To: com.csc.dip.projectset [3.0.0.200905051715]
>>> Cannot satisfy dependency:
>>> From: Subversive Integration for the CSC Project Set Project
>>> 2.0.2.I20090116-1600
>>> (org.polarion.eclipse.team.svn.projectset.feature.group
>>> 2.0.2.I20090116-1600)
>>> To: com.csc.dip.projectset.feature.group [2.18.0.200811141124,3.0.0)
>>
>>
>
Re: Updated ProjectSet connector - availability [message #492265 is a reply to message #492218] Mon, 19 October 2009 15:52 Go to previous messageGo to next message
Steve Whatmore is currently offline Steve WhatmoreFriend
Messages: 95
Registered: July 2009
Member
Thanks download now works, however, I am still getting the

org.polarion.team.svn.core.svnnature not supported

which plugin is that defines this, I thought it would be the PSP svn
integration.


"Igor Burilo" <igor.burilo@polarion.org> wrote in message
news:hbhqkq$bla$1@build.eclipse.org...
> Hello,
>
> Thanks for the issue. I've already fixed this problem and updated 'update
> site'. Please, try it.
>
>> Thank you, I guess I could have done that but I just assumed that the
>> connector lineup would have already been scheduled for the upgrade
>>
>> "Igor Burilo" <igor.burilo@polarion.org> wrote in message
>> news:hb7bpa$bd3$1@build.eclipse.org...
>>> Hello,
>>>
>>> I created the corresponding bug on tracker:
>>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=292407
>>>
>>>> Does anyone know when the updated ProjectSet connector will be
>>>> available?
>>>>
>>>> Currently I am getting the following conflict when I try to update my
>>>> connector.
>>>>
>>>> Cannot complete the install because of a conflicting dependency.
>>>> Software being installed: Subversive Integration for the CSC Project
>>>> Set Project 2.0.2.I20090116-1600
>>>> (org.polarion.eclipse.team.svn.projectset.feature.group
>>>> 2.0.2.I20090116-1600)
>>>> Software currently installed: ProjectSet 3.0.0.200905051715
>>>> (com.csc.dip.projectset.feature.group 3.0.0.200905051715)
>>>> Only one of the following can be installed at once:
>>>> Projectset 3.0.0.200905051715 (com.csc.dip.projectset
>>>> 3.0.0.200905051715)
>>>> com.csc.dip.projectset 2.18.0.200811141124
>>>> Cannot satisfy dependency:
>>>> From: ProjectSet 2.18.0.200811141124
>>>> (com.csc.dip.projectset.feature.group 2.18.0.200811141124)
>>>> To: com.csc.dip.projectset
>>>> Cannot satisfy dependency:
>>>> From: ProjectSet 3.0.0.200905051715
>>>> (com.csc.dip.projectset.feature.group 3.0.0.200905051715)
>>>> To: com.csc.dip.projectset [3.0.0.200905051715]
>>>> Cannot satisfy dependency:
>>>> From: Subversive Integration for the CSC Project Set Project
>>>> 2.0.2.I20090116-1600
>>>> (org.polarion.eclipse.team.svn.projectset.feature.group
>>>> 2.0.2.I20090116-1600)
>>>> To: com.csc.dip.projectset.feature.group [2.18.0.200811141124,3.0.0)
>>>
>>>
>>
>
>
Re: Updated ProjectSet connector - availability [message #492629 is a reply to message #492265] Wed, 21 October 2009 07:31 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello,

You used old version of Subversive and you need to migrate to new one, for
more details how to migrate please see:
http://www.eclipse.org/subversive/documentation/gettingStart ed/aboutSubversive/update_polarion.php

> Thanks download now works, however, I am still getting the
>
> org.polarion.team.svn.core.svnnature not supported
>
> which plugin is that defines this, I thought it would be the PSP svn
> integration.
>
>
> "Igor Burilo" <igor.burilo@polarion.org> wrote in message
> news:hbhqkq$bla$1@build.eclipse.org...
>> Hello,
>>
>> Thanks for the issue. I've already fixed this problem and updated 'update
>> site'. Please, try it.
>>
>>> Thank you, I guess I could have done that but I just assumed that the
>>> connector lineup would have already been scheduled for the upgrade
>>>
>>> "Igor Burilo" <igor.burilo@polarion.org> wrote in message
>>> news:hb7bpa$bd3$1@build.eclipse.org...
>>>> Hello,
>>>>
>>>> I created the corresponding bug on tracker:
>>>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=292407
>>>>
>>>>> Does anyone know when the updated ProjectSet connector will be
>>>>> available?
>>>>>
>>>>> Currently I am getting the following conflict when I try to update my
>>>>> connector.
>>>>>
>>>>> Cannot complete the install because of a conflicting dependency.
>>>>> Software being installed: Subversive Integration for the CSC Project
>>>>> Set Project 2.0.2.I20090116-1600
>>>>> (org.polarion.eclipse.team.svn.projectset.feature.group
>>>>> 2.0.2.I20090116-1600)
>>>>> Software currently installed: ProjectSet 3.0.0.200905051715
>>>>> (com.csc.dip.projectset.feature.group 3.0.0.200905051715)
>>>>> Only one of the following can be installed at once:
>>>>> Projectset 3.0.0.200905051715 (com.csc.dip.projectset
>>>>> 3.0.0.200905051715)
>>>>> com.csc.dip.projectset 2.18.0.200811141124
>>>>> Cannot satisfy dependency:
>>>>> From: ProjectSet 2.18.0.200811141124
>>>>> (com.csc.dip.projectset.feature.group 2.18.0.200811141124)
>>>>> To: com.csc.dip.projectset
>>>>> Cannot satisfy dependency:
>>>>> From: ProjectSet 3.0.0.200905051715
>>>>> (com.csc.dip.projectset.feature.group 3.0.0.200905051715)
>>>>> To: com.csc.dip.projectset [3.0.0.200905051715]
>>>>> Cannot satisfy dependency:
>>>>> From: Subversive Integration for the CSC Project Set Project
>>>>> 2.0.2.I20090116-1600
>>>>> (org.polarion.eclipse.team.svn.projectset.feature.group
>>>>> 2.0.2.I20090116-1600)
>>>>> To: com.csc.dip.projectset.feature.group
>>>>> [2.18.0.200811141124,3.0.0)
>>>>
>>>>
>>>
>>
>>
>
Re: Updated ProjectSet connector - availability [message #492681 is a reply to message #492629] Wed, 21 October 2009 11:25 Go to previous messageGo to next message
Steve Whatmore is currently offline Steve WhatmoreFriend
Messages: 95
Registered: July 2009
Member
Igor,

Thanks, unfortunately the project set that I was trying to load was a old
project set from a previous version of Eclipse which I no longer since I
have upgraded to 3.5.

However, it was fairly easy to figure out that I had to edit the PSF file
directly and replace the line

<provider id="org.polarion.team.svn.core.svnnature">

with

<provider id="org.eclipse.team.svn.core.svnnature">

Everything seems to be okay, but just to be sure is there anything that I
may have missed.

Thanks for your help BTW.

Whatty

"Igor Burilo" <igor.burilo@polarion.org> wrote in message
news:hbmdbm$1cv$1@build.eclipse.org...
> Hello,
>
> You used old version of Subversive and you need to migrate to new one, for
> more details how to migrate please see:
> http://www.eclipse.org/subversive/documentation/gettingStart ed/aboutSubversive/update_polarion.php
>
>> Thanks download now works, however, I am still getting the
>>
>> org.polarion.team.svn.core.svnnature not supported
>>
>> which plugin is that defines this, I thought it would be the PSP svn
>> integration.
>>
>>
>> "Igor Burilo" <igor.burilo@polarion.org> wrote in message
>> news:hbhqkq$bla$1@build.eclipse.org...
>>> Hello,
>>>
>>> Thanks for the issue. I've already fixed this problem and updated
>>> 'update site'. Please, try it.
>>>
>>>> Thank you, I guess I could have done that but I just assumed that the
>>>> connector lineup would have already been scheduled for the upgrade
>>>>
>>>> "Igor Burilo" <igor.burilo@polarion.org> wrote in message
>>>> news:hb7bpa$bd3$1@build.eclipse.org...
>>>>> Hello,
>>>>>
>>>>> I created the corresponding bug on tracker:
>>>>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=292407
>>>>>
>>>>>> Does anyone know when the updated ProjectSet connector will be
>>>>>> available?
>>>>>>
>>>>>> Currently I am getting the following conflict when I try to update my
>>>>>> connector.
>>>>>>
>>>>>> Cannot complete the install because of a conflicting dependency.
>>>>>> Software being installed: Subversive Integration for the CSC Project
>>>>>> Set Project 2.0.2.I20090116-1600
>>>>>> (org.polarion.eclipse.team.svn.projectset.feature.group
>>>>>> 2.0.2.I20090116-1600)
>>>>>> Software currently installed: ProjectSet 3.0.0.200905051715
>>>>>> (com.csc.dip.projectset.feature.group 3.0.0.200905051715)
>>>>>> Only one of the following can be installed at once:
>>>>>> Projectset 3.0.0.200905051715 (com.csc.dip.projectset
>>>>>> 3.0.0.200905051715)
>>>>>> com.csc.dip.projectset 2.18.0.200811141124
>>>>>> Cannot satisfy dependency:
>>>>>> From: ProjectSet 2.18.0.200811141124
>>>>>> (com.csc.dip.projectset.feature.group 2.18.0.200811141124)
>>>>>> To: com.csc.dip.projectset
>>>>>> Cannot satisfy dependency:
>>>>>> From: ProjectSet 3.0.0.200905051715
>>>>>> (com.csc.dip.projectset.feature.group 3.0.0.200905051715)
>>>>>> To: com.csc.dip.projectset [3.0.0.200905051715]
>>>>>> Cannot satisfy dependency:
>>>>>> From: Subversive Integration for the CSC Project Set Project
>>>>>> 2.0.2.I20090116-1600
>>>>>> (org.polarion.eclipse.team.svn.projectset.feature.group
>>>>>> 2.0.2.I20090116-1600)
>>>>>> To: com.csc.dip.projectset.feature.group
>>>>>> [2.18.0.200811141124,3.0.0)
>>>>>
>>>>>
>>>>
>>>
>>>
>>
>
>
Re: Updated ProjectSet connector - availability [message #512786 is a reply to message #491881] Sun, 07 February 2010 12:02 Go to previous messageGo to next message
Werner Keil is currently offline Werner KeilFriend
Messages: 1085
Registered: July 2009
Senior Member
Sorry, what exactly is an CSC ProjectSet (connector) ?

As the discussion with other colleagues around the atomicity of commits
using Subversive lead to the asumption, commits were done for each
WorkingSet in Eclipse (as it always counts "n items" in the status bar which
is exactly the number of WorkingSets) I noticed, there's not only an Eclipse
WorkingSet, but a second "SVN WorkingSet". At least when you use
Subversive.

So what's this CSC Project or WorkingSet good for?
It seems, there are more fundamental problems with Subversive at the moment
than some fancy add-ons...

Werner
Re: Updated ProjectSet connector - availability [message #512921 is a reply to message #512786] Mon, 08 February 2010 11:10 Go to previous message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello Werner,

>using Subversive lead to the asumption, commits were done for each
>WorkingSet in Eclipse
Commits atomicity doesn't depend on Working Sets, e.g. if you commit two
projects from the same repository and use SVNKit connector (JavaHL doesn't
support commit atomicity) then commit will be atomic.

> So what's this CSC Project or WorkingSet good for?
We have long ago integration for CSC Project Set project, please see
http://vpms.de.csc.com/projectset/


> Sorry, what exactly is an CSC ProjectSet (connector) ?
>
> As the discussion with other colleagues around the atomicity of commits
> using Subversive lead to the asumption, commits were done for each
> WorkingSet in Eclipse (as it always counts "n items" in the status bar
> which is exactly the number of WorkingSets) I noticed, there's not only an
> Eclipse WorkingSet, but a second "SVN WorkingSet". At least when you use
> Subversive.
>
> So what's this CSC Project or WorkingSet good for?
> It seems, there are more fundamental problems with Subversive at the
> moment than some fancy add-ons...
>
> Werner
Previous Topic:Problem with slow https requests
Next Topic:SVN "team" support was there yesterday ...today its gone
Goto Forum:
  


Current Time: Thu Sep 20 16:33:13 GMT 2018

Powered by FUDForum. Page generated in 0.01574 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top