Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » No Git commands on Team menu
No Git commands on Team menu [message #489009] Thu, 01 October 2009 08:33 Go to next message
John Bito is currently offline John BitoFriend
Messages: 54
Registered: July 2009
Member
I tried to follow the instructions to switch over to the eclipse git
project and installed org.eclipse.egit.feature.group 0.5.0.200908282229
after uninstalling the old plugin. Now the Team context menus for the
projects in my workspace do not show the 'Share Project...' commands.

I guess I'll try creating (another) new workspace, but if anyone has any
suggestions for getting EGit to work in the existing workspace, I'd
appreciate it - there are several projects and some workspace settings
can be tedious to recreate.

Thanks!
John
Re: No Git commands on Team menu [message #489024 is a reply to message #489009] Thu, 01 October 2009 09:22 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1212
Registered: July 2009
Senior Member
According to http://dev.eclipse.org/mhonarc/lists/egit-dev/msg00015.html it seems Shawn was able to switch from the old to the new plugin by following the sequence :
- remove the old feature and plugins
- install the new one
- delete projects from Eclipse workspace (instead you may of course move them somewhere else)
- re-import the projects
- re-attach the projects to the Git team provider

--
Matthias
Re: No Git commands on Team menu [message #489187 is a reply to message #489024] Thu, 01 October 2009 18:35 Go to previous messageGo to next message
John Bito is currently offline John BitoFriend
Messages: 54
Registered: July 2009
Member
Matthias Sohn wrote:
> According to http://dev.eclipse.org/mhonarc/lists/egit-dev/msg00015.html
> it seems Shawn was able to switch from the old to the new plugin by
> following the sequence :
> - remove the old feature and plugins
> - install the new one
> - delete projects from Eclipse workspace (instead you may of course move
> them somewhere else)
> - re-import the projects
> - re-attach the projects to the Git team provider

Thanks, Matthias! I'll try deleting and re-importing projects on
another workspace and see if that keeps things in order.
Re: No Git commands on Team menu [message #489225 is a reply to message #489187] Thu, 01 October 2009 22:23 Go to previous message
Werner Keil is currently offline Werner KeilFriend
Messages: 1087
Registered: July 2009
Senior Member
Interesting, looks like the Git plugin gets somewhere near the other Team
plugins ?;-)
Re: No Git commands on Team menu [message #574350 is a reply to message #489009] Thu, 01 October 2009 09:22 Go to previous message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1212
Registered: July 2009
Senior Member
According to http://dev.eclipse.org/mhonarc/lists/egit-dev/msg00015.html it seems Shawn was able to switch from the old to the new plugin by following the sequence :
- remove the old feature and plugins
- install the new one
- delete projects from Eclipse workspace (instead you may of course move them somewhere else)
- re-import the projects
- re-attach the projects to the Git team provider

--
Matthias
Re: No Git commands on Team menu [message #574397 is a reply to message #489024] Thu, 01 October 2009 18:35 Go to previous message
John Bito is currently offline John BitoFriend
Messages: 54
Registered: July 2009
Member
Matthias Sohn wrote:
> According to http://dev.eclipse.org/mhonarc/lists/egit-dev/msg00015.html
> it seems Shawn was able to switch from the old to the new plugin by
> following the sequence :
> - remove the old feature and plugins
> - install the new one
> - delete projects from Eclipse workspace (instead you may of course move
> them somewhere else)
> - re-import the projects
> - re-attach the projects to the Git team provider

Thanks, Matthias! I'll try deleting and re-importing projects on
another workspace and see if that keeps things in order.
Re: No Git commands on Team menu [message #574420 is a reply to message #489187] Thu, 01 October 2009 22:23 Go to previous message
Werner Keil is currently offline Werner KeilFriend
Messages: 1087
Registered: July 2009
Senior Member
Interesting, looks like the Git plugin gets somewhere near the other Team
plugins ?;-)
Previous Topic:Mylyn Git Branching Integration
Next Topic:JGit question
Goto Forum:
  


Current Time: Tue Aug 16 08:19:16 GMT 2022

Powered by FUDForum. Page generated in 0.01921 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top