Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Service Component Architecture (SCA) Tools » SCA build from source code
SCA build from source code [message #482481] Wed, 26 August 2009 18:04 Go to next message
Jamil Shaikh is currently offline Jamil ShaikhFriend
Messages: 10
Registered: July 2009
Junior Member
Hi All,

I think instructions to build SCA tools from the link:

http://wiki.eclipse.org/STP/SCA_Component/SCA_Build

has something missing. We are not able to build any features using he
instructions. The key part of the instructions which doesn't work are:

* Open the file site.xml (project org.eclipse.stp.sca.updatesite)
* Select the tab Site Map
* Click Build All

When we click Build All or individual features, nothing happens, not even
the errors? It is not a new issue, its like that for months.

Thanks,
Jamil
Re: SCA build from source code [message #482611 is a reply to message #482481] Thu, 27 August 2009 09:39 Go to previous messageGo to next message
Vincent Zurczak is currently offline Vincent ZurczakFriend
Messages: 149
Registered: July 2009
Senior Member

Hi Jamil,

I just tested it and it works.
Did you check out the features too? On the trunk, they are in a
directory called "features". Without them, the build cannot work.

Features are a way to group plug-ins together in a coherent package.


Vincent.




Jamil Shaikh a écrit :
> Hi All,
>
> I think instructions to build SCA tools from the link:
>
> http://wiki.eclipse.org/STP/SCA_Component/SCA_Build
>
> has something missing. We are not able to build any features using he
> instructions. The key part of the instructions which doesn't work are:
>
> * Open the file site.xml (project org.eclipse.stp.sca.updatesite)
> * Select the tab Site Map
> * Click Build All
> When we click Build All or individual features, nothing happens, not
> even the errors? It is not a new issue, its like that for months.
> Thanks,
> Jamil
>


--
Vincent Zurczak
EBM WebSourcing
+33 (0) 4 38 12 91 72
Re: SCA build from source code [message #482619 is a reply to message #482611] Thu, 27 August 2009 10:26 Go to previous message
Stephane Drapeau is currently offline Stephane DrapeauFriend
Messages: 199
Registered: July 2009
Senior Member
It also works for me.

Does a dialog box appear when you click on Build All?

Do you have warnings, like "Plugin reference org.eclipse.stp.sca....
cannot be resolved", in the Problem View? I updated the wiki page with
the plugins required for a build.

Do you have an old version of SCA Tools installed in your Eclipse? If
yes, can you try with a fresh Galileo install?

Stephane


Vincent Zurczak a écrit :
> Hi Jamil,
>
> I just tested it and it works.
> Did you check out the features too? On the trunk, they are in a
> directory called "features". Without them, the build cannot work.
>
> Features are a way to group plug-ins together in a coherent package.
>
>
> Vincent.
>
>
>
>
> Jamil Shaikh a écrit :
>> Hi All,
>>
>> I think instructions to build SCA tools from the link:
>>
>> http://wiki.eclipse.org/STP/SCA_Component/SCA_Build
>>
>> has something missing. We are not able to build any features using he
>> instructions. The key part of the instructions which doesn't work are:
>>
>> * Open the file site.xml (project org.eclipse.stp.sca.updatesite)
>> * Select the tab Site Map
>> * Click Build All
>> When we click Build All or individual features, nothing happens, not
>> even the errors? It is not a new issue, its like that for months.
>> Thanks,
>> Jamil
>>
>
>
Re: SCA build from source code [message #575913 is a reply to message #482481] Thu, 27 August 2009 09:39 Go to previous message
Vincent Zurczak is currently offline Vincent ZurczakFriend
Messages: 149
Registered: July 2009
Senior Member

Hi Jamil,

I just tested it and it works.
Did you check out the features too? On the trunk, they are in a
directory called "features". Without them, the build cannot work.

Features are a way to group plug-ins together in a coherent package.


Vincent.




Jamil Shaikh a écrit :
> Hi All,
>
> I think instructions to build SCA tools from the link:
>
> http://wiki.eclipse.org/STP/SCA_Component/SCA_Build
>
> has something missing. We are not able to build any features using he
> instructions. The key part of the instructions which doesn't work are:
>
> * Open the file site.xml (project org.eclipse.stp.sca.updatesite)
> * Select the tab Site Map
> * Click Build All
> When we click Build All or individual features, nothing happens, not
> even the errors? It is not a new issue, its like that for months.
> Thanks,
> Jamil
>


--
Vincent Zurczak
EBM WebSourcing
+33 (0) 4 38 12 91 72
Re: SCA build from source code [message #575925 is a reply to message #482611] Thu, 27 August 2009 10:26 Go to previous message
Stephane Drapeau is currently offline Stephane DrapeauFriend
Messages: 199
Registered: July 2009
Senior Member
It also works for me.

Does a dialog box appear when you click on Build All?

Do you have warnings, like "Plugin reference org.eclipse.stp.sca....
cannot be resolved", in the Problem View? I updated the wiki page with
the plugins required for a build.

Do you have an old version of SCA Tools installed in your Eclipse? If
yes, can you try with a fresh Galileo install?

Stephane


Vincent Zurczak a écrit :
> Hi Jamil,
>
> I just tested it and it works.
> Did you check out the features too? On the trunk, they are in a
> directory called "features". Without them, the build cannot work.
>
> Features are a way to group plug-ins together in a coherent package.
>
>
> Vincent.
>
>
>
>
> Jamil Shaikh a écrit :
>> Hi All,
>>
>> I think instructions to build SCA tools from the link:
>>
>> http://wiki.eclipse.org/STP/SCA_Component/SCA_Build
>>
>> has something missing. We are not able to build any features using he
>> instructions. The key part of the instructions which doesn't work are:
>>
>> * Open the file site.xml (project org.eclipse.stp.sca.updatesite)
>> * Select the tab Site Map
>> * Click Build All
>> When we click Build All or individual features, nothing happens, not
>> even the errors? It is not a new issue, its like that for months.
>> Thanks,
>> Jamil
>>
>
>
Previous Topic:SCA build from source code
Next Topic:Missing 'Generate Java Skeleton' function
Goto Forum:
  


Current Time: Sat Nov 17 20:12:05 GMT 2018

Powered by FUDForum. Page generated in 0.01568 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top