Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] Executing ATL transformations by using ANT scripts: profiled models
[ATL] Executing ATL transformations by using ANT scripts: profiled models [message #48875] Mon, 25 June 2007 11:43 Go to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
Hello,
I am trying to execute a transformation from an ANT script whose source
model is a stereotyped class diagram.
A part of the script is:


<am3.loadModel name="IN" metamodel="UML2"
path="${inputModelsPath}FirstStereotypedClassDiagram.uml2"/ >

I have the error:
[am3.loadModel] Loading of model IN

[am3.loadModel] org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package
with uri 'http:///Profile_15_E25RgN3OEdudm7Bb3-eRQg.profile.uml2' not found.
(platform:/resource/Prueba/src/prueba/popup/actions/InputMod els/FirstStereotypedClassDiagram.uml2,
137, -1)

Does anybody know if I have to load the applied Profile too?

Thank you
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #48906 is a reply to message #48875] Mon, 25 June 2007 12:05 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
I have also tried to execute another transformation and I get another error.
The extrange thing is that this transformation works when I execute it
without using the script. Why?



"Bea" <beaperez@unizar.es> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #48935 is a reply to message #48875] Mon, 25 June 2007 12:10 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Hugo.Bruneliere.univ-nantes.fr

Bea a écrit :
> Hello,

Hello Bea,

> I am trying to execute a transformation from an ANT script whose source
> model is a stereotyped class diagram.
> A part of the script is:
>
>
> <am3.loadModel name="IN" metamodel="UML2"
> path="${inputModelsPath}FirstStereotypedClassDiagram.uml2"/ >
>
> I have the error:
> [am3.loadModel] Loading of model IN
>
> [am3.loadModel] org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package
> with uri 'http:///Profile_15_E25RgN3OEdudm7Bb3-eRQg.profile.uml2' not found.
> (platform:/resource/Prueba/src/prueba/popup/actions/InputMod els/FirstStereotypedClassDiagram.uml2,
> 137, -1)
>
> Does anybody know if I have to load the applied Profile too?
>

Yes, you also have to load the "profile" model using the same way as for
another UML2 model.

> Thank you
>
>
>

Best regards,

Hugo

--
--------------------------------------------------------
Hugo Bruneliere - R&D Engineer
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssiniere
44322 Nantes Cedex 3 - France
office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
EMail: Hugo.Bruneliere@univ-nantes.fr
http://www.sciences.univ-nantes.fr/lina/atl/
--------------------------------------------------------
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #48963 is a reply to message #48935] Mon, 25 June 2007 12:16 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
Thank you Hugo, but I get the same error. I have:

<am3.loadModel name="ProIni" metamodel="UML2"
path="${inputModelsPath}Profile.profile.uml2"/>
<am3.loadModel name="IN" metamodel="UML2"
path="${inputModelsPath}FirstStereotypedClassDiagram.uml2"/ >

And I get:
[am3.loadModel] Loading of model ProIni

[am3.loadModel] Loading of model IN

[am3.loadModel] org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package
with uri 'http:///Profile_15_E25RgN3OEdudm7Bb3-eRQg.profile.uml2' not found.
(platform:/resource/Prueba/src/prueba/popup/actions/InputMod els/FirstStereotypedClassDiagram.uml2,
137, -1)

Any idea?


"Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49012 is a reply to message #48963] Mon, 25 June 2007 12:34 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Hugo.Bruneliere.univ-nantes.fr

Bea a écrit :
> Thank you Hugo, but I get the same error. I have:
>
> <am3.loadModel name="ProIni" metamodel="UML2"
> path="${inputModelsPath}Profile.profile.uml2"/>
> <am3.loadModel name="IN" metamodel="UML2"
> path="${inputModelsPath}FirstStereotypedClassDiagram.uml2"/ >
>
> And I get:
> [am3.loadModel] Loading of model ProIni
>
> [am3.loadModel] Loading of model IN
>
> [am3.loadModel] org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package
> with uri 'http:///Profile_15_E25RgN3OEdudm7Bb3-eRQg.profile.uml2' not found.
> (platform:/resource/Prueba/src/prueba/popup/actions/InputMod els/FirstStereotypedClassDiagram.uml2,
> 137, -1)
>
> Any idea?
>

By default, the model handler used by the "loadModel" task is EMF.
You may use the UML2 model handler for loading UML2 models and metamodels:

<am3.loadModel modelHandler="UML2" name="UML2" metamodel="MOF"
nsUri="http://www.eclipse.org/uml2/2.0.0/UML"/>

<am3.loadModel modelHandler="UML2" name="ProIni" metamodel="UML2"
path="${inputModelsPath}Profile.profile.uml2"/>
<am3.loadModel modelHandler="UML2" name="IN" metamodel="UML2"
path="${inputModelsPath}FirstStereotypedClassDiagram.uml2"/ >

You can get the UML2 model handler by checking out the
"org.eclipse.m2m.atl.drivers.uml24atl" plugin from the Eclipse CVS
(see http://wiki.eclipse.org/index.php/ATL/How_Install_ATL_From_C VS/).
Note that this plugin also requires Eclipse/MDT UML2 to be installed.


>
> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el mensaje
> news:f5obbi$1bs$1@build.eclipse.org...
>> Bea a écrit :
>>> Hello,
>> Hello Bea,
>>
>>> I am trying to execute a transformation from an ANT script whose source
>>> model is a stereotyped class diagram.
>>> A part of the script is:
>>>
>>>
>>> <am3.loadModel name="IN" metamodel="UML2"
>>> path="${inputModelsPath}FirstStereotypedClassDiagram.uml2"/ >
>>>
>>> I have the error:
>>> [am3.loadModel] Loading of model IN
>>>
>>> [am3.loadModel] org.eclipse.emf.ecore.xmi.PackageNotFoundException:
>>> Package with uri 'http:///Profile_15_E25RgN3OEdudm7Bb3-eRQg.profile.uml2'
>>> not found.
>>> (platform:/resource/Prueba/src/prueba/popup/actions/InputMod els/FirstStereotypedClassDiagram.uml2,
>>> 137, -1)
>>>
>>> Does anybody know if I have to load the applied Profile too?
>>>
>> Yes, you also have to load the "profile" model using the same way as for
>> another UML2 model.
>>
>>> Thank you
>>>
>>>
>>>
>> Best regards,
>>
>> Hugo
>>
>> --
>> --------------------------------------------------------
>> Hugo Bruneliere - R&D Engineer
>> ATLAS Group (INRIA & LINA) - University of Nantes
>> 2, rue de la Houssiniere
>> 44322 Nantes Cedex 3 - France
>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>> EMail: Hugo.Bruneliere@univ-nantes.fr
>> http://www.sciences.univ-nantes.fr/lina/atl/
>> --------------------------------------------------------
>
>


--
--------------------------------------------------------
Hugo Bruneliere - R&D Engineer
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssiniere
44322 Nantes Cedex 3 - France
office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
EMail: Hugo.Bruneliere@univ-nantes.fr
http://www.sciences.univ-nantes.fr/lina/atl/
--------------------------------------------------------
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49033 is a reply to message #49012] Mon, 25 June 2007 16:09 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
I have done that but It doesn't work. I think that I do something wrong. I
am using Eclipse 3.1 and I have had to check out more plugins that
org.eclipse.m2m.atl.drivers.uml24atl, and org.eclipse.mdt/org.eclipse.uml
(such as org.eclipse.m2m.atl.drivers.emf4atl, or
org.eclipse.m2m.atl.engine.vm). It is the first time that I use CVS but
doing that I get several projects in my workspace, is it ok? After doing
that I have some errors in those new projects.
What am I doing wrong?



"Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49059 is a reply to message #49033] Mon, 25 June 2007 16:31 Go to previous messageGo to next message
William Piers is currently offline William PiersFriend
Messages: 297
Registered: July 2009
Senior Member
Bea a écrit :
> I have done that but It doesn't work. I think that I do something wrong. I
> am using Eclipse 3.1 and I have had to check out more plugins that
> org.eclipse.m2m.atl.drivers.uml24atl, and org.eclipse.mdt/org.eclipse.uml
> (such as org.eclipse.m2m.atl.drivers.emf4atl, or
> org.eclipse.m2m.atl.engine.vm). It is the first time that I use CVS but
> doing that I get several projects in my workspace, is it ok? After doing
> that I have some errors in those new projects.
> What am I doing wrong?

Hello,

I don't think you did anything wrong, but according to this page :
http://wiki.eclipse.org/index.php/ATL/How_Install_ATL_From_C VS/
You must install mdr-standalone and antlr libraries into your new
projects. The compilation errors you are talking about are probably
caused by that.

Regards,

William Piers
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49088 is a reply to message #49059] Mon, 25 June 2007 16:35 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
Hello,
do you know if I all these new projects have to be directly in the workspace
or in my plug-in project?



"William Piers" <william.piers@obeo.fr> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49117 is a reply to message #49088] Mon, 25 June 2007 16:42 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
The thing is that following the Hugo's email, I only have to check out
org.eclipse.m2m.atl.drivers.uml24atl and org.eclipse.mdt/org.eclipse.uml.
And following
http://wiki.eclipse.org/index.php/ATL/How_Install_ATL_From_C VS/ I don't have
to do anything with these plugins.




"Bea" <beaperez@unizar.es> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49146 is a reply to message #49117] Mon, 25 June 2007 16:47 Go to previous messageGo to next message
William Piers is currently offline William PiersFriend
Messages: 297
Registered: July 2009
Senior Member
> Hello,
> do you know if I all these new projects have to be directly in the workspace
> or in my plug-in project?
They have to be directly in the workspace.

Bea a écrit :
> The thing is that following the Hugo's email, I only have to check out
> org.eclipse.m2m.atl.drivers.uml24atl and org.eclipse.mdt/org.eclipse.uml.
> And following
> http://wiki.eclipse.org/index.php/ATL/How_Install_ATL_From_C VS/ I don't have
> to do anything with these plugins.

Ok, sorry. I thought that you checked out mdr4atl too, which requires
additional libraries.

William Piers
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49175 is a reply to message #49146] Mon, 25 June 2007 17:50 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
I have checked out those two plugins. The
org.eclipse.m2m.atl.drivers.uml24atl project has errors because it doesn't
find some packages. I have added pluging dependencies in order not to have
any error and I get it, but I have the same error with the UML2 model
handler,
Any idea?
Thank you in advance.


"William Piers" <william.piers@obeo.fr> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49219 is a reply to message #49175] Tue, 26 June 2007 09:18 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Hugo.Bruneliere.univ-nantes.fr

Hello Bea,

Bea a écrit :
> I have checked out those two plugins. The
> org.eclipse.m2m.atl.drivers.uml24atl project has errors because it doesn't
> find some packages. I have added pluging dependencies in order not to have
> any error and I get it, but I have the same error with the UML2 model
> handler,
> Any idea?
> Thank you in advance.
>

I am sorry if you encountered some problems because of my yesterday's
email. I thought you were already using ATL sources instead of ATL
binaries, that's why I told you to checkout the "uml24atl" driver from
the Eclipse CVS.

In order to always get the latest version of ATL and its IDE, I advise
you to use the ATL sources instead of using the binaries versions
available from the ATL download page.

To do so, you have to follow the process described in the Wiki page "How
Install ATL From CVS". You must checkout the ATL plugins into the
workspace of a first Eclipse and then you have to launch a second
Eclipse from the first one in order to load the plugins. You can work
using ATL in the second Eclipse.
Note that you don't need to checkout the "mdr4atl" driver's plugin if
you don't need to use MDR as model handler (and I think it's the case).

You may also follow the same process for the AM3 plugins except that:
--> the repository path is "/cvsroot/technology" (instead of
"/cvsroot/modeling")
--> the plugins to checkout are in "HEAD->org.eclipse.gmt->AM3"
|-> org.eclipse.am3.core, org.eclipse.am3.tools.tge,
org.eclipse.am3.ui, org.eclipse.gmt.am3.dsls.km3,
org.eclipse.gmt.am3.tools.ant

I hope this will help you.

Best regards,

Hugo

>
> "William Piers" <william.piers@obeo.fr> escribió en el mensaje
> news:f5ork4$524$1@build.eclipse.org...
>>> Hello,
>>> do you know if I all these new projects have to be directly in the
>>> workspace or in my plug-in project?
>> They have to be directly in the workspace.
>>
>> Bea a écrit :
>>> The thing is that following the Hugo's email, I only have to check out
>>> org.eclipse.m2m.atl.drivers.uml24atl and org.eclipse.mdt/org.eclipse.uml.
>>> And following
>>> http://wiki.eclipse.org/index.php/ATL/How_Install_ATL_From_C VS/ I don't
>>> have to do anything with these plugins.
>> Ok, sorry. I thought that you checked out mdr4atl too, which requires
>> additional libraries.
>>
>> William Piers
>
>


--
--------------------------------------------------------
Hugo Bruneliere - R&D Engineer
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssiniere
44322 Nantes Cedex 3 - France
office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
EMail: Hugo.Bruneliere@univ-nantes.fr
http://www.sciences.univ-nantes.fr/lina/atl/
--------------------------------------------------------
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49323 is a reply to message #49219] Tue, 26 June 2007 09:59 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
Thank you very much Hugo, but It doesn't work. When I check out the plugins
almost all of them have errors (they have the red cross), so when I try to
lunch the second Eclipse, an error window appears.
I am a bit lost, I would be very grateful if you could help me.


"Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49353 is a reply to message #49323] Tue, 26 June 2007 11:48 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
Now I only have errors in the org.eclipse.m2m.atl.drivers.uml24atl and
org.eclipse.m2m.atl.adt.editor plugins.
I am using the ATLBundle-20060501.





"Bea" <beaperez@unizar.es> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49383 is a reply to message #49353] Tue, 26 June 2007 13:31 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Hugo.Bruneliere.univ-nantes.fr

Bea a écrit :
> Now I only have errors in the org.eclipse.m2m.atl.drivers.uml24atl and
> org.eclipse.m2m.atl.adt.editor plugins.
> I am using the ATLBundle-20060501.

The problem is that the latest versions of ATL are not compatible with
this version of the bundle (as the ATL component has moved from the GMT
to the M2M project).

The better solution is to install a new Eclipse with only the EMF and
UML2 plugins. Then, you can launch this Eclipse and checkout the ATL &
AM3 plugins as I explained in my previous email. Finally, you can start
another Eclipse from the first one to load the ATL & AM3 plugins.

We are currently testing the latest ATL & AM3 version with the Eclipse
Europa release (i.e. Eclipse 3.3, EMF 2.3, UML2 2.1) and we don't find
any major problem for the moment. You can download these versions.

By doing that, you will have the latest version of ATL ;-)

>
>
> "Bea" <beaperez@unizar.es> escribió en el mensaje
> news:f5qo36$4pv$1@build.eclipse.org...
>> Thank you very much Hugo, but It doesn't work. When I check out the
>> plugins almost all of them have errors (they have the red cross), so when
>> I try to lunch the second Eclipse, an error window appears.
>> I am a bit lost, I would be very grateful if you could help me.
>>
>>
>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el mensaje
>> news:f5qlka$tth$1@build.eclipse.org...
>>> Hello Bea,
>>>
>>> Bea a écrit :
>>>> I have checked out those two plugins. The
>>>> org.eclipse.m2m.atl.drivers.uml24atl project has errors because it
>>>> doesn't find some packages. I have added pluging dependencies in order
>>>> not to have any error and I get it, but I have the same error with the
>>>> UML2 model handler,
>>>> Any idea?
>>>> Thank you in advance.
>>>>
>>> I am sorry if you encountered some problems because of my yesterday's
>>> email. I thought you were already using ATL sources instead of ATL
>>> binaries, that's why I told you to checkout the "uml24atl" driver from
>>> the Eclipse CVS.
>>>
>>> In order to always get the latest version of ATL and its IDE, I advise
>>> you to use the ATL sources instead of using the binaries versions
>>> available from the ATL download page.
>>>
>>> To do so, you have to follow the process described in the Wiki page "How
>>> Install ATL From CVS". You must checkout the ATL plugins into the
>>> workspace of a first Eclipse and then you have to launch a second Eclipse
>>> from the first one in order to load the plugins. You can work using ATL
>>> in the second Eclipse.
>>> Note that you don't need to checkout the "mdr4atl" driver's plugin if you
>>> don't need to use MDR as model handler (and I think it's the case).
>>>
>>> You may also follow the same process for the AM3 plugins except that:
>>> --> the repository path is "/cvsroot/technology" (instead of
>>> "/cvsroot/modeling")
>>> --> the plugins to checkout are in "HEAD->org.eclipse.gmt->AM3"
>>> |-> org.eclipse.am3.core, org.eclipse.am3.tools.tge, org.eclipse.am3.ui,
>>> org.eclipse.gmt.am3.dsls.km3, org.eclipse.gmt.am3.tools.ant
>>>
>>> I hope this will help you.
>>>
>>> Best regards,
>>>
>>> Hugo
>>>
>>>> "William Piers" <william.piers@obeo.fr> escribió en el mensaje
>>>> news:f5ork4$524$1@build.eclipse.org...
>>>>>> Hello,
>>>>>> do you know if I all these new projects have to be directly in the
>>>>>> workspace or in my plug-in project?
>>>>> They have to be directly in the workspace.
>>>>>
>>>>> Bea a écrit :
>>>>>> The thing is that following the Hugo's email, I only have to check out
>>>>>> org.eclipse.m2m.atl.drivers.uml24atl and
>>>>>> org.eclipse.mdt/org.eclipse.uml. And following
>>>>>> http://wiki.eclipse.org/index.php/ATL/How_Install_ATL_From_C VS/ I
>>>>>> don't have to do anything with these plugins.
>>>>> Ok, sorry. I thought that you checked out mdr4atl too, which requires
>>>>> additional libraries.
>>>>>
>>>>> William Piers
>>>>
>>>
>>> --
>>> --------------------------------------------------------
>>> Hugo Bruneliere - R&D Engineer
>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>> 2, rue de la Houssiniere
>>> 44322 Nantes Cedex 3 - France
>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>> --------------------------------------------------------
>>
>
>


--
--------------------------------------------------------
Hugo Bruneliere - R&D Engineer
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssiniere
44322 Nantes Cedex 3 - France
office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
EMail: Hugo.Bruneliere@univ-nantes.fr
http://www.sciences.univ-nantes.fr/lina/atl/
--------------------------------------------------------
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49442 is a reply to message #49383] Tue, 26 June 2007 15:15 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
Nothing I get the same errors in those two packages. I am trying with
Eclipse 3.1 because all my models are created in UML2 for that version. I
don't know what to do. Any help?


"Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49502 is a reply to message #49442] Tue, 26 June 2007 18:19 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
I need org.eclipse.uml2.uml.jar and org.eclipse.core.runtime.ListenerList,
Does anybody know where I can find these .jar?


"Bea" <beaperez@unizar.es> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49532 is a reply to message #49502] Tue, 26 June 2007 19:06 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
I have installed Eclipse 3.1, with EMF and UML2 1.1.1.
I have check out ATL and AM3 as you have explained to me.
But I get some errors in org.eclipse.m2m.atl.adt.editor and
org.eclipse.m2m.atl.drivers.uml24atl. Perhaps I need to check out those
plugins (ATL and AM3) from another repository?




"Bea" <beaperez@unizar.es> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49716 is a reply to message #49383] Wed, 27 June 2007 14:31 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jean-pierre.bourey.ec-lille.fr

Hi everybody,

Following your Hugo's advices, I have just installed (from scratch)
-Eclipse 3.3 (Build I20070621-1340),
-EMF 2.3 (v200706251320)
-MDT-UML2 (v200706251652)
and from CVS, the latest version of ATL and AM3 plugins.

I have written a simple transformation from Petri Nets to UML Activity
Diagrams
When I run the transformation by the menu "Run->Open Run Dialog" using the
parameters you can see on the screenshot in attached file named "run
configuration.png" , I obtain the result I expected and I can open the
result with the UML editor (screenshot in the attached file
"expectedResult.png")

But, when I use the build.xml script (see atteched file) , I can't open the
result with the UML editor. When I compare the 2 files I see

1) in the "good" result ("manual" run configuration) :
------------------------------------------------------------ --------------------
<?xml version="1.0" encoding="ISO-8859-1"?>
<uml:Model xmi:version="2.1" xmlns:xmi="http://schema.omg.org/spec/XMI/2.1"
xmlns:uml="http://www.eclipse.org/uml2/2.1.0/UML"
xmi:id="_28NZICS3EdyzOPBFDStLfg" name="FirstPN">
<packagedElement xmi:type="uml:Activity" xmi:id="_28NZISS3EdyzOPBFDStLfg"
name="PN_Example1">
<node xmi:type="uml:OpaqueAction" xmi:id="_28NZIiS3EdyzOPBFDStLfg" name="P2"
outgoing="_28NZKiS3EdyzOPBFDStLfg" incoming="_28NZKCS3EdyzOPBFDStLfg"/>
<node xmi:type="uml:OpaqueAction" xmi:id="_28NZIyS3EdyzOPBFDStLfg" name="P1"
outgoing="_28NZKCS3EdyzOPBFDStLfg" incoming="_28NZJyS3EdyzOPBFDStLfg"/>
<node xmi:type="uml:InitialNode" xmi:id="_28NZJCS3EdyzOPBFDStLfg"
outgoing="_28NZJSS3EdyzOPBFDStLfg"/>
<node xmi:type="uml:MergeNode" xmi:id="_28NZJiS3EdyzOPBFDStLfg" name="MG_P1"
outgoing="_28NZJyS3EdyzOPBFDStLfg" incoming="_28NZJSS3EdyzOPBFDStLfg
_28NZKiS3EdyzOPBFDStLfg"/>
<edge xmi:type="uml:ControlFlow" xmi:id="_28NZJSS3EdyzOPBFDStLfg"
source="_28NZJCS3EdyzOPBFDStLfg" target="_28NZJiS3EdyzOPBFDStLfg"/>
<edge xmi:type="uml:ControlFlow" xmi:id="_28NZJyS3EdyzOPBFDStLfg"
source="_28NZJiS3EdyzOPBFDStLfg" target="_28NZIyS3EdyzOPBFDStLfg"/>
<edge xmi:type="uml:ControlFlow" xmi:id="_28NZKCS3EdyzOPBFDStLfg" name="T1"
source="_28NZIyS3EdyzOPBFDStLfg" target="_28NZIiS3EdyzOPBFDStLfg">
<weight xmi:type="uml:LiteralInteger" xmi:id="_28NZKSS3EdyzOPBFDStLfg"
name="weight of P1->T1"/>
</edge>
<edge xmi:type="uml:ControlFlow" xmi:id="_28NZKiS3EdyzOPBFDStLfg" name="T2"
source="_28NZIiS3EdyzOPBFDStLfg" target="_28NZJiS3EdyzOPBFDStLfg">
<weight xmi:type="uml:LiteralInteger" xmi:id="_28NZKyS3EdyzOPBFDStLfg"
name="weight of P2->T2"/>
</edge>
</packagedElement>
</uml:Model>
------------------------------------------------------------ --------------------



2) in the bad result (with ant script)
------------------------------------------------------------ --------------------
<?xml version="1.0" encoding="ISO-8859-1"?>
<uml:Model xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:uml="http://www.eclipse.org/uml2/2.1.0/UML" name="FirstPN">
<packagedElement xsi:type="uml:Activity" name="PN_Example1">
<node xsi:type="uml:OpaqueAction" name="P2" outgoing="//PN_Example1/T2"
incoming="//PN_Example1/T1"/>
<node xsi:type="uml:OpaqueAction" name="P1" outgoing="//PN_Example1/T1"
incoming="//PN_Example1/@edge.1"/>
<node xsi:type="uml:InitialNode" outgoing="//PN_Example1/@edge.0"/>
<node xsi:type="uml:MergeNode" name="MG_P1" outgoing="//PN_Example1/@edge.1"
incoming="//PN_Example1/@edge.0 //PN_Example1/T2"/>
<edge xsi:type="uml:ControlFlow" source="//PN_Example1/@node.2"
target="//PN_Example1/MG_P1"/>
<edge xsi:type="uml:ControlFlow" source="//PN_Example1/MG_P1"
target="//PN_Example1/P1"/>
<edge xsi:type="uml:ControlFlow" name="T1" source="//PN_Example1/P1"
target="//PN_Example1/P2">
<weight xsi:type="uml:LiteralInteger" name="weight of P1->T1"/>
</edge>
<edge xsi:type="uml:ControlFlow" name="T2" source="//PN_Example1/P2"
target="//PN_Example1/MG_P1">
<weight xsi:type="uml:LiteralInteger" name="weight of P2->T2"/>
</edge>
</packagedElement>
</uml:Model>
------------------------------------------------------------ -----------------

My questions are :
1) why are they different? (especially xmiversion and links betweens
elements)
2) how to get the same (good) result with ant script?

Subsidiary questions:
3) when I use UML2 as model handler for the UML metamodel, it works with the
configuration dialog box, but raises an exception with the ant script
3) when I try to use UML2 as model handler for the Petri net metamodel
(using PetriNetMM.uml as file), it raises an exception with both run methods

Any help will be very appreciated
best regards
jean-pierre




"Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> a
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49747 is a reply to message #49716] Wed, 27 June 2007 15:20 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Hugo.Bruneliere.univ-nantes.fr

Hello Jean-Pierre,

Jean-Pierre Bourey a écrit :
> Hi everybody,
>
> Following your Hugo's advices, I have just installed (from scratch)
> -Eclipse 3.3 (Build I20070621-1340),
> -EMF 2.3 (v200706251320)
> -MDT-UML2 (v200706251652)
> and from CVS, the latest version of ATL and AM3 plugins.
>
> I have written a simple transformation from Petri Nets to UML Activity
> Diagrams
> When I run the transformation by the menu "Run->Open Run Dialog" using the
> parameters you can see on the screenshot in attached file named "run
> configuration.png" , I obtain the result I expected and I can open the
> result with the UML editor (screenshot in the attached file
> "expectedResult.png")
>
> But, when I use the build.xml script (see atteched file) , I can't open the
> result with the UML editor. When I compare the 2 files I see
>
> 1) in the "good" result ("manual" run configuration) :
> ------------------------------------------------------------ --------------------
> <?xml version="1.0" encoding="ISO-8859-1"?>
> <uml:Model xmi:version="2.1" xmlns:xmi="http://schema.omg.org/spec/XMI/2.1"
> xmlns:uml="http://www.eclipse.org/uml2/2.1.0/UML"
> xmi:id="_28NZICS3EdyzOPBFDStLfg" name="FirstPN">
> <packagedElement xmi:type="uml:Activity" xmi:id="_28NZISS3EdyzOPBFDStLfg"
> name="PN_Example1">
> <node xmi:type="uml:OpaqueAction" xmi:id="_28NZIiS3EdyzOPBFDStLfg" name="P2"
> outgoing="_28NZKiS3EdyzOPBFDStLfg" incoming="_28NZKCS3EdyzOPBFDStLfg"/>
> <node xmi:type="uml:OpaqueAction" xmi:id="_28NZIyS3EdyzOPBFDStLfg" name="P1"
> outgoing="_28NZKCS3EdyzOPBFDStLfg" incoming="_28NZJyS3EdyzOPBFDStLfg"/>
> <node xmi:type="uml:InitialNode" xmi:id="_28NZJCS3EdyzOPBFDStLfg"
> outgoing="_28NZJSS3EdyzOPBFDStLfg"/>
> <node xmi:type="uml:MergeNode" xmi:id="_28NZJiS3EdyzOPBFDStLfg" name="MG_P1"
> outgoing="_28NZJyS3EdyzOPBFDStLfg" incoming="_28NZJSS3EdyzOPBFDStLfg
> _28NZKiS3EdyzOPBFDStLfg"/>
> <edge xmi:type="uml:ControlFlow" xmi:id="_28NZJSS3EdyzOPBFDStLfg"
> source="_28NZJCS3EdyzOPBFDStLfg" target="_28NZJiS3EdyzOPBFDStLfg"/>
> <edge xmi:type="uml:ControlFlow" xmi:id="_28NZJyS3EdyzOPBFDStLfg"
> source="_28NZJiS3EdyzOPBFDStLfg" target="_28NZIyS3EdyzOPBFDStLfg"/>
> <edge xmi:type="uml:ControlFlow" xmi:id="_28NZKCS3EdyzOPBFDStLfg" name="T1"
> source="_28NZIyS3EdyzOPBFDStLfg" target="_28NZIiS3EdyzOPBFDStLfg">
> <weight xmi:type="uml:LiteralInteger" xmi:id="_28NZKSS3EdyzOPBFDStLfg"
> name="weight of P1->T1"/>
> </edge>
> <edge xmi:type="uml:ControlFlow" xmi:id="_28NZKiS3EdyzOPBFDStLfg" name="T2"
> source="_28NZIiS3EdyzOPBFDStLfg" target="_28NZJiS3EdyzOPBFDStLfg">
> <weight xmi:type="uml:LiteralInteger" xmi:id="_28NZKyS3EdyzOPBFDStLfg"
> name="weight of P2->T2"/>
> </edge>
> </packagedElement>
> </uml:Model>
> ------------------------------------------------------------ --------------------
>
>
>
> 2) in the bad result (with ant script)
> ------------------------------------------------------------ --------------------
> <?xml version="1.0" encoding="ISO-8859-1"?>
> <uml:Model xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xmlns:uml="http://www.eclipse.org/uml2/2.1.0/UML" name="FirstPN">
> <packagedElement xsi:type="uml:Activity" name="PN_Example1">
> <node xsi:type="uml:OpaqueAction" name="P2" outgoing="//PN_Example1/T2"
> incoming="//PN_Example1/T1"/>
> <node xsi:type="uml:OpaqueAction" name="P1" outgoing="//PN_Example1/T1"
> incoming="//PN_Example1/@edge.1"/>
> <node xsi:type="uml:InitialNode" outgoing="//PN_Example1/@edge.0"/>
> <node xsi:type="uml:MergeNode" name="MG_P1" outgoing="//PN_Example1/@edge.1"
> incoming="//PN_Example1/@edge.0 //PN_Example1/T2"/>
> <edge xsi:type="uml:ControlFlow" source="//PN_Example1/@node.2"
> target="//PN_Example1/MG_P1"/>
> <edge xsi:type="uml:ControlFlow" source="//PN_Example1/MG_P1"
> target="//PN_Example1/P1"/>
> <edge xsi:type="uml:ControlFlow" name="T1" source="//PN_Example1/P1"
> target="//PN_Example1/P2">
> <weight xsi:type="uml:LiteralInteger" name="weight of P1->T1"/>
> </edge>
> <edge xsi:type="uml:ControlFlow" name="T2" source="//PN_Example1/P2"
> target="//PN_Example1/MG_P1">
> <weight xsi:type="uml:LiteralInteger" name="weight of P2->T2"/>
> </edge>
> </packagedElement>
> </uml:Model>
> ------------------------------------------------------------ -----------------
>
> My questions are :
> 1) why are they different? (especially xmiversion and links betweens
> elements)

This "good" result is obtained because the model is serialized using the
UML driver (and extractor) whereas the "bad" result is obtained because
the model is serialized using the EMF driver (and extractor).

> 2) how to get the same (good) result with ant script?

You have to load the UML2 metamodel with the UML2 modelHandler (see
answer to your question 3) and to precise a path in the "outModel" markup:

<outModel name="OUT" model="targetUmlModel" metamodel="UML2MM"
path="/PN2UMLAD/OutputModels/${model}.uml">

and keep the call to the "saveModel" task as it is.

Doing this, it may works.

> Subsidiary questions:
> 3) when I use UML2 as model handler for the UML metamodel, it works with the
> configuration dialog box, but raises an exception with the ant script

I do this

<am3.loadModel modelHandler="UML2" name="UML2" metamodel="MOF"
nsUri="http://www.eclipse.org/uml2/2.0.0/UML"/>

and do not see any error. Do you have checked-out the latest version of
AM3 (committed today afternoon)?

Do you still have errors with this latest version?

> 3) when I try to use UML2 as model handler for the Petri net metamodel
> (using PetriNetMM.uml as file), it raises an exception with both run methods
>

"PetriNetMM.uml" is a UML2 model, i.e. a model that conforms to the UML2
metamodel (which conforms to the MOF metametamodel). This is not a
metamodel, but it is possible to generate a metamodel from this UML
model: see http://www.eclipse.org/m2m/atl/usecases/UML2MOF/

Best regards,

Hugo

> Any help will be very appreciated
> best regards
> jean-pierre
>
>
>
>
> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> a écrit dans le message
> de news: f5r4fg$8s3$1@build.eclipse.org...
>> Bea a écrit :
>>> Now I only have errors in the org.eclipse.m2m.atl.drivers.uml24atl and
>>> org.eclipse.m2m.atl.adt.editor plugins.
>>> I am using the ATLBundle-20060501.
>> The problem is that the latest versions of ATL are not compatible with
>> this version of the bundle (as the ATL component has moved from the GMT
>> to the M2M project).
>>
>> The better solution is to install a new Eclipse with only the EMF and
>> UML2 plugins. Then, you can launch this Eclipse and checkout the ATL &
>> AM3 plugins as I explained in my previous email. Finally, you can start
>> another Eclipse from the first one to load the ATL & AM3 plugins.
>>
>> We are currently testing the latest ATL & AM3 version with the Eclipse
>> Europa release (i.e. Eclipse 3.3, EMF 2.3, UML2 2.1) and we don't find
>> any major problem for the moment. You can download these versions.
>>
>> By doing that, you will have the latest version of ATL ;-)
>>
>>>
>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>> news:f5qo36$4pv$1@build.eclipse.org...
>>>> Thank you very much Hugo, but It doesn't work. When I check out the
>>>> plugins almost all of them have errors (they have the red cross), so
>>>> when
>>>> I try to lunch the second Eclipse, an error window appears.
>>>> I am a bit lost, I would be very grateful if you could help me.
>>>>
>>>>
>>>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el
>>>> mensaje
>>>> news:f5qlka$tth$1@build.eclipse.org...
>>>>> Hello Bea,
>>>>>
>>>>> Bea a écrit :
>>>>>> I have checked out those two plugins. The
>>>>>> org.eclipse.m2m.atl.drivers.uml24atl project has errors because it
>>>>>> doesn't find some packages. I have added pluging dependencies in order
>>>>>> not to have any error and I get it, but I have the same error with the
>>>>>> UML2 model handler,
>>>>>> Any idea?
>>>>>> Thank you in advance.
>>>>>>
>>>>> I am sorry if you encountered some problems because of my yesterday's
>>>>> email. I thought you were already using ATL sources instead of ATL
>>>>> binaries, that's why I told you to checkout the "uml24atl" driver from
>>>>> the Eclipse CVS.
>>>>>
>>>>> In order to always get the latest version of ATL and its IDE, I advise
>>>>> you to use the ATL sources instead of using the binaries versions
>>>>> available from the ATL download page.
>>>>>
>>>>> To do so, you have to follow the process described in the Wiki page
>>>>> "How
>>>>> Install ATL From CVS". You must checkout the ATL plugins into the
>>>>> workspace of a first Eclipse and then you have to launch a second
>>>>> Eclipse
>>>>> from the first one in order to load the plugins. You can work using ATL
>>>>> in the second Eclipse.
>>>>> Note that you don't need to checkout the "mdr4atl" driver's plugin if
>>>>> you
>>>>> don't need to use MDR as model handler (and I think it's the case).
>>>>>
>>>>> You may also follow the same process for the AM3 plugins except that:
>>>>> --> the repository path is "/cvsroot/technology" (instead of
>>>>> "/cvsroot/modeling")
>>>>> --> the plugins to checkout are in "HEAD->org.eclipse.gmt->AM3"
>>>>> |-> org.eclipse.am3.core, org.eclipse.am3.tools.tge,
>>>>> org.eclipse.am3.ui,
>>>>> org.eclipse.gmt.am3.dsls.km3, org.eclipse.gmt.am3.tools.ant
>>>>>
>>>>> I hope this will help you.
>>>>>
>>>>> Best regards,
>>>>>
>>>>> Hugo
>>>>>
>>>>>> "William Piers" <william.piers@obeo.fr> escribió en el mensaje
>>>>>> news:f5ork4$524$1@build.eclipse.org...
>>>>>>>> Hello,
>>>>>>>> do you know if I all these new projects have to be directly in the
>>>>>>>> workspace or in my plug-in project?
>>>>>>> They have to be directly in the workspace.
>>>>>>>
>>>>>>> Bea a écrit :
>>>>>>>> The thing is that following the Hugo's email, I only have to check
>>>>>>>> out
>>>>>>>> org.eclipse.m2m.atl.drivers.uml24atl and
>>>>>>>> org.eclipse.mdt/org.eclipse.uml. And following
>>>>>>>> http://wiki.eclipse.org/index.php/ATL/How_Install_ATL_From_C VS/ I
>>>>>>>> don't have to do anything with these plugins.
>>>>>>> Ok, sorry. I thought that you checked out mdr4atl too, which requires
>>>>>>> additional libraries.
>>>>>>>
>>>>>>> William Piers
>>>>> --
>>>>> --------------------------------------------------------
>>>>> Hugo Bruneliere - R&D Engineer
>>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>>> 2, rue de la Houssiniere
>>>>> 44322 Nantes Cedex 3 - France
>>>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>>> --------------------------------------------------------
>>>
>>
>> --
>> --------------------------------------------------------
>> Hugo Bruneliere - R&D Engineer
>> ATLAS Group (INRIA & LINA) - University of Nantes
>> 2, rue de la Houssiniere
>> 44322 Nantes Cedex 3 - France
>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>> EMail: Hugo.Bruneliere@univ-nantes.fr
>> http://www.sciences.univ-nantes.fr/lina/atl/
>> --------------------------------------------------------
>
>
> <project name="PN2UMLAD" default="transfo">
>
> <!-- Change this value if you want to use another input model -->
> <property name="model"
> value="MyFirstPetriNet"/>
>
> <target name="loadMetaModels">
> <!-- Load UML 2.1 metamodel-->
> <am3.loadModel modelHandler="EMF"
> name="UML2MM"
> metamodel="MOF"
> nsuri="http://www.eclipse.org/uml2/2.1.0/UML"/>
> <!-- Load PN metamodel-->
> <am3.loadModel modelHandler="EMF"
> name="PetriNetMM"
> metamodel="MOF"
> path="/PN2UMLAD/MetaModels/PetriNetMM.ecore"/>
> </target>
>
> <target name="transfo"
> depends="loadMetaModels">
> <!-- -->
> <am3.loadModel name="sourcePNModel"
> metamodel="PetriNetMM"
> path="/PN2UMLAD/InputModels/${model}.ecore"/>
>
> <am3.atl path="/PN2UMLAD/Transformations/PN2UMLAD_V3.asm">
> <inModel name="IN"
> model="sourcePNModel"/>
> <inModel name="UML2"
> model="UML2MM"/>
> <inModel name="PetriNetMM"
> model="PetriNetMM"/>
> <outModel name="OUT"
> model="targetUmlModel"
> metamodel="UML2MM"/>
> </am3.atl>
>
> <am3.saveModel model="targetUmlModel"
> path="/PN2UMLAD/OutputModels/${model}.uml"/>
>
> </target>
> </project>


--
--------------------------------------------------------
Hugo Bruneliere - R&D Engineer
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssiniere
44322 Nantes Cedex 3 - France
office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
EMail: Hugo.Bruneliere@univ-nantes.fr
http://www.sciences.univ-nantes.fr/lina/atl/
--------------------------------------------------------
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #49973 is a reply to message #49747] Thu, 28 June 2007 09:28 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jean-pierre.bourey.ec-lille.fr

Hi Hugo,

many thanks for your explanations and advices:
This morning
1) I checked out AM3
2) I added the "path" attribute in the "outModel" element
and...it works perfectly.

So thanks again for your preciouls help
best regards
jean-pierre

"Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> a
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #50119 is a reply to message #49532] Fri, 29 June 2007 09:44 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Hugo.Bruneliere.univ-nantes.fr

Bea a écrit :
> I have installed Eclipse 3.1, with EMF and UML2 1.1.1.
> I have check out ATL and AM3 as you have explained to me.
> But I get some errors in org.eclipse.m2m.atl.adt.editor and
> org.eclipse.m2m.atl.drivers.uml24atl. Perhaps I need to check out those
> plugins (ATL and AM3) from another repository?
>
>

Hello Bea,

I have submitted a bug and a patch in order to delete the dependence to
the UML2 plugin from the "uml24atl" driver:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=194894

So when the patch will be integrated, it may work ;-)

But in my opinion, your problem is more a problem of upward
compatibility in UML2 than a problem with ATL.
Are your UML2 1.1 models compatible with UML2 2.0 or 2.1? I have never
testing this so I don't know, but the Eclipse/MDT project may provide
some ways to ensure this compatibility (at least converters from a
version to another)...

I think you should now try to use latest versions of Eclipse, EMF and
UML2 or you will probably encounter more problems later.

Best regards,

Hugo

>
>
> "Bea" <beaperez@unizar.es> escribió en el mensaje
> news:f5rlbh$5u6$1@build.eclipse.org...
>> I need org.eclipse.uml2.uml.jar and org.eclipse.core.runtime.ListenerList,
>> Does anybody know where I can find these .jar?
>>
>>
>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>> news:f5raii$3bh$1@build.eclipse.org...
>>> Nothing I get the same errors in those two packages. I am trying with
>>> Eclipse 3.1 because all my models are created in UML2 for that version. I
>>> don't know what to do. Any help?
>>>
>>>
>>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el mensaje
>>> news:f5r4fg$8s3$1@build.eclipse.org...
>>>> Bea a écrit :
>>>>> Now I only have errors in the org.eclipse.m2m.atl.drivers.uml24atl and
>>>>> org.eclipse.m2m.atl.adt.editor plugins.
>>>>> I am using the ATLBundle-20060501.
>>>> The problem is that the latest versions of ATL are not compatible with
>>>> this version of the bundle (as the ATL component has moved from the GMT
>>>> to the M2M project).
>>>>
>>>> The better solution is to install a new Eclipse with only the EMF and
>>>> UML2 plugins. Then, you can launch this Eclipse and checkout the ATL &
>>>> AM3 plugins as I explained in my previous email. Finally, you can start
>>>> another Eclipse from the first one to load the ATL & AM3 plugins.
>>>>
>>>> We are currently testing the latest ATL & AM3 version with the Eclipse
>>>> Europa release (i.e. Eclipse 3.3, EMF 2.3, UML2 2.1) and we don't find
>>>> any major problem for the moment. You can download these versions.
>>>>
>>>> By doing that, you will have the latest version of ATL ;-)
>>>>
>>>>>
>>>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>>>> news:f5qo36$4pv$1@build.eclipse.org...
>>>>>> Thank you very much Hugo, but It doesn't work. When I check out the
>>>>>> plugins almost all of them have errors (they have the red cross), so
>>>>>> when I try to lunch the second Eclipse, an error window appears.
>>>>>> I am a bit lost, I would be very grateful if you could help me.
>>>>>>
>>>>>>
>>>>>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el
>>>>>> mensaje news:f5qlka$tth$1@build.eclipse.org...
>>>>>>> Hello Bea,
>>>>>>>
>>>>>>> Bea a écrit :
>>>>>>>> I have checked out those two plugins. The
>>>>>>>> org.eclipse.m2m.atl.drivers.uml24atl project has errors because it
>>>>>>>> doesn't find some packages. I have added pluging dependencies in
>>>>>>>> order not to have any error and I get it, but I have the same error
>>>>>>>> with the UML2 model handler,
>>>>>>>> Any idea?
>>>>>>>> Thank you in advance.
>>>>>>>>
>>>>>>> I am sorry if you encountered some problems because of my yesterday's
>>>>>>> email. I thought you were already using ATL sources instead of ATL
>>>>>>> binaries, that's why I told you to checkout the "uml24atl" driver
>>>>>>> from the Eclipse CVS.
>>>>>>>
>>>>>>> In order to always get the latest version of ATL and its IDE, I
>>>>>>> advise you to use the ATL sources instead of using the binaries
>>>>>>> versions available from the ATL download page.
>>>>>>>
>>>>>>> To do so, you have to follow the process described in the Wiki page
>>>>>>> "How Install ATL From CVS". You must checkout the ATL plugins into
>>>>>>> the workspace of a first Eclipse and then you have to launch a second
>>>>>>> Eclipse from the first one in order to load the plugins. You can work
>>>>>>> using ATL in the second Eclipse.
>>>>>>> Note that you don't need to checkout the "mdr4atl" driver's plugin if
>>>>>>> you don't need to use MDR as model handler (and I think it's the
>>>>>>> case).
>>>>>>>
>>>>>>> You may also follow the same process for the AM3 plugins except that:
>>>>>>> --> the repository path is "/cvsroot/technology" (instead of
>>>>>>> "/cvsroot/modeling")
>>>>>>> --> the plugins to checkout are in "HEAD->org.eclipse.gmt->AM3"
>>>>>>> |-> org.eclipse.am3.core, org.eclipse.am3.tools.tge,
>>>>>>> org.eclipse.am3.ui, org.eclipse.gmt.am3.dsls.km3,
>>>>>>> org.eclipse.gmt.am3.tools.ant
>>>>>>>
>>>>>>> I hope this will help you.
>>>>>>>
>>>>>>> Best regards,
>>>>>>>
>>>>>>> Hugo
>>>>>>>
>>>>>>>> "William Piers" <william.piers@obeo.fr> escribió en el mensaje
>>>>>>>> news:f5ork4$524$1@build.eclipse.org...
>>>>>>>>>> Hello,
>>>>>>>>>> do you know if I all these new projects have to be directly in the
>>>>>>>>>> workspace or in my plug-in project?
>>>>>>>>> They have to be directly in the workspace.
>>>>>>>>>
>>>>>>>>> Bea a écrit :
>>>>>>>>>> The thing is that following the Hugo's email, I only have to check
>>>>>>>>>> out org.eclipse.m2m.atl.drivers.uml24atl and
>>>>>>>>>> org.eclipse.mdt/org.eclipse.uml. And following
>>>>>>>>>> http://wiki.eclipse.org/index.php/ATL/How_Install_ATL_From_C VS/ I
>>>>>>>>>> don't have to do anything with these plugins.
>>>>>>>>> Ok, sorry. I thought that you checked out mdr4atl too, which
>>>>>>>>> requires additional libraries.
>>>>>>>>>
>>>>>>>>> William Piers
>>>>>>> --
>>>>>>> --------------------------------------------------------
>>>>>>> Hugo Bruneliere - R&D Engineer
>>>>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>>>>> 2, rue de la Houssiniere
>>>>>>> 44322 Nantes Cedex 3 - France
>>>>>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>>>>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>>>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>>>>> --------------------------------------------------------
>>>>>
>>>>
>>>> --
>>>> --------------------------------------------------------
>>>> Hugo Bruneliere - R&D Engineer
>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>> 2, rue de la Houssiniere
>>>> 44322 Nantes Cedex 3 - France
>>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>> --------------------------------------------------------
>>>
>>
>
>


--
--------------------------------------------------------
Hugo Bruneliere - R&D Engineer
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssiniere
44322 Nantes Cedex 3 - France
office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
EMail: Hugo.Bruneliere@univ-nantes.fr
http://www.sciences.univ-nantes.fr/lina/atl/
--------------------------------------------------------
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #51511 is a reply to message #50119] Mon, 09 July 2007 09:05 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
Hello,
I am working now with Eclipse 3.2 and I have installed UML24ATL plugin. When
I try to load the profile from the ant script I get the error:
[am3.loadModel] Loading of model PRO

[am3.loadModel] java.lang.NullPointerException

[am3.loadModel] at
org.eclipse.m2m.atl.drivers.uml24atl.ASMUMLModel.addReferenc edExtentsFor

Any idea? Thank you very much in advance.

Bea



"Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #51562 is a reply to message #51511] Mon, 09 July 2007 09:18 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Hugo.Bruneliere.univ-nantes.fr

Bea a écrit :
> Hello,

Hello Bea,

> I am working now with Eclipse 3.2 and I have installed UML24ATL plugin. When
> I try to load the profile from the ant script I get the error:
> [am3.loadModel] Loading of model PRO
>
> [am3.loadModel] java.lang.NullPointerException
>
> [am3.loadModel] at
> org.eclipse.m2m.atl.drivers.uml24atl.ASMUMLModel.addReferenc edExtentsFor
>
> Any idea? Thank you very much in advance.
>

Is it possible to see your ANT script & transformation file's header?

> Bea
>
>
>
> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el mensaje
> news:f62k97$qe2$1@build.eclipse.org...
>> Bea a écrit :
>>> I have installed Eclipse 3.1, with EMF and UML2 1.1.1.
>>> I have check out ATL and AM3 as you have explained to me.
>>> But I get some errors in org.eclipse.m2m.atl.adt.editor and
>>> org.eclipse.m2m.atl.drivers.uml24atl. Perhaps I need to check out those
>>> plugins (ATL and AM3) from another repository?
>>>
>>>
>> Hello Bea,
>>
>> I have submitted a bug and a patch in order to delete the dependence to
>> the UML2 plugin from the "uml24atl" driver:
>>
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=194894
>>
>> So when the patch will be integrated, it may work ;-)
>>
>> But in my opinion, your problem is more a problem of upward compatibility
>> in UML2 than a problem with ATL.
>> Are your UML2 1.1 models compatible with UML2 2.0 or 2.1? I have never
>> testing this so I don't know, but the Eclipse/MDT project may provide some
>> ways to ensure this compatibility (at least converters from a version to
>> another)...
>>
>> I think you should now try to use latest versions of Eclipse, EMF and UML2
>> or you will probably encounter more problems later.
>>
>> Best regards,
>>
>> Hugo
>>
>>>
>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>> news:f5rlbh$5u6$1@build.eclipse.org...
>>>> I need org.eclipse.uml2.uml.jar and
>>>> org.eclipse.core.runtime.ListenerList, Does anybody know where I can
>>>> find these .jar?
>>>>
>>>>
>>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>>> news:f5raii$3bh$1@build.eclipse.org...
>>>>> Nothing I get the same errors in those two packages. I am trying with
>>>>> Eclipse 3.1 because all my models are created in UML2 for that version.
>>>>> I don't know what to do. Any help?
>>>>>
>>>>>
>>>>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el
>>>>> mensaje news:f5r4fg$8s3$1@build.eclipse.org...
>>>>>> Bea a écrit :
>>>>>>> Now I only have errors in the org.eclipse.m2m.atl.drivers.uml24atl
>>>>>>> and org.eclipse.m2m.atl.adt.editor plugins.
>>>>>>> I am using the ATLBundle-20060501.
>>>>>> The problem is that the latest versions of ATL are not compatible with
>>>>>> this version of the bundle (as the ATL component has moved from the
>>>>>> GMT to the M2M project).
>>>>>>
>>>>>> The better solution is to install a new Eclipse with only the EMF and
>>>>>> UML2 plugins. Then, you can launch this Eclipse and checkout the ATL &
>>>>>> AM3 plugins as I explained in my previous email. Finally, you can
>>>>>> start another Eclipse from the first one to load the ATL & AM3
>>>>>> plugins.
>>>>>>
>>>>>> We are currently testing the latest ATL & AM3 version with the Eclipse
>>>>>> Europa release (i.e. Eclipse 3.3, EMF 2.3, UML2 2.1) and we don't find
>>>>>> any major problem for the moment. You can download these versions.
>>>>>>
>>>>>> By doing that, you will have the latest version of ATL ;-)
>>>>>>
>>>>>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>>>>>> news:f5qo36$4pv$1@build.eclipse.org...
>>>>>>>> Thank you very much Hugo, but It doesn't work. When I check out the
>>>>>>>> plugins almost all of them have errors (they have the red cross), so
>>>>>>>> when I try to lunch the second Eclipse, an error window appears.
>>>>>>>> I am a bit lost, I would be very grateful if you could help me.
>>>>>>>>
>>>>>>>>
>>>>>>>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el
>>>>>>>> mensaje news:f5qlka$tth$1@build.eclipse.org...
>>>>>>>>> Hello Bea,
>>>>>>>>>
>>>>>>>>> Bea a écrit :
>>>>>>>>>> I have checked out those two plugins. The
>>>>>>>>>> org.eclipse.m2m.atl.drivers.uml24atl project has errors because it
>>>>>>>>>> doesn't find some packages. I have added pluging dependencies in
>>>>>>>>>> order not to have any error and I get it, but I have the same
>>>>>>>>>> error with the UML2 model handler,
>>>>>>>>>> Any idea?
>>>>>>>>>> Thank you in advance.
>>>>>>>>>>
>>>>>>>>> I am sorry if you encountered some problems because of my
>>>>>>>>> yesterday's email. I thought you were already using ATL sources
>>>>>>>>> instead of ATL binaries, that's why I told you to checkout the
>>>>>>>>> "uml24atl" driver from the Eclipse CVS.
>>>>>>>>>
>>>>>>>>> In order to always get the latest version of ATL and its IDE, I
>>>>>>>>> advise you to use the ATL sources instead of using the binaries
>>>>>>>>> versions available from the ATL download page.
>>>>>>>>>
>>>>>>>>> To do so, you have to follow the process described in the Wiki page
>>>>>>>>> "How Install ATL From CVS". You must checkout the ATL plugins into
>>>>>>>>> the workspace of a first Eclipse and then you have to launch a
>>>>>>>>> second Eclipse from the first one in order to load the plugins. You
>>>>>>>>> can work using ATL in the second Eclipse.
>>>>>>>>> Note that you don't need to checkout the "mdr4atl" driver's plugin
>>>>>>>>> if you don't need to use MDR as model handler (and I think it's the
>>>>>>>>> case).
>>>>>>>>>
>>>>>>>>> You may also follow the same process for the AM3 plugins except
>>>>>>>>> that:
>>>>>>>>> --> the repository path is "/cvsroot/technology" (instead of
>>>>>>>>> "/cvsroot/modeling")
>>>>>>>>> --> the plugins to checkout are in "HEAD->org.eclipse.gmt->AM3"
>>>>>>>>> |-> org.eclipse.am3.core, org.eclipse.am3.tools.tge,
>>>>>>>>> org.eclipse.am3.ui, org.eclipse.gmt.am3.dsls.km3,
>>>>>>>>> org.eclipse.gmt.am3.tools.ant
>>>>>>>>>
>>>>>>>>> I hope this will help you.
>>>>>>>>>
>>>>>>>>> Best regards,
>>>>>>>>>
>>>>>>>>> Hugo
>>>>>>>>>
>>>>>>>>>> "William Piers" <william.piers@obeo.fr> escribió en el mensaje
>>>>>>>>>> news:f5ork4$524$1@build.eclipse.org...
>>>>>>>>>>>> Hello,
>>>>>>>>>>>> do you know if I all these new projects have to be directly in
>>>>>>>>>>>> the workspace or in my plug-in project?
>>>>>>>>>>> They have to be directly in the workspace.
>>>>>>>>>>>
>>>>>>>>>>> Bea a écrit :
>>>>>>>>>>>> The thing is that following the Hugo's email, I only have to
>>>>>>>>>>>> check out org.eclipse.m2m.atl.drivers.uml24atl and
>>>>>>>>>>>> org.eclipse.mdt/org.eclipse.uml. And following
>>>>>>>>>>>> http://wiki.eclipse.org/index.php/ATL/How_Install_ATL_From_C VS/
>>>>>>>>>>>> I don't have to do anything with these plugins.
>>>>>>>>>>> Ok, sorry. I thought that you checked out mdr4atl too, which
>>>>>>>>>>> requires additional libraries.
>>>>>>>>>>>
>>>>>>>>>>> William Piers
>>>>>>>>> --
>>>>>>>>> --------------------------------------------------------
>>>>>>>>> Hugo Bruneliere - R&D Engineer
>>>>>>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>>>>>>> 2, rue de la Houssiniere
>>>>>>>>> 44322 Nantes Cedex 3 - France
>>>>>>>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>>>>>>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>>>>>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>>>>>>> --------------------------------------------------------
>>>>>> --
>>>>>> --------------------------------------------------------
>>>>>> Hugo Bruneliere - R&D Engineer
>>>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>>>> 2, rue de la Houssiniere
>>>>>> 44322 Nantes Cedex 3 - France
>>>>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>>>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>>>> --------------------------------------------------------
>>>
>>
>> --
>> --------------------------------------------------------
>> Hugo Bruneliere - R&D Engineer
>> ATLAS Group (INRIA & LINA) - University of Nantes
>> 2, rue de la Houssiniere
>> 44322 Nantes Cedex 3 - France
>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>> EMail: Hugo.Bruneliere@univ-nantes.fr
>> http://www.sciences.univ-nantes.fr/lina/atl/
>> --------------------------------------------------------
>
>

Best regards,

Hugo

--
--------------------------------------------------------
Hugo Bruneliere - R&D Engineer
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssiniere
44322 Nantes Cedex 3 - France
office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
EMail: Hugo.Bruneliere@univ-nantes.fr
http://www.sciences.univ-nantes.fr/lina/atl/
--------------------------------------------------------
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #51585 is a reply to message #51562] Mon, 09 July 2007 09:26 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
Yes, the senteces of the ANT script are:

<project default="transfo">

<property name="projectPath" value="/Plugin/src/plugin/popup/actions/"/>

<property name="inputModelsPath" value="${projectPath}InputModels/"/>

<property name="outputModelsPath" value="${projectPath}OutputModels/"/>

<property name="firstTransformationPath"
value="${projectPath}ATLFiles/First/"/>

<property name="secondTransformationPath"
value="${projectPath}ATLFiles/Second/"/>


<target name="loadMetaModels">

<!--Load UML 2.0 metamodel-->

<am3.loadModel modelHandler="UML2" name="UML2" metamodel="MOF"
nsUri="http://www.eclipse.org/uml2/2.0.0/UML"/>

</target>

<target name="transfo" depends="loadMetaModels">

<property name="targetModel" value="FirstTargetModel"/>

<property name="transformation" value="firstTransformation"/>

<am3.loadModel modelHandler="UML2" name="PRO" metamodel="UML2"
path="${inputModelsPath}Profile.profile.uml"/>

<am3.loadModel modelHandler="UML2" name="IN" metamodel="UML2"
path="${inputModelsPath}Source.uml"/>

<am3.atl path="${firstTransformationPath}${transformation}.asm">

<inModel name="IN" model="UML2"/>

<inModel name="UML" model="UML2"/>

<inModel name="PRO" model="UML2"/>

<library name="strings" path="${firstTransformationPath}strings.asm" />

<library name="Multiplicities"
path="${firstTransformationPath}Multiplicities.asm" />

<library name="Profile" path="${firstTransformationPath}Profile.asm" />

<outModel name="OUT" model="firstTargetUmlModel" metamodel="UML2"/>

</am3.atl>

<am3.saveModel model="firstTargetUmlModel"
path="${outputModelsPath}${targetModel}.uml"/>

</target>

</project>

and the header of the transformation file is;
module firstTransformation; -- Module Template

create OUT : UML from IN : UML, PRO : UML;







"Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #51936 is a reply to message #51585] Tue, 10 July 2007 18:53 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
I have realised that if I tried to execute my ATL transformation in this
second Eclipse I obtain the same error, then it is not the ant script.
Any idea?
Thank you very much in advance
Bea



"Bea" <beaperez@unizar.es> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #51988 is a reply to message #51936] Wed, 11 July 2007 08:23 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Hugo.Bruneliere.univ-nantes.fr

Hi Bea,

Could you send us your ATL project so that we can test it on our own
Eclipse install?

Best regards,

Hugo

Bea a écrit :
> I have realised that if I tried to execute my ATL transformation in this
> second Eclipse I obtain the same error, then it is not the ant script.
> Any idea?
> Thank you very much in advance
> Bea
>
>
>
> "Bea" <beaperez@unizar.es> escribió en el mensaje
> news:f6sv0n$j5v$1@build.eclipse.org...
>> Yes, the senteces of the ANT script are:
>>
>> <project default="transfo">
>>
>> <property name="projectPath" value="/Plugin/src/plugin/popup/actions/"/>
>>
>> <property name="inputModelsPath" value="${projectPath}InputModels/"/>
>>
>> <property name="outputModelsPath" value="${projectPath}OutputModels/"/>
>>
>> <property name="firstTransformationPath"
>> value="${projectPath}ATLFiles/First/"/>
>>
>> <property name="secondTransformationPath"
>> value="${projectPath}ATLFiles/Second/"/>
>>
>>
>> <target name="loadMetaModels">
>>
>> <!--Load UML 2.0 metamodel-->
>>
>> <am3.loadModel modelHandler="UML2" name="UML2" metamodel="MOF"
>> nsUri="http://www.eclipse.org/uml2/2.0.0/UML"/>
>>
>> </target>
>>
>> <target name="transfo" depends="loadMetaModels">
>>
>> <property name="targetModel" value="FirstTargetModel"/>
>>
>> <property name="transformation" value="firstTransformation"/>
>>
>> <am3.loadModel modelHandler="UML2" name="PRO" metamodel="UML2"
>> path="${inputModelsPath}Profile.profile.uml"/>
>>
>> <am3.loadModel modelHandler="UML2" name="IN" metamodel="UML2"
>> path="${inputModelsPath}Source.uml"/>
>>
>> <am3.atl path="${firstTransformationPath}${transformation}.asm">
>>
>> <inModel name="IN" model="UML2"/>
>>
>> <inModel name="UML" model="UML2"/>
>>
>> <inModel name="PRO" model="UML2"/>
>>
>> <library name="strings" path="${firstTransformationPath}strings.asm" />
>>
>> <library name="Multiplicities"
>> path="${firstTransformationPath}Multiplicities.asm" />
>>
>> <library name="Profile" path="${firstTransformationPath}Profile.asm" />
>>
>> <outModel name="OUT" model="firstTargetUmlModel" metamodel="UML2"/>
>>
>> </am3.atl>
>>
>> <am3.saveModel model="firstTargetUmlModel"
>> path="${outputModelsPath}${targetModel}.uml"/>
>>
>> </target>
>>
>> </project>
>>
>> and the header of the transformation file is;
>> module firstTransformation; -- Module Template
>>
>> create OUT : UML from IN : UML, PRO : UML;
>>
>>
>>
>>
>>
>>
>>
>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el mensaje
>> news:f6suga$g7a$2@build.eclipse.org...
>>> Bea a écrit :
>>>> Hello,
>>> Hello Bea,
>>>
>>>> I am working now with Eclipse 3.2 and I have installed UML24ATL plugin.
>>>> When I try to load the profile from the ant script I get the error:
>>>> [am3.loadModel] Loading of model PRO
>>>>
>>>> [am3.loadModel] java.lang.NullPointerException
>>>>
>>>> [am3.loadModel] at
>>>> org.eclipse.m2m.atl.drivers.uml24atl.ASMUMLModel.addReferenc edExtentsFor
>>>>
>>>> Any idea? Thank you very much in advance.
>>>>
>>> Is it possible to see your ANT script & transformation file's header?
>>>
>>>> Bea
>>>>
>>>>
>>>>
>>>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el
>>>> mensaje news:f62k97$qe2$1@build.eclipse.org...
>>>>> Bea a écrit :
>>>>>> I have installed Eclipse 3.1, with EMF and UML2 1.1.1.
>>>>>> I have check out ATL and AM3 as you have explained to me.
>>>>>> But I get some errors in org.eclipse.m2m.atl.adt.editor and
>>>>>> org.eclipse.m2m.atl.drivers.uml24atl. Perhaps I need to check out
>>>>>> those plugins (ATL and AM3) from another repository?
>>>>>>
>>>>>>
>>>>> Hello Bea,
>>>>>
>>>>> I have submitted a bug and a patch in order to delete the dependence to
>>>>> the UML2 plugin from the "uml24atl" driver:
>>>>>
>>>>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=194894
>>>>>
>>>>> So when the patch will be integrated, it may work ;-)
>>>>>
>>>>> But in my opinion, your problem is more a problem of upward
>>>>> compatibility in UML2 than a problem with ATL.
>>>>> Are your UML2 1.1 models compatible with UML2 2.0 or 2.1? I have never
>>>>> testing this so I don't know, but the Eclipse/MDT project may provide
>>>>> some ways to ensure this compatibility (at least converters from a
>>>>> version to another)...
>>>>>
>>>>> I think you should now try to use latest versions of Eclipse, EMF and
>>>>> UML2 or you will probably encounter more problems later.
>>>>>
>>>>> Best regards,
>>>>>
>>>>> Hugo
>>>>>
>>>>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>>>>> news:f5rlbh$5u6$1@build.eclipse.org...
>>>>>>> I need org.eclipse.uml2.uml.jar and
>>>>>>> org.eclipse.core.runtime.ListenerList, Does anybody know where I can
>>>>>>> find these .jar?
>>>>>>>
>>>>>>>
>>>>>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>>>>>> news:f5raii$3bh$1@build.eclipse.org...
>>>>>>>> Nothing I get the same errors in those two packages. I am trying
>>>>>>>> with Eclipse 3.1 because all my models are created in UML2 for that
>>>>>>>> version. I don't know what to do. Any help?
>>>>>>>>
>>>>>>>>
>>>>>>>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el
>>>>>>>> mensaje news:f5r4fg$8s3$1@build.eclipse.org...
>>>>>>>>> Bea a écrit :
>>>>>>>>>> Now I only have errors in the org.eclipse.m2m.atl.drivers.uml24atl
>>>>>>>>>> and org.eclipse.m2m.atl.adt.editor plugins.
>>>>>>>>>> I am using the ATLBundle-20060501.
>>>>>>>>> The problem is that the latest versions of ATL are not compatible
>>>>>>>>> with this version of the bundle (as the ATL component has moved
>>>>>>>>> from the GMT to the M2M project).
>>>>>>>>>
>>>>>>>>> The better solution is to install a new Eclipse with only the EMF
>>>>>>>>> and UML2 plugins. Then, you can launch this Eclipse and checkout
>>>>>>>>> the ATL & AM3 plugins as I explained in my previous email. Finally,
>>>>>>>>> you can start another Eclipse from the first one to load the ATL &
>>>>>>>>> AM3 plugins.
>>>>>>>>>
>>>>>>>>> We are currently testing the latest ATL & AM3 version with the
>>>>>>>>> Eclipse Europa release (i.e. Eclipse 3.3, EMF 2.3, UML2 2.1) and we
>>>>>>>>> don't find any major problem for the moment. You can download these
>>>>>>>>> versions.
>>>>>>>>>
>>>>>>>>> By doing that, you will have the latest version of ATL ;-)
>>>>>>>>>
>>>>>>>>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>>>>>>>>> news:f5qo36$4pv$1@build.eclipse.org...
>>>>>>>>>>> Thank you very much Hugo, but It doesn't work. When I check out
>>>>>>>>>>> the plugins almost all of them have errors (they have the red
>>>>>>>>>>> cross), so when I try to lunch the second Eclipse, an error
>>>>>>>>>>> window appears.
>>>>>>>>>>> I am a bit lost, I would be very grateful if you could help me.
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el
>>>>>>>>>>> mensaje news:f5qlka$tth$1@build.eclipse.org...
>>>>>>>>>>>> Hello Bea,
>>>>>>>>>>>>
>>>>>>>>>>>> Bea a écrit :
>>>>>>>>>>>>> I have checked out those two plugins. The
>>>>>>>>>>>>> org.eclipse.m2m.atl.drivers.uml24atl project has errors because
>>>>>>>>>>>>> it doesn't find some packages. I have added pluging
>>>>>>>>>>>>> dependencies in order not to have any error and I get it, but I
>>>>>>>>>>>>> have the same error with the UML2 model handler,
>>>>>>>>>>>>> Any idea?
>>>>>>>>>>>>> Thank you in advance.
>>>>>>>>>>>>>
>>>>>>>>>>>> I am sorry if you encountered some problems because of my
>>>>>>>>>>>> yesterday's email. I thought you were already using ATL sources
>>>>>>>>>>>> instead of ATL binaries, that's why I told you to checkout the
>>>>>>>>>>>> "uml24atl" driver from the Eclipse CVS.
>>>>>>>>>>>>
>>>>>>>>>>>> In order to always get the latest version of ATL and its IDE, I
>>>>>>>>>>>> advise you to use the ATL sources instead of using the binaries
>>>>>>>>>>>> versions available from the ATL download page.
>>>>>>>>>>>>
>>>>>>>>>>>> To do so, you have to follow the process described in the Wiki
>>>>>>>>>>>> page "How Install ATL From CVS". You must checkout the ATL
>>>>>>>>>>>> plugins into the workspace of a first Eclipse and then you have
>>>>>>>>>>>> to launch a second Eclipse from the first one in order to load
>>>>>>>>>>>> the plugins. You can work using ATL in the second Eclipse.
>>>>>>>>>>>> Note that you don't need to checkout the "mdr4atl" driver's
>>>>>>>>>>>> plugin if you don't need to use MDR as model handler (and I
>>>>>>>>>>>> think it's the case).
>>>>>>>>>>>>
>>>>>>>>>>>> You may also follow the same process for the AM3 plugins except
>>>>>>>>>>>> that:
>>>>>>>>>>>> --> the repository path is "/cvsroot/technology" (instead of
>>>>>>>>>>>> "/cvsroot/modeling")
>>>>>>>>>>>> --> the plugins to checkout are in
>>>>>>>>>>>> "HEAD->org.eclipse.gmt->AM3"
>>>>>>>>>>>> |-> org.eclipse.am3.core, org.eclipse.am3.tools.tge,
>>>>>>>>>>>> org.eclipse.am3.ui, org.eclipse.gmt.am3.dsls.km3,
>>>>>>>>>>>> org.eclipse.gmt.am3.tools.ant
>>>>>>>>>>>>
>>>>>>>>>>>> I hope this will help you.
>>>>>>>>>>>>
>>>>>>>>>>>> Best regards,
>>>>>>>>>>>>
>>>>>>>>>>>> Hugo
>>>>>>>>>>>>
>>>>>>>>>>>>> "William Piers" <william.piers@obeo.fr> escribió en el mensaje
>>>>>>>>>>>>> news:f5ork4$524$1@build.eclipse.org...
>>>>>>>>>>>>>>> Hello,
>>>>>>>>>>>>>>> do you know if I all these new projects have to be directly
>>>>>>>>>>>>>>> in the workspace or in my plug-in project?
>>>>>>>>>>>>>> They have to be directly in the workspace.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Bea a écrit :
>>>>>>>>>>>>>>> The thing is that following the Hugo's email, I only have to
>>>>>>>>>>>>>>> check out org.eclipse.m2m.atl.drivers.uml24atl and
>>>>>>>>>>>>>>> org.eclipse.mdt/org.eclipse.uml. And following
>>>>>>>>>>>>>>> http://wiki.eclipse.org/index.php/ATL/How_Install_ATL_From_C VS/ I
>>>>>>>>>>>>>>> don't have to do anything with these plugins.
>>>>>>>>>>>>>> Ok, sorry. I thought that you checked out mdr4atl too, which
>>>>>>>>>>>>>> requires additional libraries.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> William Piers
>>>>>>>>>>>> --
>>>>>>>>>>>> --------------------------------------------------------
>>>>>>>>>>>> Hugo Bruneliere - R&D Engineer
>>>>>>>>>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>>>>>>>>>> 2, rue de la Houssiniere
>>>>>>>>>>>> 44322 Nantes Cedex 3 - France
>>>>>>>>>>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>>>>>>>>>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>>>>>>>>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>>>>>>>>>> --------------------------------------------------------
>>>>>>>>> --
>>>>>>>>> --------------------------------------------------------
>>>>>>>>> Hugo Bruneliere - R&D Engineer
>>>>>>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>>>>>>> 2, rue de la Houssiniere
>>>>>>>>> 44322 Nantes Cedex 3 - France
>>>>>>>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>>>>>>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>>>>>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>>>>>>> --------------------------------------------------------
>>>>> --
>>>>> --------------------------------------------------------
>>>>> Hugo Bruneliere - R&D Engineer
>>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>>> 2, rue de la Houssiniere
>>>>> 44322 Nantes Cedex 3 - France
>>>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>>> --------------------------------------------------------
>>>>
>>> Best regards,
>>>
>>> Hugo
>>>
>>> --
>>> --------------------------------------------------------
>>> Hugo Bruneliere - R&D Engineer
>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>> 2, rue de la Houssiniere
>>> 44322 Nantes Cedex 3 - France
>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>> --------------------------------------------------------
>>
>
>


--
--------------------------------------------------------
Hugo Bruneliere - R&D Engineer
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssiniere
44322 Nantes Cedex 3 - France
office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
EMail: Hugo.Bruneliere@univ-nantes.fr
http://www.sciences.univ-nantes.fr/lina/atl/
--------------------------------------------------------
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #52068 is a reply to message #51988] Wed, 11 July 2007 13:48 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Hugo.Bruneliere.univ-nantes.fr

Hi Bea,

We succeeded in loading your UML profile by deleting, in the "UML"
annotation from the root of the profile model, all the packages
excepting the first one (i.e. keep the "StatechartProfile" one and
delete the "StatechartProfile_XX" ones).

The information was duplicated several times and it does not seem to be
useful. Moreverer, there were some attributes whose data type was not
specified was not good (and it was the origin of the errors).

Which UML CASE tool did you produce this model with?

Best regards,

Hugo

Hugo Bruneliere a écrit :
> Hi Bea,
>
> Could you send us your ATL project so that we can test it on our own
> Eclipse install?
>
> Best regards,
>
> Hugo
>
> Bea a écrit :
>> I have realised that if I tried to execute my ATL transformation in
>> this second Eclipse I obtain the same error, then it is not the ant
>> script.
>> Any idea?
>> Thank you very much in advance
>> Bea
>>
>>
>>
>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>> news:f6sv0n$j5v$1@build.eclipse.org...
>>> Yes, the senteces of the ANT script are:
>>>
>>> <project default="transfo">
>>>
>>> <property name="projectPath" value="/Plugin/src/plugin/popup/actions/"/>
>>>
>>> <property name="inputModelsPath" value="${projectPath}InputModels/"/>
>>>
>>> <property name="outputModelsPath" value="${projectPath}OutputModels/"/>
>>>
>>> <property name="firstTransformationPath"
>>> value="${projectPath}ATLFiles/First/"/>
>>>
>>> <property name="secondTransformationPath"
>>> value="${projectPath}ATLFiles/Second/"/>
>>>
>>>
>>> <target name="loadMetaModels">
>>>
>>> <!--Load UML 2.0 metamodel-->
>>>
>>> <am3.loadModel modelHandler="UML2" name="UML2" metamodel="MOF"
>>> nsUri="http://www.eclipse.org/uml2/2.0.0/UML"/>
>>>
>>> </target>
>>>
>>> <target name="transfo" depends="loadMetaModels">
>>>
>>> <property name="targetModel" value="FirstTargetModel"/>
>>>
>>> <property name="transformation" value="firstTransformation"/>
>>>
>>> <am3.loadModel modelHandler="UML2" name="PRO" metamodel="UML2"
>>> path="${inputModelsPath}Profile.profile.uml"/>
>>>
>>> <am3.loadModel modelHandler="UML2" name="IN" metamodel="UML2"
>>> path="${inputModelsPath}Source.uml"/>
>>>
>>> <am3.atl path="${firstTransformationPath}${transformation}.asm">
>>>
>>> <inModel name="IN" model="UML2"/>
>>>
>>> <inModel name="UML" model="UML2"/>
>>>
>>> <inModel name="PRO" model="UML2"/>
>>>
>>> <library name="strings" path="${firstTransformationPath}strings.asm" />
>>>
>>> <library name="Multiplicities"
>>> path="${firstTransformationPath}Multiplicities.asm" />
>>>
>>> <library name="Profile" path="${firstTransformationPath}Profile.asm" />
>>>
>>> <outModel name="OUT" model="firstTargetUmlModel" metamodel="UML2"/>
>>>
>>> </am3.atl>
>>>
>>> <am3.saveModel model="firstTargetUmlModel"
>>> path="${outputModelsPath}${targetModel}.uml"/>
>>>
>>> </target>
>>>
>>> </project>
>>>
>>> and the header of the transformation file is;
>>> module firstTransformation; -- Module Template
>>>
>>> create OUT : UML from IN : UML, PRO : UML;
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el
>>> mensaje news:f6suga$g7a$2@build.eclipse.org...
>>>> Bea a écrit :
>>>>> Hello,
>>>> Hello Bea,
>>>>
>>>>> I am working now with Eclipse 3.2 and I have installed UML24ATL
>>>>> plugin. When I try to load the profile from the ant script I get
>>>>> the error:
>>>>> [am3.loadModel] Loading of model PRO
>>>>>
>>>>> [am3.loadModel] java.lang.NullPointerException
>>>>>
>>>>> [am3.loadModel] at
>>>>> org.eclipse.m2m.atl.drivers.uml24atl.ASMUMLModel.addReferenc edExtentsFor
>>>>>
>>>>>
>>>>> Any idea? Thank you very much in advance.
>>>>>
>>>> Is it possible to see your ANT script & transformation file's header?
>>>>
>>>>> Bea
>>>>>
>>>>>
>>>>>
>>>>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en el
>>>>> mensaje news:f62k97$qe2$1@build.eclipse.org...
>>>>>> Bea a écrit :
>>>>>>> I have installed Eclipse 3.1, with EMF and UML2 1.1.1.
>>>>>>> I have check out ATL and AM3 as you have explained to me.
>>>>>>> But I get some errors in org.eclipse.m2m.atl.adt.editor and
>>>>>>> org.eclipse.m2m.atl.drivers.uml24atl. Perhaps I need to check out
>>>>>>> those plugins (ATL and AM3) from another repository?
>>>>>>>
>>>>>>>
>>>>>> Hello Bea,
>>>>>>
>>>>>> I have submitted a bug and a patch in order to delete the
>>>>>> dependence to the UML2 plugin from the "uml24atl" driver:
>>>>>>
>>>>>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=194894
>>>>>>
>>>>>> So when the patch will be integrated, it may work ;-)
>>>>>>
>>>>>> But in my opinion, your problem is more a problem of upward
>>>>>> compatibility in UML2 than a problem with ATL.
>>>>>> Are your UML2 1.1 models compatible with UML2 2.0 or 2.1? I have
>>>>>> never testing this so I don't know, but the Eclipse/MDT project
>>>>>> may provide some ways to ensure this compatibility (at least
>>>>>> converters from a version to another)...
>>>>>>
>>>>>> I think you should now try to use latest versions of Eclipse, EMF
>>>>>> and UML2 or you will probably encounter more problems later.
>>>>>>
>>>>>> Best regards,
>>>>>>
>>>>>> Hugo
>>>>>>
>>>>>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>>>>>> news:f5rlbh$5u6$1@build.eclipse.org...
>>>>>>>> I need org.eclipse.uml2.uml.jar and
>>>>>>>> org.eclipse.core.runtime.ListenerList, Does anybody know where I
>>>>>>>> can find these .jar?
>>>>>>>>
>>>>>>>>
>>>>>>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>>>>>>> news:f5raii$3bh$1@build.eclipse.org...
>>>>>>>>> Nothing I get the same errors in those two packages. I am
>>>>>>>>> trying with Eclipse 3.1 because all my models are created in
>>>>>>>>> UML2 for that version. I don't know what to do. Any help?
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió en
>>>>>>>>> el mensaje news:f5r4fg$8s3$1@build.eclipse.org...
>>>>>>>>>> Bea a écrit :
>>>>>>>>>>> Now I only have errors in the
>>>>>>>>>>> org.eclipse.m2m.atl.drivers.uml24atl and
>>>>>>>>>>> org.eclipse.m2m.atl.adt.editor plugins.
>>>>>>>>>>> I am using the ATLBundle-20060501.
>>>>>>>>>> The problem is that the latest versions of ATL are not
>>>>>>>>>> compatible with this version of the bundle (as the ATL
>>>>>>>>>> component has moved from the GMT to the M2M project).
>>>>>>>>>>
>>>>>>>>>> The better solution is to install a new Eclipse with only the
>>>>>>>>>> EMF and UML2 plugins. Then, you can launch this Eclipse and
>>>>>>>>>> checkout the ATL & AM3 plugins as I explained in my previous
>>>>>>>>>> email. Finally, you can start another Eclipse from the first
>>>>>>>>>> one to load the ATL & AM3 plugins.
>>>>>>>>>>
>>>>>>>>>> We are currently testing the latest ATL & AM3 version with the
>>>>>>>>>> Eclipse Europa release (i.e. Eclipse 3.3, EMF 2.3, UML2 2.1)
>>>>>>>>>> and we don't find any major problem for the moment. You can
>>>>>>>>>> download these versions.
>>>>>>>>>>
>>>>>>>>>> By doing that, you will have the latest version of ATL ;-)
>>>>>>>>>>
>>>>>>>>>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>>>>>>>>>> news:f5qo36$4pv$1@build.eclipse.org...
>>>>>>>>>>>> Thank you very much Hugo, but It doesn't work. When I check
>>>>>>>>>>>> out the plugins almost all of them have errors (they have
>>>>>>>>>>>> the red cross), so when I try to lunch the second Eclipse,
>>>>>>>>>>>> an error window appears.
>>>>>>>>>>>> I am a bit lost, I would be very grateful if you could help me.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> "Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribió
>>>>>>>>>>>> en el mensaje news:f5qlka$tth$1@build.eclipse.org...
>>>>>>>>>>>>> Hello Bea,
>>>>>>>>>>>>>
>>>>>>>>>>>>> Bea a écrit :
>>>>>>>>>>>>>> I have checked out those two plugins. The
>>>>>>>>>>>>>> org.eclipse.m2m.atl.drivers.uml24atl project has errors
>>>>>>>>>>>>>> because it doesn't find some packages. I have added
>>>>>>>>>>>>>> pluging dependencies in order not to have any error and I
>>>>>>>>>>>>>> get it, but I have the same error with the UML2 model
>>>>>>>>>>>>>> handler,
>>>>>>>>>>>>>> Any idea?
>>>>>>>>>>>>>> Thank you in advance.
>>>>>>>>>>>>>>
>>>>>>>>>>>>> I am sorry if you encountered some problems because of my
>>>>>>>>>>>>> yesterday's email. I thought you were already using ATL
>>>>>>>>>>>>> sources instead of ATL binaries, that's why I told you to
>>>>>>>>>>>>> checkout the "uml24atl" driver from the Eclipse CVS.
>>>>>>>>>>>>>
>>>>>>>>>>>>> In order to always get the latest version of ATL and its
>>>>>>>>>>>>> IDE, I advise you to use the ATL sources instead of using
>>>>>>>>>>>>> the binaries versions available from the ATL download page.
>>>>>>>>>>>>>
>>>>>>>>>>>>> To do so, you have to follow the process described in the
>>>>>>>>>>>>> Wiki page "How Install ATL From CVS". You must checkout the
>>>>>>>>>>>>> ATL plugins into the workspace of a first Eclipse and then
>>>>>>>>>>>>> you have to launch a second Eclipse from the first one in
>>>>>>>>>>>>> order to load the plugins. You can work using ATL in the
>>>>>>>>>>>>> second Eclipse.
>>>>>>>>>>>>> Note that you don't need to checkout the "mdr4atl" driver's
>>>>>>>>>>>>> plugin if you don't need to use MDR as model handler (and I
>>>>>>>>>>>>> think it's the case).
>>>>>>>>>>>>>
>>>>>>>>>>>>> You may also follow the same process for the AM3 plugins
>>>>>>>>>>>>> except that:
>>>>>>>>>>>>> --> the repository path is "/cvsroot/technology" (instead
>>>>>>>>>>>>> of "/cvsroot/modeling")
>>>>>>>>>>>>> --> the plugins to checkout are in
>>>>>>>>>>>>> "HEAD->org.eclipse.gmt->AM3"
>>>>>>>>>>>>> |-> org.eclipse.am3.core, org.eclipse.am3.tools.tge,
>>>>>>>>>>>>> org.eclipse.am3.ui, org.eclipse.gmt.am3.dsls.km3,
>>>>>>>>>>>>> org.eclipse.gmt.am3.tools.ant
>>>>>>>>>>>>>
>>>>>>>>>>>>> I hope this will help you.
>>>>>>>>>>>>>
>>>>>>>>>>>>> Best regards,
>>>>>>>>>>>>>
>>>>>>>>>>>>> Hugo
>>>>>>>>>>>>>
>>>>>>>>>>>>>> "William Piers" <william.piers@obeo.fr> escribió en el
>>>>>>>>>>>>>> mensaje news:f5ork4$524$1@build.eclipse.org...
>>>>>>>>>>>>>>>> Hello,
>>>>>>>>>>>>>>>> do you know if I all these new projects have to be
>>>>>>>>>>>>>>>> directly in the workspace or in my plug-in project?
>>>>>>>>>>>>>>> They have to be directly in the workspace.
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Bea a écrit :
>>>>>>>>>>>>>>>> The thing is that following the Hugo's email, I only
>>>>>>>>>>>>>>>> have to check out org.eclipse.m2m.atl.drivers.uml24atl
>>>>>>>>>>>>>>>> and org.eclipse.mdt/org.eclipse.uml. And following
>>>>>>>>>>>>>>>> http://wiki.eclipse.org/index.php/ATL/How_Install_ATL_From_C VS/
>>>>>>>>>>>>>>>> I don't have to do anything with these plugins.
>>>>>>>>>>>>>>> Ok, sorry. I thought that you checked out mdr4atl too,
>>>>>>>>>>>>>>> which requires additional libraries.
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> William Piers
>>>>>>>>>>>>> --
>>>>>>>>>>>>> --------------------------------------------------------
>>>>>>>>>>>>> Hugo Bruneliere - R&D Engineer
>>>>>>>>>>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>>>>>>>>>>> 2, rue de la Houssiniere
>>>>>>>>>>>>> 44322 Nantes Cedex 3 - France
>>>>>>>>>>>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>>>>>>>>>>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>>>>>>>>>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>>>>>>>>>>> --------------------------------------------------------
>>>>>>>>>> --
>>>>>>>>>> --------------------------------------------------------
>>>>>>>>>> Hugo Bruneliere - R&D Engineer
>>>>>>>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>>>>>>>> 2, rue de la Houssiniere
>>>>>>>>>> 44322 Nantes Cedex 3 - France
>>>>>>>>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>>>>>>>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>>>>>>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>>>>>>>> --------------------------------------------------------
>>>>>> --
>>>>>> --------------------------------------------------------
>>>>>> Hugo Bruneliere - R&D Engineer
>>>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>>>> 2, rue de la Houssiniere
>>>>>> 44322 Nantes Cedex 3 - France
>>>>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>>>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>>>> --------------------------------------------------------
>>>>>
>>>> Best regards,
>>>>
>>>> Hugo
>>>>
>>>> --
>>>> --------------------------------------------------------
>>>> Hugo Bruneliere - R&D Engineer
>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>> 2, rue de la Houssiniere
>>>> 44322 Nantes Cedex 3 - France
>>>> office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
>>>> EMail: Hugo.Bruneliere@univ-nantes.fr
>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>> --------------------------------------------------------
>>>
>>
>>
>
>


--
--------------------------------------------------------
Hugo Bruneliere - R&D Engineer
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssiniere
44322 Nantes Cedex 3 - France
office +33 2 51 12 58 10 /\ cell.+33 6 07 42 45 30
EMail: Hugo.Bruneliere@univ-nantes.fr
http://www.sciences.univ-nantes.fr/lina/atl/
--------------------------------------------------------
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #52095 is a reply to message #52068] Wed, 11 July 2007 14:19 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
I have created the profile using the UML2 Eclipse plugin. Firstly with the
UML2 1.1.1 version and later translating it to UML 2.0.2.
Please, could you tell me what versions of Eclipse, ATL, AM3, etc has used
to test the proyect. I don't know why but if I tried to run my main atl
file, I get an error because I don't have the .asm.
Thank you again.


"Hugo Bruneliere" <Hugo.Bruneliere@univ-nantes.fr> escribi
Re: [ATL] Executing ATL transformations by using ANT scripts: profiled models [message #52149 is a reply to message #52095] Wed, 11 July 2007 16:25 Go to previous message
Eclipse UserFriend
Originally posted by: Hugo.Bruneliere.univ-nantes.fr

This is a multi-part message in MIME format.
--------------040503050202020206080004
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit

Bea a
Previous Topic:[ATL] Increase transformation performance
Next Topic:[ATL]: Installation from source
Goto Forum:
  


Current Time: Thu Jan 21 16:05:37 GMT 2021

Powered by FUDForum. Page generated in 0.03435 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top