Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » Problems applying a particular stereotype:java.lang.NullPointerException at EStructuralFeatureImpl.
Problems applying a particular stereotype:java.lang.NullPointerException at EStructuralFeatureImpl. [message #478256] Thu, 26 March 2009 12:23 Go to next message
Juan Pedro Silva is currently offline Juan Pedro SilvaFriend
Messages: 258
Registered: July 2009
Senior Member
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
</head>
<body bgcolor="#ffffff" text="#000000">
Hello everybody.<br>
I'm having problems trying to apply a particular stereotype (the
"Overrides" stereotype from the Theme/UML profile:
<a class="moz-txt-link-freetext" href=" https://www.cs.tcd.ie/Eamonn.Linehan/lero/ThemeUML.profile.u ml"> https://www.cs.tcd.ie/Eamonn.Linehan/lero/ThemeUML.profile.u ml</a>).<br>
The rest of the stereotypes I used applied correctly with no problems,
but each time I try to use "Overrides" I get the following error
(independently of the type of element I'm applying it to):<br>
<font color="#ffff00"><br>
<font color="#3333ff">java.lang.NullPointerException<br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.EStructuralFeatureImpl.getSetting Delegate(EStructuralFeatureImpl.java:814) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eSettingDelegate (BasicEObjectImpl.java:1532) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eDynamicIsSet(Ba sicEObjectImpl.java:1268) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1250) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1235) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.shouldSaveFeature (XMLSaveImpl.java:1194) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveFeatures(XMLS aveImpl.java:1232) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveElementID(XML SaveImpl.java:2667) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMISaveImpl.writeTopObjects(X MISaveImpl.java:90) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.traverse(XMLSaveI mpl.java:592) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.save(XMLSaveImpl. java:256) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doSave(XMLRes ourceImpl.java:205) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:1344) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.saveOnlyIfC hangedWithMemoryBuffer(ResourceImpl.java:1120) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:973) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.uml2.uml.editor.presentation.UMLEditor$14.execut e(UMLEditor.java:1400) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:104) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:116) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121) </font></font><br>
<br>
Which could be the reason?, perhaps the profile was made with a
different version of UML2/EMF/Eclipse?.<br>
Any suggestions would be greatly appreciated.<br>
Regards,<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp; Juan Pedro<br>
<br>
</body>
</html>
Re: Problems applying a particular stereotype:java.lang.NullPointerException at EStructuralFeatureI [message #478260 is a reply to message #478256] Thu, 26 March 2009 13:00 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30993
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------060009000704040606030202
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Juan,

My guess would be an ill formed profile where there is a feature without
a type. The validator ought to catch that, so be sure to validate the
profile. If you set a breakpoint for this exception, you'll know which
feature is causing the problem.


Juan Pedro Silva wrote:
> Hello everybody.
> I'm having problems trying to apply a particular stereotype (the
> "Overrides" stereotype from the Theme/UML profile:
> https://www.cs.tcd.ie/Eamonn.Linehan/lero/ThemeUML.profile.u ml).
> The rest of the stereotypes I used applied correctly with no problems,
> but each time I try to use "Overrides" I get the following error
> (independently of the type of element I'm applying it to):
>
> java.lang.NullPointerException
> at
> org.eclipse.emf.ecore.impl.EStructuralFeatureImpl.getSetting Delegate(EStructuralFeatureImpl.java:814)
> at
> org.eclipse.emf.ecore.impl.BasicEObjectImpl.eSettingDelegate (BasicEObjectImpl.java:1532)
> at
> org.eclipse.emf.ecore.impl.BasicEObjectImpl.eDynamicIsSet(Ba sicEObjectImpl.java:1268)
> at
> org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1250)
> at
> org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1235)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.shouldSaveFeature (XMLSaveImpl.java:1194)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveFeatures(XMLS aveImpl.java:1232)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveElementID(XML SaveImpl.java:2667)
> at
> org.eclipse.emf.ecore.xmi.impl.XMISaveImpl.writeTopObjects(X MISaveImpl.java:90)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.traverse(XMLSaveI mpl.java:592)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.save(XMLSaveImpl. java:256)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doSave(XMLRes ourceImpl.java:205)
> at
> org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:1344)
> at
> org.eclipse.emf.ecore.resource.impl.ResourceImpl.saveOnlyIfC hangedWithMemoryBuffer(ResourceImpl.java:1120)
> at
> org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:973)
> at
> org.eclipse.uml2.uml.editor.presentation.UMLEditor$14.execut e(UMLEditor.java:1400)
> at
> org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:104)
> at
> org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800)
> at
> org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:116)
> at
> org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121)
>
> Which could be the reason?, perhaps the profile was made with a
> different version of UML2/EMF/Eclipse?.
> Any suggestions would be greatly appreciated.
> Regards,
> Juan Pedro
>

--------------060009000704040606030202
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Juan,<br>
<br>
My guess would be an ill formed profile where there is a feature
without a type.&nbsp; The validator ought to catch that, so be sure to
validate the profile.&nbsp; If you set a breakpoint for this exception,
you'll know which feature is causing the problem.<br>
<br>
<br>
Juan Pedro Silva wrote:
<blockquote cite="mid:gqfs3c$auc$1@build.eclipse.org" type="cite">Hello
everybody.<br>
I'm having problems trying to apply a particular stereotype (the
"Overrides" stereotype from the Theme/UML profile:
<a moz-do-not-send="true" class="moz-txt-link-freetext"
href=" https://www.cs.tcd.ie/Eamonn.Linehan/lero/ThemeUML.profile.u ml"> https://www.cs.tcd.ie/Eamonn.Linehan/lero/ThemeUML.profile.u ml</a>).<br>
The rest of the stereotypes I used applied correctly with no problems,
but each time I try to use "Overrides" I get the following error
(independently of the type of element I'm applying it to):<br>
<font color="#ffff00"><br>
<font color="#3333ff">java.lang.NullPointerException<br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.EStructuralFeatureImpl.getSetting Delegate(EStructuralFeatureImpl.java:814) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eSettingDelegate (BasicEObjectImpl.java:1532) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eDynamicIsSet(Ba sicEObjectImpl.java:1268) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1250) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1235) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.shouldSaveFeature (XMLSaveImpl.java:1194) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveFeatures(XMLS aveImpl.java:1232) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveElementID(XML SaveImpl.java:2667) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMISaveImpl.writeTopObjects(X MISaveImpl.java:90) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.traverse(XMLSaveI mpl.java:592) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.save(XMLSaveImpl. java:256) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doSave(XMLRes ourceImpl.java:205) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:1344) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.saveOnlyIfC hangedWithMemoryBuffer(ResourceImpl.java:1120) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:973) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.uml2.uml.editor.presentation.UMLEditor$14.execut e(UMLEditor.java:1400) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:104) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:116) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121) </font></font><br>
<br>
Which could be the reason?, perhaps the profile was made with a
different version of UML2/EMF/Eclipse?.<br>
Any suggestions would be greatly appreciated.<br>
Regards,<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp; Juan Pedro<br>
<br>
</blockquote>
</body>
</html>

--------------060009000704040606030202--
Re: Problems applying a particular stereotype:java.lang.NullPointerException at EStructuralFeatureI [message #478262 is a reply to message #478260] Thu, 26 March 2009 14:01 Go to previous message
Juan Pedro Silva is currently offline Juan Pedro SilvaFriend
Messages: 258
Registered: July 2009
Senior Member
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Thanks Ed, you were right, as usual.<br>
There are two feature with no types in the profile.<br>
Regards,<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp; Juan Pedro<br>
<br>
Ed Merks escribi&oacute;:
<blockquote cite="mid:gqfu8t$kk5$1@build.eclipse.org" type="cite">
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
Juan,<br>
<br>
My guess would be an ill formed profile where there is a feature
without a type.&nbsp; The validator ought to catch that, so be sure to
validate the profile.&nbsp; If you set a breakpoint for this exception,
you'll know which feature is causing the problem.<br>
<br>
<br>
Juan Pedro Silva wrote:
<blockquote cite="mid:gqfs3c$auc$1@build.eclipse.org" type="cite">Hello
everybody.<br>
I'm having problems trying to apply a particular stereotype (the
"Overrides" stereotype from the Theme/UML profile: <a
moz-do-not-send="true" class="moz-txt-link-freetext"
href=" https://www.cs.tcd.ie/Eamonn.Linehan/lero/ThemeUML.profile.u ml"> https://www.cs.tcd.ie/Eamonn.Linehan/lero/ThemeUML.profile.u ml</a>).<br>
The rest of the stereotypes I used applied correctly with no problems,
but each time I try to use "Overrides" I get the following error
(independently of the type of element I'm applying it to):<br>
<font color="#ffff00"><br>
<font color="#3333ff">java.lang.NullPointerException<br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.EStructuralFeatureImpl.getSetting Delegate(EStructuralFeatureImpl.java:814) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eSettingDelegate (BasicEObjectImpl.java:1532) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eDynamicIsSet(Ba sicEObjectImpl.java:1268) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1250) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1235) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.shouldSaveFeature (XMLSaveImpl.java:1194) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveFeatures(XMLS aveImpl.java:1232) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveElementID(XML SaveImpl.java:2667) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMISaveImpl.writeTopObjects(X MISaveImpl.java:90) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.traverse(XMLSaveI mpl.java:592) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.save(XMLSaveImpl. java:256) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doSave(XMLRes ourceImpl.java:205) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:1344) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.saveOnlyIfC hangedWithMemoryBuffer(ResourceImpl.java:1120) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:973) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.uml2.uml.editor.presentation.UMLEditor$14.execut e(UMLEditor.java:1400) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:104) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:116) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121) </font></font><br>
<br>
Which could be the reason?, perhaps the profile was made with a
different version of UML2/EMF/Eclipse?.<br>
Any suggestions would be greatly appreciated.<br>
Regards,<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp; Juan Pedro<br>
<br>
</blockquote>
</blockquote>
</body>
</html>
Re: Problems applying a particular stereotype:java.lang.NullPointerException at EStructuralFeatureI [message #627451 is a reply to message #478256] Thu, 26 March 2009 13:00 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30993
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------060009000704040606030202
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Juan,

My guess would be an ill formed profile where there is a feature without
a type. The validator ought to catch that, so be sure to validate the
profile. If you set a breakpoint for this exception, you'll know which
feature is causing the problem.


Juan Pedro Silva wrote:
> Hello everybody.
> I'm having problems trying to apply a particular stereotype (the
> "Overrides" stereotype from the Theme/UML profile:
> https://www.cs.tcd.ie/Eamonn.Linehan/lero/ThemeUML.profile.u ml).
> The rest of the stereotypes I used applied correctly with no problems,
> but each time I try to use "Overrides" I get the following error
> (independently of the type of element I'm applying it to):
>
> java.lang.NullPointerException
> at
> org.eclipse.emf.ecore.impl.EStructuralFeatureImpl.getSetting Delegate(EStructuralFeatureImpl.java:814)
> at
> org.eclipse.emf.ecore.impl.BasicEObjectImpl.eSettingDelegate (BasicEObjectImpl.java:1532)
> at
> org.eclipse.emf.ecore.impl.BasicEObjectImpl.eDynamicIsSet(Ba sicEObjectImpl.java:1268)
> at
> org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1250)
> at
> org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1235)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.shouldSaveFeature (XMLSaveImpl.java:1194)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveFeatures(XMLS aveImpl.java:1232)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveElementID(XML SaveImpl.java:2667)
> at
> org.eclipse.emf.ecore.xmi.impl.XMISaveImpl.writeTopObjects(X MISaveImpl.java:90)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.traverse(XMLSaveI mpl.java:592)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.save(XMLSaveImpl. java:256)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doSave(XMLRes ourceImpl.java:205)
> at
> org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:1344)
> at
> org.eclipse.emf.ecore.resource.impl.ResourceImpl.saveOnlyIfC hangedWithMemoryBuffer(ResourceImpl.java:1120)
> at
> org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:973)
> at
> org.eclipse.uml2.uml.editor.presentation.UMLEditor$14.execut e(UMLEditor.java:1400)
> at
> org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:104)
> at
> org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800)
> at
> org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:116)
> at
> org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121)
>
> Which could be the reason?, perhaps the profile was made with a
> different version of UML2/EMF/Eclipse?.
> Any suggestions would be greatly appreciated.
> Regards,
> Juan Pedro
>

--------------060009000704040606030202
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Juan,<br>
<br>
My guess would be an ill formed profile where there is a feature
without a type.&nbsp; The validator ought to catch that, so be sure to
validate the profile.&nbsp; If you set a breakpoint for this exception,
you'll know which feature is causing the problem.<br>
<br>
<br>
Juan Pedro Silva wrote:
<blockquote cite="mid:gqfs3c$auc$1@build.eclipse.org" type="cite">Hello
everybody.<br>
I'm having problems trying to apply a particular stereotype (the
"Overrides" stereotype from the Theme/UML profile:
<a moz-do-not-send="true" class="moz-txt-link-freetext"
href=" https://www.cs.tcd.ie/Eamonn.Linehan/lero/ThemeUML.profile.u ml"> https://www.cs.tcd.ie/Eamonn.Linehan/lero/ThemeUML.profile.u ml</a>).<br>
The rest of the stereotypes I used applied correctly with no problems,
but each time I try to use "Overrides" I get the following error
(independently of the type of element I'm applying it to):<br>
<font color="#ffff00"><br>
<font color="#3333ff">java.lang.NullPointerException<br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.EStructuralFeatureImpl.getSetting Delegate(EStructuralFeatureImpl.java:814) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eSettingDelegate (BasicEObjectImpl.java:1532) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eDynamicIsSet(Ba sicEObjectImpl.java:1268) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1250) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1235) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.shouldSaveFeature (XMLSaveImpl.java:1194) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveFeatures(XMLS aveImpl.java:1232) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveElementID(XML SaveImpl.java:2667) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMISaveImpl.writeTopObjects(X MISaveImpl.java:90) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.traverse(XMLSaveI mpl.java:592) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.save(XMLSaveImpl. java:256) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doSave(XMLRes ourceImpl.java:205) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:1344) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.saveOnlyIfC hangedWithMemoryBuffer(ResourceImpl.java:1120) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:973) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.uml2.uml.editor.presentation.UMLEditor$14.execut e(UMLEditor.java:1400) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:104) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:116) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121) </font></font><br>
<br>
Which could be the reason?, perhaps the profile was made with a
different version of UML2/EMF/Eclipse?.<br>
Any suggestions would be greatly appreciated.<br>
Regards,<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp; Juan Pedro<br>
<br>
</blockquote>
</body>
</html>

--------------060009000704040606030202--
Re: Problems applying a particular stereotype:java.lang.NullPointerException at EStructuralFeatureI [message #627453 is a reply to message #478260] Thu, 26 March 2009 14:01 Go to previous message
Juan Pedro Silva is currently offline Juan Pedro SilvaFriend
Messages: 258
Registered: July 2009
Senior Member
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Thanks Ed, you were right, as usual.<br>
There are two feature with no types in the profile.<br>
Regards,<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp; Juan Pedro<br>
<br>
Ed Merks escribi&oacute;:
<blockquote cite="mid:gqfu8t$kk5$1@build.eclipse.org" type="cite">
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
Juan,<br>
<br>
My guess would be an ill formed profile where there is a feature
without a type.&nbsp; The validator ought to catch that, so be sure to
validate the profile.&nbsp; If you set a breakpoint for this exception,
you'll know which feature is causing the problem.<br>
<br>
<br>
Juan Pedro Silva wrote:
<blockquote cite="mid:gqfs3c$auc$1@build.eclipse.org" type="cite">Hello
everybody.<br>
I'm having problems trying to apply a particular stereotype (the
"Overrides" stereotype from the Theme/UML profile: <a
moz-do-not-send="true" class="moz-txt-link-freetext"
href=" https://www.cs.tcd.ie/Eamonn.Linehan/lero/ThemeUML.profile.u ml"> https://www.cs.tcd.ie/Eamonn.Linehan/lero/ThemeUML.profile.u ml</a>).<br>
The rest of the stereotypes I used applied correctly with no problems,
but each time I try to use "Overrides" I get the following error
(independently of the type of element I'm applying it to):<br>
<font color="#ffff00"><br>
<font color="#3333ff">java.lang.NullPointerException<br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.EStructuralFeatureImpl.getSetting Delegate(EStructuralFeatureImpl.java:814) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eSettingDelegate (BasicEObjectImpl.java:1532) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eDynamicIsSet(Ba sicEObjectImpl.java:1268) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1250) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.impl.BasicEObjectImpl.eIsSet(BasicEObj ectImpl.java:1235) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.shouldSaveFeature (XMLSaveImpl.java:1194) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveFeatures(XMLS aveImpl.java:1232) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.saveElementID(XML SaveImpl.java:2667) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMISaveImpl.writeTopObjects(X MISaveImpl.java:90) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.traverse(XMLSaveI mpl.java:592) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLSaveImpl.save(XMLSaveImpl. java:256) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doSave(XMLRes ourceImpl.java:205) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:1344) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.saveOnlyIfC hangedWithMemoryBuffer(ResourceImpl.java:1120) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.save(Resour ceImpl.java:973) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.uml2.uml.editor.presentation.UMLEditor$14.execut e(UMLEditor.java:1400) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:104) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:116) <br>
&nbsp;&nbsp; &nbsp;at
org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121) </font></font><br>
<br>
Which could be the reason?, perhaps the profile was made with a
different version of UML2/EMF/Eclipse?.<br>
Any suggestions would be greatly appreciated.<br>
Regards,<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp; Juan Pedro<br>
<br>
</blockquote>
</blockquote>
</body>
</html>
Previous Topic:Problems applying a particular stereotype:java.lang.NullPointerException at EStructuralFeatureImpl.
Next Topic:[Announce] MDT UML2 3.0.0 I200903261317 is available
Goto Forum:
  


Current Time: Sun Mar 29 18:31:32 GMT 2020

Powered by FUDForum. Page generated in 0.01909 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top