Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » setting uml2 namespaces
setting uml2 namespaces [message #477687] Wed, 20 August 2008 23:21 Go to next message
Victor Hugo is currently offline Victor HugoFriend
Messages: 20
Registered: July 2009
Junior Member
Hi friends,

When I run an uml2 atl transformation programmatically the generated model
don't has the MODEL element as root element of tree. There are elements
(packages and classes) at the same level of the MODEL element.

I expected a document with this hierarch:
-Model
-Package1
-class1
-class2
-package2
-class3


But I obtain an document with this hierach:
-Model
-Package1
-class1
-class2
-Package2
-class3

the problem is: i dont know how to set namespace property in uml2 elements
(classes, packages, ...)
i'm using eclipse-uml2-1.1.1

Best Regards
Re: setting uml2 namespaces [message #477688 is a reply to message #477687] Fri, 22 August 2008 13:25 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Victor,

It looks like the exact question was posted and answered on the m2m
newsgroup on 19/08/2008.

- James.



"Victor Hugo" <victorhcf@gmail.com> wrote in message
news:015afeb39f9771a4cf63c78d006ff1bb$1@www.eclipse.org...
> Hi friends,
>
> When I run an uml2 atl transformation programmatically the generated model
> don't has the MODEL element as root element of tree. There are elements
> (packages and classes) at the same level of the MODEL element.
>
> I expected a document with this hierarch:
> -Model
> -Package1
> -class1
> -class2
> -package2
> -class3
>
>
> But I obtain an document with this hierach:
> -Model
> -Package1
> -class1
> -class2
> -Package2
> -class3
>
> the problem is: i dont know how to set namespace property in uml2 elements
> (classes, packages, ...)
> i'm using eclipse-uml2-1.1.1
>
> Best Regards
>
Re: setting uml2 namespaces [message #626880 is a reply to message #477687] Fri, 22 August 2008 13:25 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Victor,

It looks like the exact question was posted and answered on the m2m
newsgroup on 19/08/2008.

- James.



"Victor Hugo" <victorhcf@gmail.com> wrote in message
news:015afeb39f9771a4cf63c78d006ff1bb$1@www.eclipse.org...
> Hi friends,
>
> When I run an uml2 atl transformation programmatically the generated model
> don't has the MODEL element as root element of tree. There are elements
> (packages and classes) at the same level of the MODEL element.
>
> I expected a document with this hierarch:
> -Model
> -Package1
> -class1
> -class2
> -package2
> -class3
>
>
> But I obtain an document with this hierach:
> -Model
> -Package1
> -class1
> -class2
> -Package2
> -class3
>
> the problem is: i dont know how to set namespace property in uml2 elements
> (classes, packages, ...)
> i'm using eclipse-uml2-1.1.1
>
> Best Regards
>
Previous Topic:setting uml2 namespaces
Next Topic:Serialization: Workspace URIs vs. External URIs.
Goto Forum:
  


Current Time: Sun Mar 29 06:53:25 GMT 2020

Powered by FUDForum. Page generated in 0.01958 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top