Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » Validation Problem
Validation Problem [message #473446] Thu, 28 June 2007 10:50 Go to next message
Eclipse UserFriend
Originally posted by: antti.evesti.vtt.fi

Hi,

When I validate an ecore profile which I get after profile definition I get
'Validation Problems' warning that says 'Reason: Diagnosis of
<<Package>><Profile> Ecore Profile', and details view shows 'Not all the
members of namespace <Profile> Ecore Profile are distinguishable within it.'

If I validate my profile validation ends succesfully.

This doesn't cause any further problems, but it would be nice to know if I
have constructed my profile in a wrong way.


Antti
Re: Validation Problem [message #473448 is a reply to message #473446] Thu, 28 June 2007 13:24 Go to previous messageGo to next message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Antti,

Are there any obvious items with the same name within your profile? If
not, would it be possible to post your profile.
Not all the validation rules have been implemented in UML.
EMF validation rules are different so you might get a UML model that passes
UML validation but the resulting .ecore representation having warnings or
errors.

- James

"Antti Evesti" <antti.evesti@vtt.fi> wrote in message
news:f603pr$3mi$1@build.eclipse.org...
> Hi,
>
> When I validate an ecore profile which I get after profile definition I
get
> 'Validation Problems' warning that says 'Reason: Diagnosis of
> <<Package>><Profile> Ecore Profile', and details view shows 'Not all the
> members of namespace <Profile> Ecore Profile are distinguishable within
it.'
>
> If I validate my profile validation ends succesfully.
>
> This doesn't cause any further problems, but it would be nice to know if I
> have constructed my profile in a wrong way.
>
>
> Antti
>
>
Re: Validation Problem [message #473454 is a reply to message #473448] Fri, 29 June 2007 05:58 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: antti.evesti.vtt.fi

Hi James,

I noticed this issue with many profiles as well as this simple profile that
contains only one stereotype applicable to component element.

Below is the content of the profile, I used filename SampleToNews.uml while
constructing this profile. I suppose it is illegal to attach files to this
newsgroup.

Antti

<?xml version="1.0" encoding="UTF-8"?>

<uml:Profile xmi:version="2.1"
xmlns:xmi="http://schema.omg.org/spec/XMI/2.1"
xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore"
xmlns:uml="http://www.eclipse.org/uml2/2.0.0/UML"
xmi:id="_ETNtoCYEEdyaa53nuWYv-g" name="sampleProfile"
metaclassReference="_KoWqwCYEEdyaa53nuWYv-g">

<eAnnotations xmi:id="_TndTwSYEEdyaa53nuWYv-g"
source="http://www.eclipse.org/uml2/2.0.0/UML">

<contents xmi:type="ecore:EPackage" xmi:id="_TndTwiYEEdyaa53nuWYv-g"
name="sampleProfile"
nsURI="http:///schemas/sampleProfile/_TndTwCYEEdyaa53nuWYv-g/0"
nsPrefix="sampleProfile">

<eClassifiers xmi:type="ecore:EClass" xmi:id="_TndTwyYEEdyaa53nuWYv-g"
name="sampleStereotype">

<eAnnotations xmi:id="_TndTxCYEEdyaa53nuWYv-g"
source="http://www.eclipse.org/uml2/2.0.0/UML"
references="_MDOtUCYEEdyaa53nuWYv-g"/>

<eStructuralFeatures xmi:type="ecore:EReference"
xmi:id="_TndTxSYEEdyaa53nuWYv-g" name="base_Component" ordered="false"
lowerBound="1">

<eType xmi:type="ecore:EClass"
href="http://www.eclipse.org/uml2/2.0.0/UML#//Component"/>

</eStructuralFeatures>

</eClassifiers>

</contents>

</eAnnotations>

<elementImport xmi:id="_KoWqwCYEEdyaa53nuWYv-g">

<importedElement xmi:type="uml:Class"
href="pathmap://UML_METAMODELS/UML.metamodel.uml#Component"/>

</elementImport>

<packagedElement xmi:type="uml:Stereotype" xmi:id="_MDOtUCYEEdyaa53nuWYv-g"
name="sampleStereotype">

<ownedAttribute xmi:id="_RBYCUiYEEdyaa53nuWYv-g" name="base_Component"
association="_RBYCUCYEEdyaa53nuWYv-g">

<type xmi:type="uml:Class"
href="pathmap://UML_METAMODELS/UML.metamodel.uml#Component"/>

</ownedAttribute>

</packagedElement>

<packagedElement xmi:type="uml:Extension" xmi:id="_RBYCUCYEEdyaa53nuWYv-g"
name="Component_sampleStereotype" memberEnd="_RBYCUSYEEdyaa53nuWYv-g
_RBYCUiYEEdyaa53nuWYv-g">

<ownedEnd xmi:type="uml:ExtensionEnd" xmi:id="_RBYCUSYEEdyaa53nuWYv-g"
name="extension_sampleStereotype" type="_MDOtUCYEEdyaa53nuWYv-g"
aggregation="composite" association="_RBYCUCYEEdyaa53nuWYv-g"/>

</packagedElement>

</uml:Profile>



"James Bruck" <jbruck@ca.ibm.com> wrote in message
news:f60cqt$pm9$2@build.eclipse.org...
> Hi Antti,
>
> Are there any obvious items with the same name within your profile? If
> not, would it be possible to post your profile.
> Not all the validation rules have been implemented in UML.
> EMF validation rules are different so you might get a UML model that
> passes
> UML validation but the resulting .ecore representation having warnings or
> errors.
>
> - James
>
> "Antti Evesti" <antti.evesti@vtt.fi> wrote in message
> news:f603pr$3mi$1@build.eclipse.org...
>> Hi,
>>
>> When I validate an ecore profile which I get after profile definition I
> get
>> 'Validation Problems' warning that says 'Reason: Diagnosis of
>> <<Package>><Profile> Ecore Profile', and details view shows 'Not all the
>> members of namespace <Profile> Ecore Profile are distinguishable within
> it.'
>>
>> If I validate my profile validation ends succesfully.
>>
>> This doesn't cause any further problems, but it would be nice to know if
>> I
>> have constructed my profile in a wrong way.
>>
>>
>> Antti
>>
>>
>
>
Re: Validation Problem [message #473756 is a reply to message #473446] Wed, 04 July 2007 20:57 Go to previous messageGo to next message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
Antti,

You can safely ignore this warning. It's complaining about the fact that the
Ecore profile imports type named 'String' and 'Boolean' but also imports the
UML metamodel package which in turn contains types named 'String' and
'Boolean'.

Kenn

"Antti Evesti" <antti.evesti@vtt.fi> wrote in message
news:f603pr$3mi$1@build.eclipse.org...
> Hi,
>
> When I validate an ecore profile which I get after profile definition I
> get 'Validation Problems' warning that says 'Reason: Diagnosis of
> <<Package>><Profile> Ecore Profile', and details view shows 'Not all the
> members of namespace <Profile> Ecore Profile are distinguishable within
> it.'
>
> If I validate my profile validation ends succesfully.
>
> This doesn't cause any further problems, but it would be nice to know if I
> have constructed my profile in a wrong way.
>
>
> Antti
>
Re: Validation Problem [message #473939 is a reply to message #473756] Tue, 10 July 2007 12:39 Go to previous message
Eclipse UserFriend
Originally posted by: antti.evesti.vtt.fi

Thanks Kenn,

This relieve me of.

Antti



"Kenn Hussey" <khussey@ca.ibm.com> wrote in message
news:f6h1j3$qs1$1@build.eclipse.org...
> Antti,
>
> You can safely ignore this warning. It's complaining about the fact that
> the Ecore profile imports type named 'String' and 'Boolean' but also
> imports the UML metamodel package which in turn contains types named
> 'String' and 'Boolean'.
>
> Kenn
>
> "Antti Evesti" <antti.evesti@vtt.fi> wrote in message
> news:f603pr$3mi$1@build.eclipse.org...
>> Hi,
>>
>> When I validate an ecore profile which I get after profile definition I
>> get 'Validation Problems' warning that says 'Reason: Diagnosis of
>> <<Package>><Profile> Ecore Profile', and details view shows 'Not all the
>> members of namespace <Profile> Ecore Profile are distinguishable within
>> it.'
>>
>> If I validate my profile validation ends succesfully.
>>
>> This doesn't cause any further problems, but it would be nice to know if
>> I have constructed my profile in a wrong way.
>>
>>
>> Antti
>>
>
>
Re: Validation Problem [message #622661 is a reply to message #473446] Thu, 28 June 2007 13:24 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Antti,

Are there any obvious items with the same name within your profile? If
not, would it be possible to post your profile.
Not all the validation rules have been implemented in UML.
EMF validation rules are different so you might get a UML model that passes
UML validation but the resulting .ecore representation having warnings or
errors.

- James

"Antti Evesti" <antti.evesti@vtt.fi> wrote in message
news:f603pr$3mi$1@build.eclipse.org...
> Hi,
>
> When I validate an ecore profile which I get after profile definition I
get
> 'Validation Problems' warning that says 'Reason: Diagnosis of
> <<Package>><Profile> Ecore Profile', and details view shows 'Not all the
> members of namespace <Profile> Ecore Profile are distinguishable within
it.'
>
> If I validate my profile validation ends succesfully.
>
> This doesn't cause any further problems, but it would be nice to know if I
> have constructed my profile in a wrong way.
>
>
> Antti
>
>
Re: Validation Problem [message #622667 is a reply to message #473448] Fri, 29 June 2007 05:58 Go to previous message
Eclipse UserFriend
Originally posted by: antti.evesti.vtt.fi

Hi James,

I noticed this issue with many profiles as well as this simple profile that
contains only one stereotype applicable to component element.

Below is the content of the profile, I used filename SampleToNews.uml while
constructing this profile. I suppose it is illegal to attach files to this
newsgroup.

Antti

<?xml version="1.0" encoding="UTF-8"?>

<uml:Profile xmi:version="2.1"
xmlns:xmi="http://schema.omg.org/spec/XMI/2.1"
xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore"
xmlns:uml="http://www.eclipse.org/uml2/2.0.0/UML"
xmi:id="_ETNtoCYEEdyaa53nuWYv-g" name="sampleProfile"
metaclassReference="_KoWqwCYEEdyaa53nuWYv-g">

<eAnnotations xmi:id="_TndTwSYEEdyaa53nuWYv-g"
source="http://www.eclipse.org/uml2/2.0.0/UML">

<contents xmi:type="ecore:EPackage" xmi:id="_TndTwiYEEdyaa53nuWYv-g"
name="sampleProfile"
nsURI="http:///schemas/sampleProfile/_TndTwCYEEdyaa53nuWYv-g/0"
nsPrefix="sampleProfile">

<eClassifiers xmi:type="ecore:EClass" xmi:id="_TndTwyYEEdyaa53nuWYv-g"
name="sampleStereotype">

<eAnnotations xmi:id="_TndTxCYEEdyaa53nuWYv-g"
source="http://www.eclipse.org/uml2/2.0.0/UML"
references="_MDOtUCYEEdyaa53nuWYv-g"/>

<eStructuralFeatures xmi:type="ecore:EReference"
xmi:id="_TndTxSYEEdyaa53nuWYv-g" name="base_Component" ordered="false"
lowerBound="1">

<eType xmi:type="ecore:EClass"
href="http://www.eclipse.org/uml2/2.0.0/UML#//Component"/>

</eStructuralFeatures>

</eClassifiers>

</contents>

</eAnnotations>

<elementImport xmi:id="_KoWqwCYEEdyaa53nuWYv-g">

<importedElement xmi:type="uml:Class"
href="pathmap://UML_METAMODELS/UML.metamodel.uml#Component"/>

</elementImport>

<packagedElement xmi:type="uml:Stereotype" xmi:id="_MDOtUCYEEdyaa53nuWYv-g"
name="sampleStereotype">

<ownedAttribute xmi:id="_RBYCUiYEEdyaa53nuWYv-g" name="base_Component"
association="_RBYCUCYEEdyaa53nuWYv-g">

<type xmi:type="uml:Class"
href="pathmap://UML_METAMODELS/UML.metamodel.uml#Component"/>

</ownedAttribute>

</packagedElement>

<packagedElement xmi:type="uml:Extension" xmi:id="_RBYCUCYEEdyaa53nuWYv-g"
name="Component_sampleStereotype" memberEnd="_RBYCUSYEEdyaa53nuWYv-g
_RBYCUiYEEdyaa53nuWYv-g">

<ownedEnd xmi:type="uml:ExtensionEnd" xmi:id="_RBYCUSYEEdyaa53nuWYv-g"
name="extension_sampleStereotype" type="_MDOtUCYEEdyaa53nuWYv-g"
aggregation="composite" association="_RBYCUCYEEdyaa53nuWYv-g"/>

</packagedElement>

</uml:Profile>



"James Bruck" <jbruck@ca.ibm.com> wrote in message
news:f60cqt$pm9$2@build.eclipse.org...
> Hi Antti,
>
> Are there any obvious items with the same name within your profile? If
> not, would it be possible to post your profile.
> Not all the validation rules have been implemented in UML.
> EMF validation rules are different so you might get a UML model that
> passes
> UML validation but the resulting .ecore representation having warnings or
> errors.
>
> - James
>
> "Antti Evesti" <antti.evesti@vtt.fi> wrote in message
> news:f603pr$3mi$1@build.eclipse.org...
>> Hi,
>>
>> When I validate an ecore profile which I get after profile definition I
> get
>> 'Validation Problems' warning that says 'Reason: Diagnosis of
>> <<Package>><Profile> Ecore Profile', and details view shows 'Not all the
>> members of namespace <Profile> Ecore Profile are distinguishable within
> it.'
>>
>> If I validate my profile validation ends succesfully.
>>
>> This doesn't cause any further problems, but it would be nice to know if
>> I
>> have constructed my profile in a wrong way.
>>
>>
>> Antti
>>
>>
>
>
Re: Validation Problem [message #622728 is a reply to message #473446] Wed, 04 July 2007 20:57 Go to previous message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
Antti,

You can safely ignore this warning. It's complaining about the fact that the
Ecore profile imports type named 'String' and 'Boolean' but also imports the
UML metamodel package which in turn contains types named 'String' and
'Boolean'.

Kenn

"Antti Evesti" <antti.evesti@vtt.fi> wrote in message
news:f603pr$3mi$1@build.eclipse.org...
> Hi,
>
> When I validate an ecore profile which I get after profile definition I
> get 'Validation Problems' warning that says 'Reason: Diagnosis of
> <<Package>><Profile> Ecore Profile', and details view shows 'Not all the
> members of namespace <Profile> Ecore Profile are distinguishable within
> it.'
>
> If I validate my profile validation ends succesfully.
>
> This doesn't cause any further problems, but it would be nice to know if I
> have constructed my profile in a wrong way.
>
>
> Antti
>
Re: Validation Problem [message #623315 is a reply to message #473756] Tue, 10 July 2007 12:39 Go to previous message
Eclipse UserFriend
Originally posted by: antti.evesti.vtt.fi

Thanks Kenn,

This relieve me of.

Antti



"Kenn Hussey" <khussey@ca.ibm.com> wrote in message
news:f6h1j3$qs1$1@build.eclipse.org...
> Antti,
>
> You can safely ignore this warning. It's complaining about the fact that
> the Ecore profile imports type named 'String' and 'Boolean' but also
> imports the UML metamodel package which in turn contains types named
> 'String' and 'Boolean'.
>
> Kenn
>
> "Antti Evesti" <antti.evesti@vtt.fi> wrote in message
> news:f603pr$3mi$1@build.eclipse.org...
>> Hi,
>>
>> When I validate an ecore profile which I get after profile definition I
>> get 'Validation Problems' warning that says 'Reason: Diagnosis of
>> <<Package>><Profile> Ecore Profile', and details view shows 'Not all the
>> members of namespace <Profile> Ecore Profile are distinguishable within
>> it.'
>>
>> If I validate my profile validation ends succesfully.
>>
>> This doesn't cause any further problems, but it would be nice to know if
>> I have constructed my profile in a wrong way.
>>
>>
>> Antti
>>
>
>
Previous Topic:Load and parse UML file
Next Topic:Modifying existing profile
Goto Forum:
  


Current Time: Tue Nov 21 01:02:48 GMT 2017

Powered by FUDForum. Page generated in 0.02346 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software