Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » Installing uml2...
Installing uml2... [message #471815] Tue, 27 March 2007 11:52 Go to next message
Eclipse UserFriend
Originally posted by: patrick.gelin.free.fr

Hi,

This is my Eclipse version:
Version: 3.3.0
Build id: I20070323-1616

I downloaded and installed:
* emf-sdo-runtime-2.3.0M5.zip
* xsd-runtime-2.3.0M5.zip
* uml2-2.1M5.zip

But there is a problem because I can't see anything concerning uml into the
menu... so what is the problem?

Thank you for your help.

Patrick
Re: Installing uml2... [message #471816 is a reply to message #471815] Tue, 27 March 2007 13:06 Go to previous messageGo to next message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Patrick,

Did you create a uml model? Did you read the "getting started" articles?

Cheers,

- James.


"Patrick Gelin" <patrick.gelin@free.fr> wrote in message
news:eub0ie$8tk$1@utils.eclipse.org...
> Hi,
>
> This is my Eclipse version:
> Version: 3.3.0
> Build id: I20070323-1616
>
> I downloaded and installed:
> * emf-sdo-runtime-2.3.0M5.zip
> * xsd-runtime-2.3.0M5.zip
> * uml2-2.1M5.zip
>
> But there is a problem because I can't see anything concerning uml into
the
> menu... so what is the problem?
>
> Thank you for your help.
>
> Patrick
Re: Installing uml2... [message #471819 is a reply to message #471816] Tue, 27 March 2007 14:59 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: patrick.gelin.free.fr

Hi James,

I can't create a UML model because there is no menu about that and I can't
find any help documentation into eclipse about the UML module... What I can
see is only into "Manage Configuration" and property, something like this:

UML2 Runtime + End-User Tools 2.1.0.v200702222305

Identifier: org.eclipse.uml2

Provider Eclipse.org

Size: O KB

The size is very small, isn't it?

I'm really asking myself about the installation of the module. Is it
possible to uninstall simply and retry to install an other way?

Patrick

James Bruck wrote:

> Hi Patrick,
>
> Did you create a uml model? Did you read the "getting started" articles?
>
> Cheers,
>
> - James.
>
Re: Installing uml2... [message #471820 is a reply to message #471819] Tue, 27 March 2007 15:25 Go to previous messageGo to next message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Patrick,


Articles can be found here http://wiki.eclipse.org/index.php/MDT-UML2

You can create a .uml model through...

File > New > Other ... > Example EMF Model Creation Wizards > UML model.
Once you've created your model, you can see the "UML Menu" item.

- James.


"Patrick Gelin" <patrick.gelin@free.fr> wrote in message
news:eubbgf$lj0$1@utils.eclipse.org...
> Hi James,
>
> I can't create a UML model because there is no menu about that and I can't
> find any help documentation into eclipse about the UML module... What I
can
> see is only into "Manage Configuration" and property, something like this:
>
> UML2 Runtime + End-User Tools 2.1.0.v200702222305
>
> Identifier: org.eclipse.uml2
>
> Provider Eclipse.org
>
> Size: O KB
>
> The size is very small, isn't it?
>
> I'm really asking myself about the installation of the module. Is it
> possible to uninstall simply and retry to install an other way?
>
> Patrick
>
> James Bruck wrote:
>
> > Hi Patrick,
> >
> > Did you create a uml model? Did you read the "getting started"
articles?
> >
> > Cheers,
> >
> > - James.
> >
>
Re: Installing uml2... [message #471923 is a reply to message #471820] Tue, 27 March 2007 16:00 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: patrick.gelin.free.fr

ok, I follow the article until:

(...)
Creating Models

At the root of a typical UML model is a model element. It contains a
(hierarchical) set of elements that together describe the physical system
being modeled. To create a model using the UML editor, follow these steps:

1) Select a project (i.e. Getting Started with UML2) in the Navigator view
and select the File > New > Other... menu item.

2) Select the UML Model wizard from the Example EMF Model Creation Wizards
category and press the Next > button.

here I can't excute the point (2) because there isn't UML Model wizard into
my new Menu...

That is the problem!

What can I do? Uninstall and reinstall...

Patrick

James Bruck wrote:

> Hi Patrick,
>
>
> Articles can be found here http://wiki.eclipse.org/index.php/MDT-UML2
>
> You can create a .uml model through...
>
> File > New > Other ... > Example EMF Model Creation Wizards > UML model.
> Once you've created your model, you can see the "UML Menu" item.
>
> - James.
>
>
> "Patrick Gelin" <patrick.gelin@free.fr> wrote in message
> news:eubbgf$lj0$1@utils.eclipse.org...
>> Hi James,
>>
>> I can't create a UML model because there is no menu about that and I
>> can't find any help documentation into eclipse about the UML module...
>> What I
> can
>> see is only into "Manage Configuration" and property, something like
>> this:
>>
>> UML2 Runtime + End-User Tools 2.1.0.v200702222305
>>
>> Identifier: org.eclipse.uml2
>>
>> Provider Eclipse.org
>>
>> Size: O KB
>>
>> The size is very small, isn't it?
>>
>> I'm really asking myself about the installation of the module. Is it
>> possible to uninstall simply and retry to install an other way?
>>
>> Patrick
>>
>> James Bruck wrote:
>>
>> > Hi Patrick,
>> >
>> > Did you create a uml model? Did you read the "getting started"
> articles?
>> >
>> > Cheers,
>> >
>> > - James.
>> >
>>
Re: Installing uml2... [message #471927 is a reply to message #471923] Tue, 27 March 2007 16:58 Go to previous messageGo to next message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Patrick,

Sounds like you didn't install uml properly. Yes you will have to
reinstall.

- James.


"Patrick Gelin" <patrick.gelin@free.fr> wrote in message
news:eubf2k$34l$1@utils.eclipse.org...
> ok, I follow the article until:
>
> (...)
> Creating Models
>
> At the root of a typical UML model is a model element. It contains a
> (hierarchical) set of elements that together describe the physical system
> being modeled. To create a model using the UML editor, follow these steps:
>
> 1) Select a project (i.e. Getting Started with UML2) in the Navigator view
> and select the File > New > Other... menu item.
>
> 2) Select the UML Model wizard from the Example EMF Model Creation Wizards
> category and press the Next > button.
>
> here I can't excute the point (2) because there isn't UML Model wizard
into
> my new Menu...
>
> That is the problem!
>
> What can I do? Uninstall and reinstall...
>
> Patrick
>
> James Bruck wrote:
>
> > Hi Patrick,
> >
> >
> > Articles can be found here http://wiki.eclipse.org/index.php/MDT-UML2
> >
> > You can create a .uml model through...
> >
> > File > New > Other ... > Example EMF Model Creation Wizards > UML model.
> > Once you've created your model, you can see the "UML Menu" item.
> >
> > - James.
> >
> >
> > "Patrick Gelin" <patrick.gelin@free.fr> wrote in message
> > news:eubbgf$lj0$1@utils.eclipse.org...
> >> Hi James,
> >>
> >> I can't create a UML model because there is no menu about that and I
> >> can't find any help documentation into eclipse about the UML module...
> >> What I
> > can
> >> see is only into "Manage Configuration" and property, something like
> >> this:
> >>
> >> UML2 Runtime + End-User Tools 2.1.0.v200702222305
> >>
> >> Identifier: org.eclipse.uml2
> >>
> >> Provider Eclipse.org
> >>
> >> Size: O KB
> >>
> >> The size is very small, isn't it?
> >>
> >> I'm really asking myself about the installation of the module. Is it
> >> possible to uninstall simply and retry to install an other way?
> >>
> >> Patrick
> >>
> >> James Bruck wrote:
> >>
> >> > Hi Patrick,
> >> >
> >> > Did you create a uml model? Did you read the "getting started"
> > articles?
> >> >
> >> > Cheers,
> >> >
> >> > - James.
> >> >
> >>
>
Re: Installing uml2... [message #471931 is a reply to message #471927] Tue, 27 March 2007 18:46 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: patrick.gelin.free.fr

I said myself, may be you had to install UML2 TOOLS. So I dit it's the
same problem. I verifier with md5sum the UML2 package I downloaded, and
it's ok, the the problem is not here. I'm ok to reinstall it but I think
nothing will change. Do you know a dialog box where I can see error log or
something like that about plugin installation?

Patrick
Re: Installing uml2... [message #471934 is a reply to message #471931] Tue, 27 March 2007 19:06 Go to previous messageGo to next message
Andy Evans is currently offline Andy EvansFriend
Messages: 61
Registered: July 2009
Member
Patrick,

Do you have the EMF Wizards missing as well. If so, we got hit by
the fact that Eclipse M5 was running Java 1.4.2, but actually needs 1.5.
Deleting 1.4.2 did the trick.

Andy

"Patrick Gelin" <patrick.gelin@free.fr> wrote in message
news:pan.2007.03.27.18.46.07.959425@free.fr...
>I said myself, may be you had to install UML2 TOOLS. So I dit it's the
> same problem. I verifier with md5sum the UML2 package I downloaded, and
> it's ok, the the problem is not here. I'm ok to reinstall it but I think
> nothing will change. Do you know a dialog box where I can see error log or
> something like that about plugin installation?
>
> Patrick
Re: Installing uml2... [message #471938 is a reply to message #471934] Wed, 28 March 2007 06:29 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: patrick.gelin.free.fr

This is the VM i'm using: j2sdk1.4.2_13
About the EMF wizard I can say it is missing too.This is what I can see
into the choice of wizard when I select 'new':

class
- interface
- java Project
- Java Project from existing Ant Buildfile
- Plug in project
- General (folder)
- CVS (folder)
- Java (folder)
- Plug in Development (folder)
- Server (folder)
- User Assistance (folder)
- Examples (folder)

About the example folder it contain wizard of UML2 TOOLS I installed at
last. The folders it contain are:
- EMFT Query Plug-ins
- EMFT Transaction Plug-ins
- EMFT Validation Plug-ins
- GEF
- GEF Plug-ins
- GMF Plug-ins

That's all! nothing about EMF or UML... So you think I've got a bad
Virtual Machine... This is my $JAVA_HOME=/opt/j2sdk1.4.2_13/jre. What can
I do? Change the virtual machine to 1.5?

Patrick



Le Tue, 27 Mar 2007 20:06:44 +0100, ase a écrit :

> Patrick,
>
> Do you have the EMF Wizards missing as well. If so, we got hit by
> the fact that Eclipse M5 was running Java 1.4.2, but actually needs 1.5.
> Deleting 1.4.2 did the trick.
>
> Andy
>
Re: Installing uml2... [message #471952 is a reply to message #471938] Wed, 28 March 2007 14:09 Go to previous messageGo to next message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
Patrick,

You need a Java 5 VM to use EMF 2.3 and UML2 2.1.

Kenn

"Patrick Gelin" <patrick.gelin@free.fr> wrote in message
news:pan.2007.03.28.06.29.12.247315@free.fr...
> This is the VM i'm using: j2sdk1.4.2_13
> About the EMF wizard I can say it is missing too.This is what I can see
> into the choice of wizard when I select 'new':
>
> class
> - interface
> - java Project
> - Java Project from existing Ant Buildfile
> - Plug in project
> - General (folder)
> - CVS (folder)
> - Java (folder)
> - Plug in Development (folder)
> - Server (folder)
> - User Assistance (folder)
> - Examples (folder)
>
> About the example folder it contain wizard of UML2 TOOLS I installed at
> last. The folders it contain are:
> - EMFT Query Plug-ins
> - EMFT Transaction Plug-ins
> - EMFT Validation Plug-ins
> - GEF
> - GEF Plug-ins
> - GMF Plug-ins
>
> That's all! nothing about EMF or UML... So you think I've got a bad
> Virtual Machine... This is my $JAVA_HOME=/opt/j2sdk1.4.2_13/jre. What can
> I do? Change the virtual machine to 1.5?
>
> Patrick
>
>
>
> Le Tue, 27 Mar 2007 20:06:44 +0100, ase a
Re: Installing uml2... [message #471959 is a reply to message #471952] Wed, 28 March 2007 15:11 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: patrick.gelin.free.fr

Kenn,

ok this is my JAVA_HOME:
JAVA_HOME=/opt/jre1.5.0_11

But the problem is the same.
- Is it possible, into Eclipse, to see if it use the good jre...
- Do you think I have to delete UML plugin and reinstall it?

Patrick

Le Wed, 28 Mar 2007 10:09:44 -0400, Kenn Hussey a écrit :

> Patrick,
>
> You need a Java 5 VM to use EMF 2.3 and UML2 2.1.
>
> Kenn
>
Re: Installing uml2... [message #471966 is a reply to message #471952] Wed, 28 March 2007 15:36 Go to previous message
Eclipse UserFriend
Originally posted by: patrick.gelin.free.fr

Ok, I've found the solution!

The problem is that the JAVA_HOME variable into my .bashrc is not take
into account. Alternatives defined the java command as
/opt/j2sdk1.4.2_13/... so I have to redefined it as /opt/jre1.5.0_11/...

Thank you everybody for your help.

Have a good day!

Patrick
Re: Installing uml2... [message #603216 is a reply to message #471815] Tue, 27 March 2007 13:06 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Patrick,

Did you create a uml model? Did you read the "getting started" articles?

Cheers,

- James.


"Patrick Gelin" <patrick.gelin@free.fr> wrote in message
news:eub0ie$8tk$1@utils.eclipse.org...
> Hi,
>
> This is my Eclipse version:
> Version: 3.3.0
> Build id: I20070323-1616
>
> I downloaded and installed:
> * emf-sdo-runtime-2.3.0M5.zip
> * xsd-runtime-2.3.0M5.zip
> * uml2-2.1M5.zip
>
> But there is a problem because I can't see anything concerning uml into
the
> menu... so what is the problem?
>
> Thank you for your help.
>
> Patrick
Re: Installing uml2... [message #603231 is a reply to message #471816] Tue, 27 March 2007 14:59 Go to previous message
Eclipse UserFriend
Originally posted by: patrick.gelin.free.fr

Hi James,

I can't create a UML model because there is no menu about that and I can't
find any help documentation into eclipse about the UML module... What I can
see is only into "Manage Configuration" and property, something like this:

UML2 Runtime + End-User Tools 2.1.0.v200702222305

Identifier: org.eclipse.uml2

Provider Eclipse.org

Size: O KB

The size is very small, isn't it?

I'm really asking myself about the installation of the module. Is it
possible to uninstall simply and retry to install an other way?

Patrick

James Bruck wrote:

> Hi Patrick,
>
> Did you create a uml model? Did you read the "getting started" articles?
>
> Cheers,
>
> - James.
>
Re: Installing uml2... [message #603234 is a reply to message #471819] Tue, 27 March 2007 15:25 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Hi Patrick,


Articles can be found here http://wiki.eclipse.org/index.php/MDT-UML2

You can create a .uml model through...

File > New > Other ... > Example EMF Model Creation Wizards > UML model.
Once you've created your model, you can see the "UML Menu" item.

- James.


"Patrick Gelin" <patrick.gelin@free.fr> wrote in message
news:eubbgf$lj0$1@utils.eclipse.org...
> Hi James,
>
> I can't create a UML model because there is no menu about that and I can't
> find any help documentation into eclipse about the UML module... What I
can
> see is only into "Manage Configuration" and property, something like this:
>
> UML2 Runtime + End-User Tools 2.1.0.v200702222305
>
> Identifier: org.eclipse.uml2
>
> Provider Eclipse.org
>
> Size: O KB
>
> The size is very small, isn't it?
>
> I'm really asking myself about the installation of the module. Is it
> possible to uninstall simply and retry to install an other way?
>
> Patrick
>
> James Bruck wrote:
>
> > Hi Patrick,
> >
> > Did you create a uml model? Did you read the "getting started"
articles?
> >
> > Cheers,
> >
> > - James.
> >
>
Re: Installing uml2... [message #603257 is a reply to message #471820] Tue, 27 March 2007 16:00 Go to previous message
Eclipse UserFriend
Originally posted by: patrick.gelin.free.fr

ok, I follow the article until:

(...)
Creating Models

At the root of a typical UML model is a model element. It contains a
(hierarchical) set of elements that together describe the physical system
being modeled. To create a model using the UML editor, follow these steps:

1) Select a project (i.e. Getting Started with UML2) in the Navigator view
and select the File > New > Other... menu item.

2) Select the UML Model wizard from the Example EMF Model Creation Wizards
category and press the Next > button.

here I can't excute the point (2) because there isn't UML Model wizard into
my new Menu...

That is the problem!

What can I do? Uninstall and reinstall...

Patrick

James Bruck wrote:

> Hi Patrick,
>
>
> Articles can be found here http://wiki.eclipse.org/index.php/MDT-UML2
>
> You can create a .uml model through...
>
> File > New > Other ... > Example EMF Model Creation Wizards > UML model.
> Once you've created your model, you can see the "UML Menu" item.
>
> - James.
>
>
> "Patrick Gelin" <patrick.gelin@free.fr> wrote in message
> news:eubbgf$lj0$1@utils.eclipse.org...
>> Hi James,
>>
>> I can't create a UML model because there is no menu about that and I
>> can't find any help documentation into eclipse about the UML module...
>> What I
> can
>> see is only into "Manage Configuration" and property, something like
>> this:
>>
>> UML2 Runtime + End-User Tools 2.1.0.v200702222305
>>
>> Identifier: org.eclipse.uml2
>>
>> Provider Eclipse.org
>>
>> Size: O KB
>>
>> The size is very small, isn't it?
>>
>> I'm really asking myself about the installation of the module. Is it
>> possible to uninstall simply and retry to install an other way?
>>
>> Patrick
>>
>> James Bruck wrote:
>>
>> > Hi Patrick,
>> >
>> > Did you create a uml model? Did you read the "getting started"
> articles?
>> >
>> > Cheers,
>> >
>> > - James.
>> >
>>
Re: Installing uml2... [message #603264 is a reply to message #471923] Tue, 27 March 2007 16:58 Go to previous message
james bruck is currently offline james bruckFriend
Messages: 1724
Registered: July 2009
Senior Member
Patrick,

Sounds like you didn't install uml properly. Yes you will have to
reinstall.

- James.


"Patrick Gelin" <patrick.gelin@free.fr> wrote in message
news:eubf2k$34l$1@utils.eclipse.org...
> ok, I follow the article until:
>
> (...)
> Creating Models
>
> At the root of a typical UML model is a model element. It contains a
> (hierarchical) set of elements that together describe the physical system
> being modeled. To create a model using the UML editor, follow these steps:
>
> 1) Select a project (i.e. Getting Started with UML2) in the Navigator view
> and select the File > New > Other... menu item.
>
> 2) Select the UML Model wizard from the Example EMF Model Creation Wizards
> category and press the Next > button.
>
> here I can't excute the point (2) because there isn't UML Model wizard
into
> my new Menu...
>
> That is the problem!
>
> What can I do? Uninstall and reinstall...
>
> Patrick
>
> James Bruck wrote:
>
> > Hi Patrick,
> >
> >
> > Articles can be found here http://wiki.eclipse.org/index.php/MDT-UML2
> >
> > You can create a .uml model through...
> >
> > File > New > Other ... > Example EMF Model Creation Wizards > UML model.
> > Once you've created your model, you can see the "UML Menu" item.
> >
> > - James.
> >
> >
> > "Patrick Gelin" <patrick.gelin@free.fr> wrote in message
> > news:eubbgf$lj0$1@utils.eclipse.org...
> >> Hi James,
> >>
> >> I can't create a UML model because there is no menu about that and I
> >> can't find any help documentation into eclipse about the UML module...
> >> What I
> > can
> >> see is only into "Manage Configuration" and property, something like
> >> this:
> >>
> >> UML2 Runtime + End-User Tools 2.1.0.v200702222305
> >>
> >> Identifier: org.eclipse.uml2
> >>
> >> Provider Eclipse.org
> >>
> >> Size: O KB
> >>
> >> The size is very small, isn't it?
> >>
> >> I'm really asking myself about the installation of the module. Is it
> >> possible to uninstall simply and retry to install an other way?
> >>
> >> Patrick
> >>
> >> James Bruck wrote:
> >>
> >> > Hi Patrick,
> >> >
> >> > Did you create a uml model? Did you read the "getting started"
> > articles?
> >> >
> >> > Cheers,
> >> >
> >> > - James.
> >> >
> >>
>
Re: Installing uml2... [message #603270 is a reply to message #471927] Tue, 27 March 2007 18:46 Go to previous message
Eclipse UserFriend
Originally posted by: patrick.gelin.free.fr

I said myself, may be you had to install UML2 TOOLS. So I dit it's the
same problem. I verifier with md5sum the UML2 package I downloaded, and
it's ok, the the problem is not here. I'm ok to reinstall it but I think
nothing will change. Do you know a dialog box where I can see error log or
something like that about plugin installation?

Patrick
Re: Installing uml2... [message #603272 is a reply to message #471931] Tue, 27 March 2007 19:06 Go to previous message
Andy Evans is currently offline Andy EvansFriend
Messages: 61
Registered: July 2009
Member
Patrick,

Do you have the EMF Wizards missing as well. If so, we got hit by
the fact that Eclipse M5 was running Java 1.4.2, but actually needs 1.5.
Deleting 1.4.2 did the trick.

Andy

"Patrick Gelin" <patrick.gelin@free.fr> wrote in message
news:pan.2007.03.27.18.46.07.959425@free.fr...
>I said myself, may be you had to install UML2 TOOLS. So I dit it's the
> same problem. I verifier with md5sum the UML2 package I downloaded, and
> it's ok, the the problem is not here. I'm ok to reinstall it but I think
> nothing will change. Do you know a dialog box where I can see error log or
> something like that about plugin installation?
>
> Patrick
Re: Installing uml2... [message #604044 is a reply to message #471934] Wed, 28 March 2007 06:29 Go to previous message
Eclipse UserFriend
Originally posted by: patrick.gelin.free.fr

This is the VM i'm using: j2sdk1.4.2_13
About the EMF wizard I can say it is missing too.This is what I can see
into the choice of wizard when I select 'new':

class
- interface
- java Project
- Java Project from existing Ant Buildfile
- Plug in project
- General (folder)
- CVS (folder)
- Java (folder)
- Plug in Development (folder)
- Server (folder)
- User Assistance (folder)
- Examples (folder)

About the example folder it contain wizard of UML2 TOOLS I installed at
last. The folders it contain are:
- EMFT Query Plug-ins
- EMFT Transaction Plug-ins
- EMFT Validation Plug-ins
- GEF
- GEF Plug-ins
- GMF Plug-ins

That's all! nothing about EMF or UML... So you think I've got a bad
Virtual Machine... This is my $JAVA_HOME=/opt/j2sdk1.4.2_13/jre. What can
I do? Change the virtual machine to 1.5?

Patrick



Le Tue, 27 Mar 2007 20:06:44 +0100, ase a écrit :

> Patrick,
>
> Do you have the EMF Wizards missing as well. If so, we got hit by
> the fact that Eclipse M5 was running Java 1.4.2, but actually needs 1.5.
> Deleting 1.4.2 did the trick.
>
> Andy
>
Re: Installing uml2... [message #604064 is a reply to message #471938] Wed, 28 March 2007 14:09 Go to previous message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1620
Registered: July 2009
Senior Member
Patrick,

You need a Java 5 VM to use EMF 2.3 and UML2 2.1.

Kenn

"Patrick Gelin" <patrick.gelin@free.fr> wrote in message
news:pan.2007.03.28.06.29.12.247315@free.fr...
> This is the VM i'm using: j2sdk1.4.2_13
> About the EMF wizard I can say it is missing too.This is what I can see
> into the choice of wizard when I select 'new':
>
> class
> - interface
> - java Project
> - Java Project from existing Ant Buildfile
> - Plug in project
> - General (folder)
> - CVS (folder)
> - Java (folder)
> - Plug in Development (folder)
> - Server (folder)
> - User Assistance (folder)
> - Examples (folder)
>
> About the example folder it contain wizard of UML2 TOOLS I installed at
> last. The folders it contain are:
> - EMFT Query Plug-ins
> - EMFT Transaction Plug-ins
> - EMFT Validation Plug-ins
> - GEF
> - GEF Plug-ins
> - GMF Plug-ins
>
> That's all! nothing about EMF or UML... So you think I've got a bad
> Virtual Machine... This is my $JAVA_HOME=/opt/j2sdk1.4.2_13/jre. What can
> I do? Change the virtual machine to 1.5?
>
> Patrick
>
>
>
> Le Tue, 27 Mar 2007 20:06:44 +0100, ase a
Re: Installing uml2... [message #604076 is a reply to message #471952] Wed, 28 March 2007 15:11 Go to previous message
Eclipse UserFriend
Originally posted by: patrick.gelin.free.fr

Kenn,

ok this is my JAVA_HOME:
JAVA_HOME=/opt/jre1.5.0_11

But the problem is the same.
- Is it possible, into Eclipse, to see if it use the good jre...
- Do you think I have to delete UML plugin and reinstall it?

Patrick

Le Wed, 28 Mar 2007 10:09:44 -0400, Kenn Hussey a écrit :

> Patrick,
>
> You need a Java 5 VM to use EMF 2.3 and UML2 2.1.
>
> Kenn
>
Re: Installing uml2... [message #604086 is a reply to message #471952] Wed, 28 March 2007 15:36 Go to previous message
Eclipse UserFriend
Originally posted by: patrick.gelin.free.fr

Ok, I've found the solution!

The problem is that the JAVA_HOME variable into my .bashrc is not take
into account. Alternatives defined the java command as
/opt/j2sdk1.4.2_13/... so I have to redefined it as /opt/jre1.5.0_11/...

Thank you everybody for your help.

Have a good day!

Patrick
Previous Topic:WrappedException: feature eGenericType not found while loading model
Next Topic:Can enumerations specialize primitive types ?
Goto Forum:
  


Current Time: Thu Apr 02 23:43:28 GMT 2020

Powered by FUDForum. Page generated in 0.03002 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top