Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » pde build problem with exported package in another plugin
pde build problem with exported package in another plugin [message #47640] Fri, 20 February 2009 05:12
zubin Missing name is currently offline zubin Missing nameFriend
Messages: 32
Registered: July 2009
Member
For example, I have two plugins, first plugin has its own package, source
files and other jar(normal java jar file, not a eclipse plugin) files;
another plugin uses classes in plugin and classes of jar files that in
first plugin. I exported the required packaged that used in 2nd plugin in
runtime tab of plugin-mf editor. Everything works fine in eclipse, I can
export both plugins without any problem from ide.

The automatic pde build works smoothly for first plugin. The problem is
the 2nd plugin, while doing the pde build for 2nd plugin, the classes in
1st plugin are not found. I have copied both plugins and features under
plugin and feature folders.

How can I solve this problem. thanks
Previous Topic:To test my plugin I need to remove the singleton
Next Topic:pde build problem with exported package in another plugin
Goto Forum:
  


Current Time: Mon Jun 14 18:17:12 GMT 2021

Powered by FUDForum. Page generated in 0.02083 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top