Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » MS Office 2003 task pane
MS Office 2003 task pane [message #465996] Wed, 28 December 2005 13:33 Go to next message
Rahul Gudla is currently offline Rahul GudlaFriend
Messages: 17
Registered: July 2009
Junior Member
Hi

I was opening a MS Word 2003 document in Eclipse 3.1. The Word doc has
Smart Document schema attached.

The inplace editor in Eclipse does not show the task pane of MS Word. It
should have shown up by default since there are smart doc schemas
attached to the document. Even if while the Word editor is active, I do
a View -> Task Pane, the task pane does not open. Is there a particular
reason why?

After a random set of actions, somehow when I switched to another
application and got back to Eclipse, there was this grey area beside the
word page in the editor where the task pane is normally placed in the
layout. Even then View->TaskPane did not open the pane. I did a right
click on the Word doc in the editor and chose Translate menu option. Now
the task pane has opened. But unfortunately the task pane does not
provide all the task pane options that I see in a normal Word application.

Kindly let me know if there are any technical reasons for the above
behavior. As in, is it expected etc...

Overall, the OLE support does not seem to have improved much from
Eclipse 2.1 to Eclipse 3.1. Am I right?

Is there a plan to go further than this? As in, if I drag a MS Word doc
into IE application, I get complete Word LnF. Would Eclipse platform
support OLE to that extent?

thx a bunch in advance

Rahul.
Re: MS Office 2003 task pane [message #466007 is a reply to message #465996] Wed, 28 December 2005 19:09 Go to previous message
Daniel Spiewak is currently offline Daniel SpiewakFriend
Messages: 263
Registered: July 2009
Senior Member
OLE support hasn't changed really since 2.1, you're right. It's not a terribly high priority considering how little it's used in Eclipse (office docs, etc on windows and nil on other platforms). If you're doing something as complicated as a Smart Schema, I would suggest that you open the doc in a full blown instance of Word rather than within an OLE control embedded within Eclipse. As to the weird behavior, it's probably something to do with M$'s Word OLE control doing something flakey. Eclipse doesn't have anything to do with the internals of how that works.

As to dragging a word doc to Eclipse and getting a full instance, I would guess that the behavior can be changed in File Associations. However, I honestly don't know. I've never used Eclipse like that before. Try File -> Open File... and see what happens.
Previous Topic:TreeViewer inline editing
Next Topic:Text widget which could display large text document
Goto Forum:
  


Current Time: Mon Jun 24 12:18:53 GMT 2019

Powered by FUDForum. Page generated in 0.03464 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top