Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » IBM JDK required for -compilelibs?
IBM JDK required for -compilelibs? [message #461327] Tue, 20 September 2005 21:11 Go to next message
Ian Pilcher is currently offline Ian PilcherFriend
Messages: 7
Registered: July 2009
Junior Member
I am trying to build Eclipse (Linux, Gtk, IA32) with Sun's 1.5.0 JDK.
The build fails while building the SWT library, apparently because it
is hardcoded to look for libjawt.so in $JAVA_HOME/jre/bin. That's where
IBM JDKs put it, but Sun puts it in $JAVA_HOME/jre/lib/i386.

Am I stuck using an IBM JDK, or is there a way to specifiy an alternate
location?

Thanks!

--
============================================================ ============
Ian Pilcher i.pilcher@comcast.net
============================================================ ============
Re: IBM JDK required for -compilelibs? [message #461365 is a reply to message #461327] Wed, 21 September 2005 13:24 Go to previous message
Kim Moir is currently offline Kim MoirFriend
Messages: 39
Registered: July 2009
Member
The platform team doesn't build this architecture as part of the build.
Intel contributes Linux-gtk-ia64 builds to the eclipse platform
project. If you have a patch for the source build scripts to support
this architecture and changes needed for your vm, please open a bug.

Kim

Ian Pilcher wrote:
> I am trying to build Eclipse (Linux, Gtk, IA32) with Sun's 1.5.0 JDK.
> The build fails while building the SWT library, apparently because it
> is hardcoded to look for libjawt.so in $JAVA_HOME/jre/bin. That's where
> IBM JDKs put it, but Sun puts it in $JAVA_HOME/jre/lib/i386.
>
> Am I stuck using an IBM JDK, or is there a way to specifiy an alternate
> location?
>
> Thanks!
>
Previous Topic:Program.findProgram("pdf"); does not find a PDF program
Next Topic:Animation in SWT
Goto Forum:
  


Current Time: Mon Sep 16 12:08:13 GMT 2019

Powered by FUDForum. Page generated in 0.01266 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top