Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » quick fix only suggest to require bundle
quick fix only suggest to require bundle [message #46474] Wed, 11 February 2009 07:37 Go to next message
Ittay  is currently offline Ittay Friend
Messages: 15
Registered: July 2009
Junior Member
Hi,

If in a class of mine I have an import for a package not imported in the
manifest, then quick-fix only suggests to add the bundle containing the
package as a required bundle, and doesn't offer to simply import the
package. I have to open the manifest editor and add the package to the
imported packages. How can this be fixed?

Also, when completing class names, I get only classes in packages that
were already imported. If I type the full class name, then Ctrl+M adds the
proper import declaration (but then doesn't add the packages to the
manifest imports). Can I get the class name completion to look in all
available bundles? Can it add the import automatically to the manifest?

(Using eclipse 3.4.1)

Thank you,
Ittay
Re: quick fix only suggest to require bundle [message #46505 is a reply to message #46474] Wed, 11 February 2009 07:46 Go to previous message
Ittay  is currently offline Ittay Friend
Messages: 15
Registered: July 2009
Junior Member
I also see that if I let eclipse organize the manifest, it removes
imported packages that are indirectly needed. which then creates errors in
many classes in the plugin (which are very tedious to fix because of what
I wrote in the previous post)

Ittay
Re: quick fix only suggest to require bundle [message #591829 is a reply to message #46474] Wed, 11 February 2009 07:46 Go to previous message
Ittay  is currently offline Ittay Friend
Messages: 15
Registered: July 2009
Junior Member
I also see that if I let eclipse organize the manifest, it removes
imported packages that are indirectly needed. which then creates errors in
many classes in the plugin (which are very tedious to fix because of what
I wrote in the previous post)

Ittay
Previous Topic:quick fix only suggest to require bundle
Next Topic:How add "Show In" context menu for a view?
Goto Forum:
  


Current Time: Fri Jun 25 08:16:13 GMT 2021

Powered by FUDForum. Page generated in 0.01738 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top