Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Problem of TableCursor and Multi-selection
Problem of TableCursor and Multi-selection [message #454164] Mon, 18 April 2005 16:06
Ellen Li is currently offline Ellen LiFriend
Messages: 6
Registered: July 2009
Junior Member
I download Sniper96 (navigate a table cells with arrow keys) from
http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.swt.sni ppets/src/org/eclipse/swt/snippets/Snippet96.java?rev=HEAD&a mp;content-type=text/vnd.viewcvs-markup

It works except for multi-selection. Anybody has seen this and has idea
how to correct it? Thanks so much for any input.

Here are details of the problem:
1) when I click on first row with one row selection------- OK
cell 0 0 cell 0 1 cell 0 2 <---- cursor on "cell 0 0", the
row's selected


2) after I clicked twice arrow-down key, the cursor moved to row 3 with
one row selection --- OK

cell 0 0 cell 0 1 cell 0 2
cell 1 0 cell 1 1 cell 1 2
cell 2 0 cell 2 1 cell 2 2 <---- cursor on "cell 2 0", the
row's selected

3) then I clicked shift+arrow-down key together ------------ WRONG
expected result: only row 3 and 4 selected (cell 2 * and cell 3 *)
actually result: row 1 to 4 selected ( 4 rows).

cell 0 0 cell 0 1 cell 0 2 <-|
cell 1 0 cell 1 1 cell 1 2 <-|
cell 2 0 cell 2 1 cell 2 2 <-|
cell 3 0 cell 3 1 cell 3 2 <-| <-- cursor on "cell 0 0", 4
rows selected
Previous Topic:Display RTF
Next Topic:icons in texteditor
Goto Forum:
  


Current Time: Thu Feb 25 08:45:08 GMT 2021

Powered by FUDForum. Page generated in 0.01834 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top